From 00412f60d4556598874fc84c4cbae601a1c97e19 Mon Sep 17 00:00:00 2001
From: Chris Aniszczyk <zx@gentoo.org>
Date: Tue, 24 Feb 2004 20:47:39 +0000
Subject: Version bump, clean up, closes #42748

---
 dev-java/commons-httpclient/Manifest               |  6 ++---
 .../commons-httpclient-2.0.ebuild                  | 28 +++++++++++++++++++
 .../commons-httpclient-2.0_alpha3.ebuild           | 31 ----------------------
 .../files/digest-commons-httpclient-2.0            |  1 +
 .../files/digest-commons-httpclient-2.0_alpha3     |  2 --
 5 files changed, 32 insertions(+), 36 deletions(-)
 create mode 100644 dev-java/commons-httpclient/commons-httpclient-2.0.ebuild
 delete mode 100644 dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild
 create mode 100644 dev-java/commons-httpclient/files/digest-commons-httpclient-2.0
 delete mode 100644 dev-java/commons-httpclient/files/digest-commons-httpclient-2.0_alpha3

(limited to 'dev-java')

diff --git a/dev-java/commons-httpclient/Manifest b/dev-java/commons-httpclient/Manifest
index be29d0ab1f8f..4a42e52f9c22 100644
--- a/dev-java/commons-httpclient/Manifest
+++ b/dev-java/commons-httpclient/Manifest
@@ -1,4 +1,4 @@
-MD5 cb904e99a7e7db25182f90e200bdf6eb commons-httpclient-2.0_alpha3.ebuild 1052
-MD5 40c817c8d6c0428d226c77d16272d312 ChangeLog 659
+MD5 81679baea28d92fd5fbca71c2dfb6986 commons-httpclient-2.0.ebuild 981
+MD5 0034b5497862821a22cdf1cd594a14a6 ChangeLog 658
 MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
-MD5 db843fa6f23a0dea629c7b17517612dd files/digest-commons-httpclient-2.0_alpha3 159
+MD5 70dbd7a345c0a9f6a17998de0191f13e files/digest-commons-httpclient-2.0 79
diff --git a/dev-java/commons-httpclient/commons-httpclient-2.0.ebuild b/dev-java/commons-httpclient/commons-httpclient-2.0.ebuild
new file mode 100644
index 000000000000..15afcd37624f
--- /dev/null
+++ b/dev-java/commons-httpclient/commons-httpclient-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-2.0.ebuild,v 1.1 2004/02/24 20:47:39 zx Exp $
+
+inherit jakarta-commons
+
+MY_P=${P/_/-}
+
+DESCRIPTION="The Jakarta Commons HttpClient provides an efficient, up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations."
+HOMEPAGE="http://jakarta.apache.org/commons/httpclient/index.html"
+SRC_URI="mirror://apache/jakarta/commons/httpclient/source/${MY_P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+	>=dev-java/log4j-1.2.5
+	>=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc"
+IUSE="doc jikes junit"
+
+src_compile() {
+	jakarta-commons_src_compile myconf make
+
+	# UGLY HACK
+	mv ${S}/target/conf/MANIFEST.MF ${S}/target/classes/
+	cd ${S}/target/classes
+	zip -r ../${PN}-${PV}.jar org
+}
diff --git a/dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild b/dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild
deleted file mode 100644
index b15137823d4b..000000000000
--- a/dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-2.0_alpha3.ebuild,v 1.4 2003/07/11 21:41:48 aliz Exp $
-
-inherit jakarta-commons
-
-MY_P=${P/_/-}
-
-S="${WORKDIR}/httpclient"
-DESCRIPTION="The Jakarta Commons HttpClient provides an efficient, up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations."
-HOMEPAGE="http://jakarta.apache.org/commons/httpclient/index.html"
-SRC_URI="mirror://apache/jakarta/commons/httpclient/${MY_P}.zip"
-DEPEND=">=virtual/jdk-1.3
-	>=dev-java/log4j-1.2.5
-	>=dev-java/ant-1.4"
-RDEPEND=">=virtual/jdk-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="x86 ~ppc ~sparc"
-IUSE="doc jikes junit"
-
-src_compile() {
-
-	jakarta-commons_src_compile myconf make
-	use doc && jakarta-commons_src_compile makedoc
-
-	# UGLY HACK
-	mv ${S}/target/conf/MANIFEST.MF ${S}/target/classes/
-	cd ${S}/target/classes
-	zip -r ../${PN}-${PV}.jar org
-}
diff --git a/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0 b/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0
new file mode 100644
index 000000000000..6ad9c15703a0
--- /dev/null
+++ b/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0
@@ -0,0 +1 @@
+MD5 6bc428538d8299cc76b54186eed6adcd commons-httpclient-2.0-src.tar.gz 1427148
diff --git a/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0_alpha3 b/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0_alpha3
deleted file mode 100644
index 85b02520eab0..000000000000
--- a/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0_alpha3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 1aca692edac6ece439b890ea55032b85 /commons-httpclient-2.0_alpha3.ebuild 1083
-MD5 d668cc6b590ee1c2f5a533b41aa7fb89 commons-httpclient-2.0-alpha3.zip 1068445
-- 
cgit v1.2.3-65-gdbad