aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-03-02 08:55:26 +0100
committerLucio Sauer <watermanpaint@posteo.net>2024-03-02 08:55:26 +0100
commit8599e9b6d792226a47a93d3ccd9d6f211d8f85f6 (patch)
tree0129acce386c86f68f8f54673e33619c81888859
parentnet-p2p/dogecoin-qt: 1.14.7 add keyword for amd64 (diff)
downloadguru-8599e9b6d792226a47a93d3ccd9d6f211d8f85f6.tar.gz
guru-8599e9b6d792226a47a93d3ccd9d6f211d8f85f6.tar.bz2
guru-8599e9b6d792226a47a93d3ccd9d6f211d8f85f6.zip
media-libs/dr_mp3: fetch the 0.6.39 commit instead of the 0.6.38 one...
Apply fix to generate documentation proposed in https://github.com/gentoo/guru/commit/b88d3ed0965aeae7ff98e453e6216e92eaea2f3c#r134692400 Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
-rw-r--r--media-libs/dr_mp3/Manifest2
-rw-r--r--media-libs/dr_mp3/dr_mp3-0.6.39-r1.ebuild60
2 files changed, 61 insertions, 1 deletions
diff --git a/media-libs/dr_mp3/Manifest b/media-libs/dr_mp3/Manifest
index 57e90a036..49d19c319 100644
--- a/media-libs/dr_mp3/Manifest
+++ b/media-libs/dr_mp3/Manifest
@@ -1 +1 @@
-DIST dr_mp3-0.6.39.gh.tar.gz 518478 BLAKE2B 4ef68a7ba24b84d5a3c87271d399b7abe9d367137d34b68f0533414f968315bafa59fc8ae6e9d40b6d82542060420e821c47ee3337fbd1589fceb0d0aded129f SHA512 2aa595a926bf72c56c3012fa7ea13ac7141952d1dc454f7135674286ba0df900554121624e7885fb242104c4bf0598826ed36952f591055033d419199a6b66fc
+DIST dr_mp3-0.6.39.gh.tar.gz 518741 BLAKE2B 4ce05d125597605a0274216e95c5b76754a04ebb363234f262f65fb4f0352cd58008ef9ac816ba13fc6386d4673c677d387e18fa5925d55c63308a63ec0260c1 SHA512 3bbdba77abc321eddd5e43d2bae778b220565331ff3d8cee9c4b82baf1aacaa6a6d6ac440c562c4f32feac884963364409016db3d04833f86ae5ee4b324e3c2f
diff --git a/media-libs/dr_mp3/dr_mp3-0.6.39-r1.ebuild b/media-libs/dr_mp3/dr_mp3-0.6.39-r1.ebuild
new file mode 100644
index 000000000..7d5c5d0bf
--- /dev/null
+++ b/media-libs/dr_mp3/dr_mp3-0.6.39-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="Single-header MP3 audio decoder library"
+HOMEPAGE="https://github.com/mackron/dr_libs/"
+COMMIT="da35f9d6c7374a95353fd1df1d394d44ab66cf01"
+SRC_URI="https://github.com/mackron/dr_libs/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+LICENSE="|| ( MIT-0 public-domain )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/dr_libs-${COMMIT}"
+
+# Unfortunately, the only other test is interactive.
+TESTCASES=(
+ dr_mp3_test_0.c
+)
+
+src_prepare() {
+ sed 's/Introducation/Introduction/' -i dr_mp3.h || die
+ awk '/Introduction/,/\*\//' dr_wav.h | sed '$d' > README.md
+ assert
+ awk '/REVISION HISTORY/,/\*\//' dr_wav.h | sed '$d' > CHANGELOG
+ assert
+ default
+}
+
+src_compile() {
+ if use test; then
+ local MY_{CC,BUILD}
+ MY_CC=$(tc-getCC)
+
+ pushd tests > /dev/null || die
+ for tcase in ${TESTCASES[@]}; do
+ MY_BUILD="${MY_CC} mp3/${tcase} -o bin/${tcase} ${CFLAGS} ${CPPFLAGS}"
+ edo ${MY_BUILD}
+ done
+ popd || die
+ fi
+}
+
+src_test() {
+ pushd tests > /dev/null || die
+ for tcase in ${TESTCASES[@]}; do
+ edo bin/${tcase}
+ done
+ popd || die
+}
+
+src_install() {
+ einstalldocs
+ doheader dr_mp3.h
+}