aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/pulsar-bin/Manifest2
-rw-r--r--app-editors/pulsar-bin/pulsar-bin-1.120.0.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/app-editors/pulsar-bin/Manifest b/app-editors/pulsar-bin/Manifest
index 84bf2b897..60cc2d026 100644
--- a/app-editors/pulsar-bin/Manifest
+++ b/app-editors/pulsar-bin/Manifest
@@ -2,3 +2,5 @@ DIST pulsar-bin-1.118.0-amd64.tar.gz 223330647 BLAKE2B c3915aafae95e541688c56a4f
DIST pulsar-bin-1.118.0-arm64.tar.gz 218245520 BLAKE2B 2614a029a9b9ec4d7cc68e957597f925f95c32a908181f9d8d8a338adf6f051d2a8093712102367ef000230370b43722a18b2baee5818ccdf52d4e3414eac78d SHA512 b66a2790cd2fdd831baa905943a4726b6f82cd24c755bc51c87ae17f2248d819ea760effa41acb7ef675da7f85223d6efadfa732fa43325f134a9b0efebb7cbe
DIST pulsar-bin-1.119.0-amd64.tar.gz 223426238 BLAKE2B a12ca733ca1a6053b899badf38a1f9d19ed22065646a42d36466740f0c277308edbb07032ef899681279ecdee53b3d1517ce5b880efc1bb2ccbe7dc69ee73c86 SHA512 e25c0e148ce5d5957ae76457016d95951a89400605c3ec3b930f956d7144a906a50faf4c126d44557831ef7bb2c3cc251fd6f29e7257461f1699ff26f08ccf0b
DIST pulsar-bin-1.119.0-arm64.tar.gz 218339722 BLAKE2B 8adaa5b41f909c539cf56035bc05220353b657329b4e87ab9d85e6cf8cb1557e1149a6278d9eaa721830f178c82e33716d90eabd521cc522e8ae38d2c978b45d SHA512 59bed4cbce00b757505c69ca759437db1602b1355054402fa0e836949dd8ad655e6191bd24e6edda6c1a38a5fa413d3677c9ebb0de335d868b7c0a59eead82db
+DIST pulsar-bin-1.120.0-amd64.tar.gz 224070958 BLAKE2B 33b91b4c4d36bff9564c5e154090472e78c1188bb8baac41019c2727ed7f1079c0cb37e8d18bdd6691ddbf8eb316c74d91d7cd04de5e1a6b73f88ed838d56302 SHA512 57eb05002be85fae3b80a34b7ad170439ad2ca09cea7162e0482b39d611bc4248ff0b7b979f1a6dfe6ddfa9fec738e2d3f3015ae218ef26c7078694cb7d4b5b9
+DIST pulsar-bin-1.120.0-arm64.tar.gz 218976256 BLAKE2B 39b4bc0ee83e02f65a40b457c6ae5583e1f43d807ce99c911f448e62427ffc7fead085afb0d5593f0c905b2557228d96f39c641a49afa79cd8bcfb171e0b30a0 SHA512 8dea8c099f1b39d49a2f5455fda875df11138b14e085e2c3833e67a723f352ff1b6d3b953a8626129f0e169a2f974015f8e9bcc837ee093c5bda464e0c680359
diff --git a/app-editors/pulsar-bin/pulsar-bin-1.120.0.ebuild b/app-editors/pulsar-bin/pulsar-bin-1.120.0.ebuild
new file mode 100644
index 000000000..fdc35e6ee
--- /dev/null
+++ b/app-editors/pulsar-bin/pulsar-bin-1.120.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="A Community-led Hyper-Hackable Text Editor"
+HOMEPAGE="https://pulsar-edit.dev/"
+
+ur=https://github.com/pulsar-edit/pulsar/releases/download
+SRC_URI="
+ amd64? ( ${ur}/v${PV}/Linux.pulsar-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm64? ( ${ur}/v${PV}/ARM.Linux.pulsar-${PV}-arm64.tar.gz -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}/pulsar-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm64"
+
+# binary package; no tests available
+RESTRICT="test"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/nspr
+ app-crypt/libsecret
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nss
+ dev-libs/openssl-compat
+ dev-vcs/git
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3[X]
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libxshmfence
+ x11-libs/libXrandr
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Pulsar/*"
+QA_PRESTRIPPED="opt/Pulsar/resources/*" # Files are already stripped
+
+src_unpack(){
+ default
+
+ if use arm64; then
+ mv "pulsar-${PV}-arm64" "pulsar-${PV}" || die
+ fi
+}
+
+src_prepare(){
+ default
+
+ # We do not install licenses
+ rm resources/LICENSE.md || die "Failed to remove LICENSE"
+}
+
+src_install(){
+ dodir /opt/Pulsar
+ mv "${S}"/* "${ED}"/opt/Pulsar
+
+ dosym -r /opt/Pulsar/resources/pulsar.sh /usr/bin/pulsar
+
+ # Bug #906939
+ if use amd64; then
+ rm "${ED}"/opt/Pulsar/resources/app.asar.unpacked/node_modules/tree-sitter-bash/build/node_gyp_bins/python3 || die
+ rmdir "${ED}"/opt/Pulsar/resources/app.asar.unpacked/node_modules/tree-sitter-bash/build/node_gyp_bins || die
+ fi
+
+ doicon "${ED}"/opt/Pulsar/resources/pulsar.png
+ make_desktop_entry "/usr/bin/pulsar %F" "Pulsar" "pulsar" \
+ "GNOME;GTK;Utility;TextEditor;Development;" \
+ "GenericName=Text Editor\nStartupNotify=true\nStartupWMClass=pulsar\n" \
+ "MimeType=application/javascript;application/json;application/x-httpd-eruby;" \
+ "application/x-httpd-php;application/x-httpd-php3;application/x-httpd-php4;" \
+ "application/x-httpd-php5;application/x-ruby;application/x-bash;application/x-csh;" \
+ "application/x-sh;application/x-zsh;application/x-shellscript;application/x-sql;" \
+ "application/x-tcl;application/xhtml+xml;application/xml;application/xml-dtd;" \
+ "application/xslt+xml;text/coffeescript;text/css;text/html;text/plain;text/xml;" \
+ "text/xml-dtd;text/x-bash;text/x-c++;text/x-c++hdr;text/x-c++src;text/x-c;text/x-chdr;" \
+ "text/x-csh;text/x-csrc;text/x-dsrc;text/x-diff;text/x-go;text/x-java;text/x-java-source;" \
+ "text/x-makefile;text/x-markdown;text/x-objc;text/x-perl;text/x-php;text/x-python;" \
+ "text/x-ruby;text/x-sh;text/x-zsh;text/yaml;inode/directory"
+
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst(){
+ xdg_desktop_database_update
+
+ elog "To migrate configurations & saved state from Atom Editor, execute:"
+ elog " cp -a \$HOME/.atom \$HOME/.pulsar"
+ elog " cp -a \$HOME/.config/Atom \$HOME/.config/Pulsar"
+}