aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/tym/tym-3.5.0-r1.ebuild (renamed from x11-terms/tym/tym-3.5.0.ebuild)10
1 files changed, 10 insertions, 0 deletions
diff --git a/x11-terms/tym/tym-3.5.0.ebuild b/x11-terms/tym/tym-3.5.0-r1.ebuild
index 0b569696f..d04bc7d45 100644
--- a/x11-terms/tym/tym-3.5.0.ebuild
+++ b/x11-terms/tym/tym-3.5.0-r1.ebuild
@@ -29,6 +29,16 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+src_prepare() {
+ default
+ # see https://github.com/endaaman/tym/issues/115
+ sed -i '/^CFLAGS=""/d' "${S}"/configure.ac || die
+
+ # the categories provided by eclass do a better job than upstream, and
+ # having duplicate list of categories fails on QA
+ sed -i '/^Categories=.*$/d' "${S}"/tym-daemon.desktop "${S}"/tym.desktop || die
+}
+
src_configure() {
if [[ ${PV} == 9999 ]]; then
eautoreconf