aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/foot/foot-1.7.2.ebuild')
-rw-r--r--gui-apps/foot/foot-1.7.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/gui-apps/foot/foot-1.7.2.ebuild b/gui-apps/foot/foot-1.7.2.ebuild
deleted file mode 100644
index 765eecea4..000000000
--- a/gui-apps/foot/foot-1.7.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson xdg
-
-if [[ ${PV} != *9999* ]]; then
- SRC_URI="https://codeberg.org/dnkl/foot/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}"
-else
- inherit git-r3
- EGIT_REPO_URI="https://codeberg.org/dnkl/foot.git"
-fi
-
-DESCRIPTION="A fast, lightweight and minimalistic Wayland terminal emulator"
-HOMEPAGE="https://codeberg.org/dnkl/foot"
-LICENSE="MIT"
-SLOT="0"
-IUSE="ime"
-
-DEPEND="
- dev-libs/wayland
- media-libs/fcft
- media-libs/fontconfig
- media-libs/freetype
- x11-libs/libxkbcommon
- x11-libs/pixman
-"
-RDEPEND="
- ${DEPEND}
- gui-apps/foot-terminfo
-"
-BDEPEND="
- app-text/scdoc
- dev-libs/tllist
- dev-libs/wayland-protocols
- sys-libs/ncurses
-"
-
-src_configure() {
- local emesonargs=(
- $(meson_use ime)
- "-Dterminfo=disabled"
- "-Dwerror=false"
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}"
-}