aboutsummaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xva-img/Manifest1
-rw-r--r--sys-fs/xva-img/metadata.xml11
-rw-r--r--sys-fs/xva-img/xva-img-1.5.ebuild17
3 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/xva-img/Manifest b/sys-fs/xva-img/Manifest
new file mode 100644
index 000000000..25f19d5b6
--- /dev/null
+++ b/sys-fs/xva-img/Manifest
@@ -0,0 +1 @@
+DIST xva-img-1.5.tar.gz 15073 BLAKE2B bef7a48289f87c4f1b187c7f620dd69fc3606d2881674e9f1d3de5572b7e5012436d5cbb8406dd29ed9db353453ef4e537a9ca586c30cc7cd425265ce772243d SHA512 0d72c9e7f626c0c8f8d85e36c0810feef2448b68c144579b0dbc8983d6eadb4c1d887991d9bc05feb9be8814ea329737385a37404ee1a64797bec576843c394e
diff --git a/sys-fs/xva-img/metadata.xml b/sys-fs/xva-img/metadata.xml
new file mode 100644
index 000000000..b2678be4c
--- /dev/null
+++ b/sys-fs/xva-img/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev@pyl.onl</email>
+ <name>Zen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eriklax/xva-img</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/xva-img/xva-img-1.5.ebuild b/sys-fs/xva-img/xva-img-1.5.ebuild
new file mode 100644
index 000000000..b28afebef
--- /dev/null
+++ b/sys-fs/xva-img/xva-img-1.5.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="XVA virtual disk tool, supports exporting XVA to RAW."
+HOMEPAGE="https://github.com/eriklax/xva-img"
+SRC_URI="https://github.com/eriklax/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/xxhash"
+RDEPEND="${DEPEND}"