summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libevent')
-rw-r--r--dev-libs/libevent/libevent-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-libs/libevent/libevent-9999.ebuild b/dev-libs/libevent/libevent-9999.ebuild
index c807cd329fc7..f17897dfe4b1 100644
--- a/dev-libs/libevent/libevent-9999.ebuild
+++ b/dev-libs/libevent/libevent-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit autotools eutils git-r3 libtool multilib-minimal
+EAPI=6
+inherit autotools eutils git-r3 multilib-minimal
DESCRIPTION="A library to execute a function when a specific event occurs on a file descriptor"
HOMEPAGE="http://libevent.org/"
@@ -29,6 +29,7 @@ MULTILIB_WRAPPED_HEADERS=(
)
src_prepare() {
+ default
eautoreconf
}
@@ -48,10 +49,7 @@ multilib_src_configure() {
}
src_test() {
- # The test suite doesn't quite work (see bug #406801 for the latest
- # installment in a riveting series of reports).
- :
- # emake -C test check | tee "${T}"/tests
+ emake -C test check | tee "${T}"/tests
}
DOCS=( ChangeLog{,-1.4,-2.0} )