summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/protobuf-python')
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
index 8deb3225f653..cf83c9cb0fbd 100644
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
-DISTUTILS_USE_SETUPTOOLS="rdepend"
+DISTUTILS_USE_SETUPTOOLS="bdepend"
inherit distutils-r1
@@ -49,19 +49,12 @@ python_prepare_all() {
popd > /dev/null || die
distutils-r1_python_prepare_all
-
- sed -e "/^[[:space:]]*setup_requires = \['wheel'\],$/d" -i setup.py || die
}
python_configure_all() {
mydistutilsargs=(--cpp_implementation)
}
-python_compile() {
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
python_test() {
esetup.py test
}