summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/rdflib-4.2.2-r1.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/dev-python/rdflib/rdflib-4.2.2-r1.ebuild b/dev-python/rdflib/rdflib-4.2.2-r1.ebuild
index 6306fc0eacc7..448f91e6dd70 100644
--- a/dev-python/rdflib/rdflib-4.2.2-r1.ebuild
+++ b/dev-python/rdflib/rdflib-4.2.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="sqlite?,threads(+)"
# The usual required for tests
@@ -19,7 +19,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc berkdb examples mysql redland sqlite test"
+IUSE="doc berkdb examples redland sqlite test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -27,11 +27,6 @@ RDEPEND="
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
- mysql? (
- $(python_gen_cond_dep '
- dev-python/mysql-python[${PYTHON_USEDEP}]
- ' -2)
- )
redland? ( dev-libs/redland-bindings[python,${PYTHON_USEDEP}] )"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )