summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/Manifest1
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.2.0.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/rdiscount/Manifest b/dev-ruby/rdiscount/Manifest
index 5a9272230b94..a7b5ebf3aba9 100644
--- a/dev-ruby/rdiscount/Manifest
+++ b/dev-ruby/rdiscount/Manifest
@@ -1,2 +1,3 @@
DIST rdiscount-1.6.8.gem 53760 SHA256 a085178fc7d6372222af192bdc8aa8b6b24c8014f0c2a3c227a1c173f104d4df SHA512 c5322308dba7fae463fe93c6b2936f97392310bc866cbb4f3f359afb37110068859525427d15376312eb8be07657e50171f8bc0dcc52b6def88282180af48f58 WHIRLPOOL 89119f0434da74d8721d2c4044465215a8a7bed1fe194573b8a19295f4f752728a70b63f5345c7e0be5a135e6b3f4dd495801083984d7d47284ca083c1b9098c
DIST rdiscount-2.1.8.gem 67072 SHA256 1b1c2b8e3c2afd2993efa14e28f992d8b755441b17f3e2c102cf719341f29e6d SHA512 a5d674a02514cb37d7e3a73bcc9131b434f624115e03f1ef5cef3ec4a378bb961966ef20daf93279b40715dcd19a0b79ccc43405fbe4523ac298f3255dca83f3 WHIRLPOOL 02b46dbd4ec83156fab5c2d621edf8ed63840124c3b591265da9b97b95bb7eb4579446560073cacf866d5227b6088d7d181ca0a2c0b4b55a2add02cb3a24aea0
+DIST rdiscount-2.2.0.1.gem 68096 SHA256 a34f55937c84f390f979808c7002fd24ab1e8b0172c916b0563d5f03e6983bab SHA512 81a477782b9829ac5e68ab390ef00b7f470bb4bd84e86ce28dd9abbb71aab6fd17b67416078dd7d4e0fc7e0c8eb78250b7a71a2f24d2bd236e861cb445f9feb6 WHIRLPOOL 905c47ed7781f76edd2eedebbabf3591368b0fd9cb31d29b5ab250e0aa3d7e2f7e7e6ab4b2758b9fc62a63049bccddc140a6e9677e81c6042b88b55791e612c0
diff --git a/dev-ruby/rdiscount/rdiscount-2.2.0.1.ebuild b/dev-ruby/rdiscount/rdiscount-2.2.0.1.ebuild
new file mode 100644
index 000000000000..bf039ba2f02c
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.2.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="https://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext || die
+ cp ext/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}