summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/grande-KXL')
-rw-r--r--games-arcade/grande-KXL/grande-KXL-0.6-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-arcade/grande-KXL/grande-KXL-0.6-r1.ebuild b/games-arcade/grande-KXL/grande-KXL-0.6-r1.ebuild
new file mode 100644
index 000000000000..b256aa384205
--- /dev/null
+++ b/games-arcade/grande-KXL/grande-KXL-0.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="ZANAC type game"
+HOMEPAGE="http://triring.net/ps2linux/games/kxl/kxlgames.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/KXL"
+RDEPEND="${DEPEND}
+ media-fonts/font-adobe-100dpi
+"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-{configure.in,cflags}.patch
+ mv configure.{in,ac}
+ rm aclocal.m4
+ eautoreconf
+}
+
+src_install() {
+ dodir /var/lib
+ default
+ newicon src/bmp/boss1.bmp ${PN}.bmp
+ make_desktop_entry grande Grande /usr/share/pixmaps/${PN}.bmp
+}