summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/files/transmission-4.0.0-cmake-unused.patch33
-rw-r--r--net-p2p/transmission/transmission-4.0.0-r2.ebuild (renamed from net-p2p/transmission/transmission-4.0.0-r1.ebuild)7
-rw-r--r--net-p2p/transmission/transmission-9999.ebuild8
3 files changed, 38 insertions, 10 deletions
diff --git a/net-p2p/transmission/files/transmission-4.0.0-cmake-unused.patch b/net-p2p/transmission/files/transmission-4.0.0-cmake-unused.patch
new file mode 100644
index 000000000000..5fc3b5c1fcd7
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-4.0.0-cmake-unused.patch
@@ -0,0 +1,33 @@
+https://github.com/transmission/transmission/pull/4807
+
+From 2c54813738ae5f9a3e2f99ffb86ed0858a5b3760 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Fri, 10 Feb 2023 17:55:54 -0500
+Subject: [PATCH] cmake: pass --no-warn-unused-cli to child cmake process
+
+Hides a warning when building the dht library.
+
+CMake Warning:
+ Manually-specified variables were not used by the project:
+
+ CMAKE_CXX_FLAGS
+ CMAKE_INSTALL_LIBDIR
+---
+ cmake/TrMacros.cmake | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/cmake/TrMacros.cmake b/cmake/TrMacros.cmake
+index 4b84c0af9..46643ff76 100644
+--- a/cmake/TrMacros.cmake
++++ b/cmake/TrMacros.cmake
+@@ -168,6 +168,7 @@ macro(tr_add_external_auto_library ID DIRNAME LIBNAME)
+ PREFIX "${${ID}_PREFIX}"
+ CMAKE_ARGS
+ -Wno-dev # We don't want to be warned over unused variables
++ --no-warn-unused-cli
+ "-DCMAKE_TOOLCHAIN_FILE:PATH=${CMAKE_TOOLCHAIN_FILE}"
+ "-DCMAKE_USER_MAKE_RULES_OVERRIDE=${CMAKE_USER_MAKE_RULES_OVERRIDE}"
+ "-DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}"
+--
+2.39.1
+
diff --git a/net-p2p/transmission/transmission-4.0.0-r1.ebuild b/net-p2p/transmission/transmission-4.0.0-r2.ebuild
index 8fa84dfd5501..7001a005404d 100644
--- a/net-p2p/transmission/transmission-4.0.0-r1.ebuild
+++ b/net-p2p/transmission/transmission-4.0.0-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 2006-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake tmpfiles systemd xdg-utils
@@ -70,9 +70,10 @@ RDEPEND="${COMMON_DEPEND}
"
src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/transmission-4.0.0-cmake-unused.patch"
+ )
cmake_src_prepare
- # https://github.com/transmission/transmission/issues/3901
- rm -f libtransmission/version.h || die
}
src_configure() {
diff --git a/net-p2p/transmission/transmission-9999.ebuild b/net-p2p/transmission/transmission-9999.ebuild
index 8fa84dfd5501..741de5688e3b 100644
--- a/net-p2p/transmission/transmission-9999.ebuild
+++ b/net-p2p/transmission/transmission-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2006-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake tmpfiles systemd xdg-utils
@@ -69,12 +69,6 @@ RDEPEND="${COMMON_DEPEND}
${ACCT_DEPEND}
"
-src_prepare() {
- cmake_src_prepare
- # https://github.com/transmission/transmission/issues/3901
- rm -f libtransmission/version.h || die
-}
-
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DOCDIR=share/doc/${PF}