summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/mesa/files')
-rw-r--r--media-libs/mesa/files/0001-gallivm-Do-not-use-NoFramePointerElim-with-LLVM-3.7.patch49
-rw-r--r--media-libs/mesa/files/0002-gallivm-Workaround-LLVM-PR23628.patch48
-rw-r--r--media-libs/mesa/files/eselect-mesa.conf.9.239
-rw-r--r--media-libs/mesa/files/glx_ro_text_segm.patch28
-rw-r--r--media-libs/mesa/files/mesa-9.2-dont-require-llvm-for-r300.patch12
-rw-r--r--media-libs/mesa/files/mesa-9999-dont-require-llvm-for-r300.patch11
6 files changed, 0 insertions, 187 deletions
diff --git a/media-libs/mesa/files/0001-gallivm-Do-not-use-NoFramePointerElim-with-LLVM-3.7.patch b/media-libs/mesa/files/0001-gallivm-Do-not-use-NoFramePointerElim-with-LLVM-3.7.patch
deleted file mode 100644
index 90717f4..0000000
--- a/media-libs/mesa/files/0001-gallivm-Do-not-use-NoFramePointerElim-with-LLVM-3.7.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From b897aca66ad669fda0f6c4e7617ec51ca42823d8 Mon Sep 17 00:00:00 2001
-From: Vinson Lee <vlee@freedesktop.org>
-Date: Tue, 26 May 2015 22:18:28 -0700
-Subject: [PATCH 1/2] gallivm: Do not use NoFramePointerElim with LLVM 3.7.
-
-TargetOptions::NoFramePointerElim was removed in llvm-3.7.0svn r238244
-"Remove NoFramePointerElim and NoFramePointerElimOverride from
-TargetOptions and remove ExecutionEngine's dependence on CodeGen. NFC."
-
-Signed-off-by: Vinson Lee <vlee@freedesktop.org>
-Reviewed-by: Tom Stellard <thomas.stellard@amd.com>
----
- src/gallium/auxiliary/gallivm/lp_bld_debug.cpp | 2 ++
- src/gallium/auxiliary/gallivm/lp_bld_misc.cpp | 2 ++
- 2 files changed, 4 insertions(+)
-
-diff --git a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
-index be3e834..76c302f 100644
---- a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
-+++ b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
-@@ -277,8 +277,10 @@ disassemble(const void* func, llvm::raw_ostream & Out)
- options.StackAlignmentOverride = 4;
- #endif
- #if defined(DEBUG) || defined(PROFILE)
-+#if HAVE_LLVM < 0x0307
- options.NoFramePointerElim = true;
- #endif
-+#endif
- OwningPtr<TargetMachine> TM(T->createTargetMachine(Triple, sys::getHostCPUName(), "", options));
-
- /*
-diff --git a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
-index 5e8a634..ffed9e6 100644
---- a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
-+++ b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
-@@ -439,8 +439,10 @@ lp_build_create_jit_compiler_for_module(LLVMExecutionEngineRef *OutJIT,
- #if HAVE_LLVM < 0x0304
- options.NoFramePointerElimNonLeaf = true;
- #endif
-+#if HAVE_LLVM < 0x0307
- options.NoFramePointerElim = true;
- #endif
-+#endif
-
- builder.setEngineKind(EngineKind::JIT)
- .setErrorStr(&Error)
---
-2.4.0
-
diff --git a/media-libs/mesa/files/0002-gallivm-Workaround-LLVM-PR23628.patch b/media-libs/mesa/files/0002-gallivm-Workaround-LLVM-PR23628.patch
deleted file mode 100644
index 3dc2c81..0000000
--- a/media-libs/mesa/files/0002-gallivm-Workaround-LLVM-PR23628.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 025db80a8deb2358638a18d6c777721e288fdca8 Mon Sep 17 00:00:00 2001
-From: Jose Fonseca <jfonseca@vmware.com>
-Date: Thu, 28 May 2015 10:11:36 +0100
-Subject: [PATCH 2/2] gallivm: Workaround LLVM PR23628.
-
-Temporarily undefine DEBUG macro while including LLVM C++ headers,
-leveraging the push/pop_macro pragmas, which are supported both by GCC
-and MSVC.
-
-https://bugs.freedesktop.org/show_bug.cgi?id=90621
-
-Trivial.
----
- src/gallium/auxiliary/gallivm/lp_bld_misc.cpp | 11 +++++++++++
- 1 file changed, 11 insertions(+)
-
-diff --git a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
-index ffed9e6..5e25819 100644
---- a/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
-+++ b/src/gallium/auxiliary/gallivm/lp_bld_misc.cpp
-@@ -50,6 +50,12 @@
-
- #include <stddef.h>
-
-+// Workaround http://llvm.org/PR23628
-+#if HAVE_LLVM >= 0x0307
-+# pragma push_macro("DEBUG")
-+# undef DEBUG
-+#endif
-+
- #include <llvm-c/Core.h>
- #include <llvm-c/ExecutionEngine.h>
- #include <llvm/Target/TargetOptions.h>
-@@ -70,6 +76,11 @@
- #include <llvm/IR/Module.h>
- #include <llvm/Support/CBindingWrapping.h>
-
-+// Workaround http://llvm.org/PR23628
-+#if HAVE_LLVM >= 0x0307
-+# pragma pop_macro("DEBUG")
-+#endif
-+
- #include "pipe/p_config.h"
- #include "util/u_debug.h"
- #include "util/u_cpu_detect.h"
---
-2.4.0
-
diff --git a/media-libs/mesa/files/eselect-mesa.conf.9.2 b/media-libs/mesa/files/eselect-mesa.conf.9.2
deleted file mode 100644
index ff590f5..0000000
--- a/media-libs/mesa/files/eselect-mesa.conf.9.2
+++ /dev/null
@@ -1,39 +0,0 @@
-# mesa classic/gallium implementations in this release
-
-# Syntax description:
-# * MESA_IMPLEMENTATIONS contains a space-delimited list of switchable
-# classic/gallium implementations.
-# * MESA_DRIVERS is an associative array, for each member "foo" of
-# MESA_IMPLEMENTATIONS it contains the following elements:
-# foo,description - Human-readable description of the driver
-# foo,classicdriver - Filename of the classic driver
-# foo,galliumdriver - Filename of the gallium driver
-# foo,default - which of classic or gallium is chosen by default
-
-MESA_IMPLEMENTATIONS="i915 i965 r300 r600 sw"
-declare -A MESA_DRIVERS || die "MESA_DRIVERS already in environment and not associative."
-
-MESA_DRIVERS[i915,description]="i915 (Intel 915, 945)"
-MESA_DRIVERS[i915,classicdriver]="i915_dri.so"
-MESA_DRIVERS[i915,galliumdriver]="i915g_dri.so"
-MESA_DRIVERS[i915,default]="gallium"
-
-MESA_DRIVERS[i965,description]="i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)"
-MESA_DRIVERS[i965,classicdriver]="i965_dri.so"
-MESA_DRIVERS[i965,galliumdriver]="ilo_dri.so"
-MESA_DRIVERS[i965,default]="classic"
-
-MESA_DRIVERS[r300,description]="r300 (Radeon R300-R500)"
-MESA_DRIVERS[r300,classicdriver]="r300_dri.so"
-MESA_DRIVERS[r300,galliumdriver]="r300g_dri.so"
-MESA_DRIVERS[r300,default]="gallium"
-
-MESA_DRIVERS[r600,description]="r600 (Radeon R600-R700, Evergreen, Northern Islands)"
-MESA_DRIVERS[r600,classicdriver]="r600_dri.so"
-MESA_DRIVERS[r600,galliumdriver]="r600g_dri.so"
-MESA_DRIVERS[r600,default]="gallium"
-
-MESA_DRIVERS[sw,description]="sw (Software renderer)"
-MESA_DRIVERS[sw,classicdriver]="swrast_dri.so"
-MESA_DRIVERS[sw,galliumdriver]="swrastg_dri.so"
-MESA_DRIVERS[sw,default]="gallium"
diff --git a/media-libs/mesa/files/glx_ro_text_segm.patch b/media-libs/mesa/files/glx_ro_text_segm.patch
deleted file mode 100644
index 495b7dc..0000000
--- a/media-libs/mesa/files/glx_ro_text_segm.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-2011-02-09 Jeremy Huddleston <jeremyhu@freedesktop.org
-
- #240956
- * configure.ac add support to enable readonly test segment on x86
-
---- configure.ac.orig 2008-11-17 23:19:38.000000000 +0100
-+++ configure.ac 2008-11-17 23:20:17.000000000 +0100
-@@ -499,6 +499,20 @@
- enable_xcb=no
- fi
-
-+
-+dnl readonly text segment on x86 hardened platforms
-+AC_ARG_ENABLE([glx_rts],
-+ [AS_HELP_STRING([--enable-glx-rts],
-+ [on x86, use a readonly text segment for libGL @<:@default=disabled@:>@])],
-+ [enable_glx_rts="$enableval"],
-+ [enable_glx_rts=no])
-+if test "x$enable_glx_rts" = xyes; then
-+ DEFINES="$DEFINES -DGLX_X86_READONLY_TEXT"
-+else
-+ enable_glx_rts=no
-+fi
-+
-+
- dnl
- dnl libGL configuration per driver
- dnl
diff --git a/media-libs/mesa/files/mesa-9.2-dont-require-llvm-for-r300.patch b/media-libs/mesa/files/mesa-9.2-dont-require-llvm-for-r300.patch
deleted file mode 100644
index bd24787..0000000
--- a/media-libs/mesa/files/mesa-9.2-dont-require-llvm-for-r300.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 21a1986..94b2247 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1777,7 +1777,6 @@ if test "x$with_gallium_drivers" != x; then
- xr300)
- HAVE_GALLIUM_R300=yes
- PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
-- gallium_require_llvm "Gallium R300"
- GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r300"
- gallium_check_st "radeon/drm" "dri-r300" "" "" "xvmc-r300" "vdpau-r300"
- ;;
diff --git a/media-libs/mesa/files/mesa-9999-dont-require-llvm-for-r300.patch b/media-libs/mesa/files/mesa-9999-dont-require-llvm-for-r300.patch
deleted file mode 100644
index a85a3c1..0000000
--- a/media-libs/mesa/files/mesa-9999-dont-require-llvm-for-r300.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur a/configure.ac b/configure.ac
---- a/configure.ac 2014-03-03 04:05:33.110522943 +0100
-+++ b/configure.ac 2014-03-03 04:06:44.165518094 +0100
-@@ -1774,7 +1774,6 @@
- HAVE_GALLIUM_R300=yes
- PKG_CHECK_MODULES([RADEON], [libdrm_radeon >= $LIBDRM_RADEON_REQUIRED])
- gallium_require_drm_loader
-- gallium_require_llvm "Gallium R300"
- GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS r300"
- gallium_check_st "radeon/drm" "r300/dri" "" "" ""
- DRICOMMON_NEED_LIBDRM=yes