summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Mavrinac <mavrinac@gmail.com>2008-10-14 15:10:25 -0400
committerAaron Mavrinac <mavrinac@gmail.com>2008-10-14 15:10:25 -0400
commit8c8f674d283d69f72730b4abebd271baa3a60a24 (patch)
treeea9e5a673ea339513553f6b856f978241ccc3de7 /sci-libs
parentRemoved sci-libs/tina-libs ebuild. (diff)
downloadezod-8c8f674d283d69f72730b4abebd271baa3a60a24.tar.gz
ezod-8c8f674d283d69f72730b4abebd271baa3a60a24.tar.bz2
ezod-8c8f674d283d69f72730b4abebd271baa3a60a24.zip
Added sci-libs/pydsscc ebuild.
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pydsscc/ChangeLog11
-rw-r--r--sci-libs/pydsscc/Manifest3
-rw-r--r--sci-libs/pydsscc/metadata.xml13
-rw-r--r--sci-libs/pydsscc/pydsscc-0.2.0.ebuild24
-rw-r--r--sci-libs/pydsscc/pydsscc-9999.ebuild27
5 files changed, 78 insertions, 0 deletions
diff --git a/sci-libs/pydsscc/ChangeLog b/sci-libs/pydsscc/ChangeLog
new file mode 100644
index 0000000..d8862bb
--- /dev/null
+++ b/sci-libs/pydsscc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/pydsscc
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 14 Oct 2008; Aaron Mavrinac <mavrinac@gmail.com> pydsscc-9999.ebuild:
+ Git ebuild
+
+*pydsscc-0.2.0 (14 Oct 2008)
+
+ 14 Oct 2008; Aaron Mavrinac <mavrinac@gmail.com> pydsscc-0.2.0.ebuild:
+ Initial import
diff --git a/sci-libs/pydsscc/Manifest b/sci-libs/pydsscc/Manifest
new file mode 100644
index 0000000..7c601fd
--- /dev/null
+++ b/sci-libs/pydsscc/Manifest
@@ -0,0 +1,3 @@
+DIST pydsscc-0.2.0.tar.bz2 33280 RMD160 3ac20888e10b500f30ae51805beeb842fa693807 SHA1 ddbf021a803ca3b9a4d43c41d6ff88414ad9b16d SHA256 3c96f8e32a1ffbd3d728a6878c9d588c00a2e57a452ca03deaedc33ba46fad6c
+EBUILD pydsscc-0.2.0.ebuild 590 RMD160 de7da39fa123c47436330bfd948e4c815f81aaaf SHA1 b7b5ea11a23f9320c2c27d9f127e7d363b2ee467 SHA256 1ada739d896233d4f3bab409d7e266f74ba316f07c0342e30c031c5f14ce3ce9
+EBUILD pydsscc-9999.ebuild 614 RMD160 d624f0c0478e7c134171f82b4462882d0188937b SHA1 5a373662ff85b219df2653bdd170e3d408f89f10 SHA256 7c1d3b54f48e7cd739bd6845ab330dd15d67d584492a1ece7bf4210402a42128
diff --git a/sci-libs/pydsscc/metadata.xml b/sci-libs/pydsscc/metadata.xml
new file mode 100644
index 0000000..f31d987
--- /dev/null
+++ b/sci-libs/pydsscc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <name>Aaron Mavrinac</name>
+ <email>mavrinac@gmail.com</email>
+</maintainer>
+<longdescription lang="en">
+PyDSSCC is an implementation of a distributed calibration method for smart stereo camera networks.
+</longdescription>
+</pkgmetadata>
+
diff --git a/sci-libs/pydsscc/pydsscc-0.2.0.ebuild b/sci-libs/pydsscc/pydsscc-0.2.0.ebuild
new file mode 100644
index 0000000..04add7d
--- /dev/null
+++ b/sci-libs/pydsscc/pydsscc-0.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.4
+
+inherit distutils eutils
+
+DESCRIPTION="PyDSSCC - Calibration Software for Distributed Smart Stereo
+Cameras"
+HOMEPAGE="http://www.mavrinac.com/research/index.cgi?page=dssccalib"
+SRC_URI="http://www.mavrinac.com/research/files/dssccalib/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+IUSE=""
+
+RDEPEND="virtual/python
+ >=dev-python/numpy-1.0.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DOCS="AUTHORS COPYING LICENSE README TODO"
diff --git a/sci-libs/pydsscc/pydsscc-9999.ebuild b/sci-libs/pydsscc/pydsscc-9999.ebuild
new file mode 100644
index 0000000..94ec0ae
--- /dev/null
+++ b/sci-libs/pydsscc/pydsscc-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_PYTHON=2.4
+
+EGIT_REPO_URI="git://glorfindel.mavrinac.com/${PN}.git"
+EGIT_BRANCH="master"
+
+inherit distutils eutils git
+
+DESCRIPTION="PyDSSCC - Calibration Software for Distributed Smart Stereo
+Cameras"
+HOMEPAGE="http://www.mavrinac.com/research/index.cgi?page=dssccalib"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/python
+ >=dev-python/numpy-1.0.4"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DOCS="AUTHORS COPYING LICENSE README TODO"