summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@zonker.localdomain>2011-08-21 14:26:12 +0200
committerroot <root@zonker.localdomain>2011-08-21 14:26:12 +0200
commitc67f92b6d766cc0baf319e284208228667ef36f5 (patch)
tree71f0a5c7886f89024b5f41c95644e008041937a6
parentimport from svn (diff)
downloadmistafunk-c67f92b6d766cc0baf319e284208228667ef36f5.tar.gz
mistafunk-c67f92b6d766cc0baf319e284208228667ef36f5.tar.bz2
mistafunk-c67f92b6d766cc0baf319e284208228667ef36f5.zip
added alembic live ebuild, openmesh
-rw-r--r--media-gfx/openmesh/Manifest2
-rw-r--r--media-gfx/openmesh/openmesh-2.0.1.ebuild60
-rw-r--r--media-libs/alembic/alembic-9999.ebuild79
3 files changed, 141 insertions, 0 deletions
diff --git a/media-gfx/openmesh/Manifest b/media-gfx/openmesh/Manifest
new file mode 100644
index 0000000..6869ea4
--- /dev/null
+++ b/media-gfx/openmesh/Manifest
@@ -0,0 +1,2 @@
+DIST OpenMesh-2.0.1.tar.bz2 17586878 RMD160 82fa5904193b1042ad4c7ff1f49d08991c219f05 SHA1 ff2a5841f16a4ae280cef83f6893c27ad405dd69 SHA256 5aa92ad275b67c37480ab21ec1b901e56a9e2f1559b84195a7c5a0c74c294045
+EBUILD openmesh-2.0.1.ebuild 1623 RMD160 3f0f95e0d63065387b21b2fcfbbfa6891d2301af SHA1 d416ae0d637a42a030ca27d09f9b126326de038e SHA256 838541700e1cf8ad870f9c5688ea4d3b9452b8318022ed487bae51316696cab6
diff --git a/media-gfx/openmesh/openmesh-2.0.1.ebuild b/media-gfx/openmesh/openmesh-2.0.1.ebuild
new file mode 100644
index 0000000..4aa64ef
--- /dev/null
+++ b/media-gfx/openmesh/openmesh-2.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/openmesh/openmesh-2.0_rc5.ebuild,v 1.3 2011/04/05 14:18:20 jsbronder Exp $
+
+EAPI="3"
+inherit eutils cmake-utils
+
+MY_PN="OpenMesh"
+MY_PV="${PV/_rc/-RC}"
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+DESCRIPTION="A generic and efficient data structure for representing and manipulating polygonal meshes"
+HOMEPAGE="http://www.openmesh.org/"
+SRC_URI="http://openmesh.org/fileadmin/${PN}-files/${MY_PV/-RC/RC}/${MY_PN}-${MY_PV}.tar.bz2"
+
+# See COPYING.EXCEPTIONS
+LICENSE="LGPL-3 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4 debug static-libs"
+
+RDEPEND="qt4? ( x11-libs/qt-gui:4
+ x11-libs/qt-opengl:4
+ media-libs/freeglut )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Fix libdir and remove rpath.
+ cd "${S}"
+ sed -i \
+ -e "s|\(set (ACG_PROJECT_LIBDIR \"\).*|\1$(get_libdir)/\")|" \
+ -e "s|\(set (ACG_PROJECT_PLUGINDIR \"\)lib\(.*\)|\1$(get_libdir)\2|" \
+ -e "s|\(BUILD_WITH_INSTALL_RPATH \)1|\1 0|" \
+ -e "s|\(SKIP_BUILD_RPATH\) 0|\1 1|" \
+ -e '/^ *INSTALL_RPATH/d' \
+ cmake/ACGCommon.cmake || die
+}
+
+src_configure() {
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ append-cppflags -DNDEBUG
+ fi
+ mycmakeargs="$(cmake-utils_use_build "qt4" "APPS")"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if ! use static-libs; then
+ # No way to set this in the build system as of 2.0_rc5
+ rm -f "${D}"/usr/$(get_libdir)/*.a \
+ || die "Failed to remove static libraries."
+ fi
+ cd "${S}"
+ dodoc LICENSE/* README CHANGELOG || die
+}
diff --git a/media-libs/alembic/alembic-9999.ebuild b/media-libs/alembic/alembic-9999.ebuild
new file mode 100644
index 0000000..33ed591
--- /dev/null
+++ b/media-libs/alembic/alembic-9999.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# TODO: replace the alembic_bootstrap.py with proper gentoo methods (cmake eclass)
+# TODO: add tests, add help
+
+EAPI=2
+
+inherit eutils mercurial
+
+DESCRIPTION="Alembic is an open framework for storing and sharing 3D geometry data."
+HOMEPAGE="http://code.google.com/p/alembic"
+EHG_REPO_URI="https://code.google.com/p/alembic"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples doc"
+RDEPEND=""
+DEPEND=">=dev-util/cmake-2.8
+ >=dev-libs/boost-1.44[static-libs]
+ >=media-libs/ilmbase-1.0.1[static-libs]
+ >=sci-libs/hdf5-1.8.7[-mpi]
+ doc? ( >=app-doc/doxygen-1.7.3 )"
+
+TMPBUILD="${WORKDIR}/alembic-build"
+TMPINSTALL="${WORKDIR}/alembic-install"
+
+src_configure() {
+ mkdir ${TMPBUILD} && cd ${TMPBUILD}
+ S=${TMPBUILD}
+
+ python ${WORKDIR}/${P}/build/bootstrap/alembic_bootstrap.py \
+ --disable-prman --disable-maya --disable-arnold \
+ --hdf5_include_dir=/usr/include \
+ --hdf5_hdf5_library=/usr/lib/libhdf5.a \
+ --boost_include_dir=${LIBS}/boost_install/include \
+ --boost_thread_library=/usr/lib/libboost_thread-mt.a \
+ --zlib_include_dir=/usr/include \
+ --zlib_library=/usr/lib/libz.a \
+ --ilmbase_include_dir=/usr/include/OpenEXR \
+ --ilmbase_imath_library=/usr/lib/libImath.a \
+ .
+}
+
+src_compile() {
+ emake
+
+ if use examples; then
+ cd ${S}/examples
+ emake all
+ fi
+}
+
+src_install() {
+ mkdir ${TMPINSTALL}
+
+ cd ${S}
+ emake DESTDIR=${TMPINSTALL} install
+
+ dolib.a ${TMPINSTALL}/usr/local/alembic-1.0.0/lib/static/*.a
+ cp -r ${TMPINSTALL}/usr/local/alembic-1.0.0/include/Alembic ${D}/usr/include
+
+ if use examples; then
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcecho
+ dobin ${TMPBUILD}/examples/bin/AbcEcho/abcechobounds
+ dobin ${TMPBUILD}/examples/bin/AbcStitcher/abcstitcher
+ dobin ${TMPBUILD}/examples/bin/SimpleAbcViewer/SimpleAbcViewer
+ fi
+
+ dodoc ${WORKDIR}/${P}/{ACKNOWLEDGEMENTS,FEEDBACK,LICENSE,MANIFEST,NEWS,README}.txt
+
+ if use doc; then
+ cd ${WORKDIR}/${P}
+ doxygen
+ dohtml -r doc/html/*
+ fi
+}