summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-9999.ebuild')
-rw-r--r--www-client/firefox/firefox-9999.ebuild111
1 files changed, 4 insertions, 107 deletions
diff --git a/www-client/firefox/firefox-9999.ebuild b/www-client/firefox/firefox-9999.ebuild
index e098ee4..bac7ea3 100644
--- a/www-client/firefox/firefox-9999.ebuild
+++ b/www-client/firefox/firefox-9999.ebuild
@@ -1,27 +1,15 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="3"
+
inherit mozilla-scm
DESCRIPTION="Firefox Web Browser"
-HOMEPAGE="http://www.mozilla.com/firefox"
+HOMEPAGE="http://www.mozilla.com/en-US/firefox"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE=""
-
-DEPEND="
- webm? ( dev-lang/yasm )
- "
-
-SRC_URI=""
-S="${WORKDIR}/mozilla-central"
-
-QA_PRESTRIPPED="usr/$(get_libdir)/${PN}/firefox"
src_prepare() {
# Gentoo specific stuff
@@ -48,93 +36,7 @@ src_prepare() {
}
src_configure() {
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- ####################################
- #
- # mozconfig, CFLAGS and CXXFLAGS setup
- #
- ####################################
-
- mozconfig_init
- mozconfig_config
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
- mozconfig_annotate '' --enable-application=browser
- mozconfig_annotate '' --enable-official-branding
- mozconfig_annotate '' --disable-mailnews
- mozconfig_annotate '' --disable-crashreporter
- mozconfig_annotate '' --enable-image-encoder=all
- mozconfig_annotate '' --enable-canvas
- mozconfig_annotate 'gtk' --enable-default-toolkit=cairo-gtk2
-
- # Bug 60668: Galeon doesn't build without oji enabled, so enable it
- # regardless of java setting.
- mozconfig_annotate '' --enable-oji --enable-mathml
- mozconfig_annotate 'places' --enable-storage --enable-places
- mozconfig_annotate '' --enable-safe-browsing
-
- # System-wide install specs
- mozconfig_annotate '' --disable-installer
- mozconfig_annotate '' --disable-updater
- mozconfig_annotate '' --disable-strip
- mozconfig_annotate '' --disable-install-strip
-
- # Use system libraries
- mozconfig_annotate '' --enable-system-cairo
- mozconfig_annotate '' --enable-system-hunspell
- mozconfig_annotate '' --with-system-nspr --with-nspr-prefix="${EPREFIX}"/usr
- mozconfig_annotate '' --with-system-nss --with-nss-prefix="${EPREFIX}"/usr
- mozconfig_annotate '' --x-includes="${EPREFIX}"/usr/include --x-libraries="${EPREFIX}"/usr/$(get_libdir)
- mozconfig_annotate '' --with-system-bz2
- mozconfig_annotate '' --with-system-png
- if use webm ; then
- mozconfig_annotate '' --with-system-libvpx
- fi
- mozconfig_annotate '' --with-system-libxul
- mozconfig_annotate '' --with-libxul-sdk="${EPREFIX}"/usr/$(get_libdir)/xulrunner-devel-${MAJ_XUL_PV}
-
- mozconfig_use_enable ipc # +ipc, upstream default
- mozconfig_use_enable libnotify
- mozconfig_use_enable wifi necko-wifi
- mozconfig_use_enable alsa ogg
- mozconfig_use_enable alsa wave
- mozconfig_use_enable system-sqlite
- mozconfig_use_enable webm
-
- # NOTE: Uses internal copy of libvpx
- if use webm && ! use alsa; then
- ewarn "USE=webm needs USE=alsa, disabling WebM support."
- mozconfig_annotate '+webm -alsa' --disable-webm
- fi
-
- if use amd64 || use x86 || use arm || use sparc; then
- mozconfig_annotate '' --enable-tracejit
- fi
-
- # Other ff-specific settings
- mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
-
- # omni.jar breaks ff on xr
- mozconfig_annotate '' --enable-chrome-format=jar
-
- # Finalize and report settings
- mozconfig_final
-
- if [[ $(gcc-major-version) -lt 4 ]]; then
- append-cxxflags -fno-stack-protector
- fi
-
- ####################################
- #
- # Configure and build
- #
- ####################################
-
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" PYTHON="$(PYTHON)" econf
+ mozconfig_configure
}
src_install() {
@@ -146,9 +48,4 @@ src_install() {
# Plugins dir
dosym ../nsbrowser/plugins "${MOZILLA_FIVE_HOME}"/plugins \
|| die "failed to symlink"
-
- # very ugly hack to make firefox not sigbus on sparc
- use sparc && { sed -e 's/Firefox/FirefoxGentoo/g' \
- -i "${ED}/${MOZILLA_FIVE_HOME}/application.ini" || \
- die "sparc sed failed"; }
}