summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2011-02-12 16:09:00 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2011-02-12 16:09:00 +0000
commit005b11ebd0b2273ce9bfb0b48a31203d243006e3 (patch)
tree77250983a6da1f34d6636281e8e00f5c35be6379
parentstable x86, bug 354237 (diff)
downloadgentoo-2-005b11ebd0b2273ce9bfb0b48a31203d243006e3.tar.gz
gentoo-2-005b11ebd0b2273ce9bfb0b48a31203d243006e3.tar.bz2
gentoo-2-005b11ebd0b2273ce9bfb0b48a31203d243006e3.zip
Bumping to 4.5.1 and removing old version
(Portage version: 2.2.0_alpha23/cvs/Linux i686)
-rw-r--r--net-misc/strongswan/ChangeLog8
-rw-r--r--net-misc/strongswan/files/strongswan-4.5.0-dhcp_segfault.patch44
-rw-r--r--net-misc/strongswan/strongswan-4.5.1.ebuild (renamed from net-misc/strongswan/strongswan-4.5.0-r1.ebuild)6
3 files changed, 8 insertions, 50 deletions
diff --git a/net-misc/strongswan/ChangeLog b/net-misc/strongswan/ChangeLog
index 0b3c66c6b7a1..17d16331958c 100644
--- a/net-misc/strongswan/ChangeLog
+++ b/net-misc/strongswan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/strongswan
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/ChangeLog,v 1.86 2011/01/18 21:31:18 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/ChangeLog,v 1.87 2011/02/12 16:08:59 gurligebis Exp $
+
+*strongswan-4.5.1 (12 Feb 2011)
+
+ 12 Feb 2011; <gurligebis@gentoo.org> -strongswan-4.5.0-r1.ebuild,
+ -files/strongswan-4.5.0-dhcp_segfault.patch, +strongswan-4.5.1.ebuild:
+ Bumping to 4.5.1 and removing fix included in 4.5.1
*strongswan-4.5.0-r1 (18 Jan 2011)
diff --git a/net-misc/strongswan/files/strongswan-4.5.0-dhcp_segfault.patch b/net-misc/strongswan/files/strongswan-4.5.0-dhcp_segfault.patch
deleted file mode 100644
index 5d1965c358e7..000000000000
--- a/net-misc/strongswan/files/strongswan-4.5.0-dhcp_segfault.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From: Martin Willi <martin@revosec.ch>
-Date: Wed, 12 Jan 2011 14:17:08 +0000 (+0100)
-Subject: Fixed memory cleanup if no DHCP transaction found for an OFFER
-X-Git-Url: http://git.strongswan.org/strongswan.git/?p=strongswan.git;a=commitdiff_plain;h=9bac426bf3b9badf1c39d282e8d49881ffbe3142
-
-Fixed memory cleanup if no DHCP transaction found for an OFFER
----
-
-diff --git a/src/libcharon/plugins/dhcp/dhcp_socket.c b/src/libcharon/plugins/dhcp/dhcp_socket.c
-index e1e83d6..8851c1b 100644
---- a/src/libcharon/plugins/dhcp/dhcp_socket.c
-+++ b/src/libcharon/plugins/dhcp/dhcp_socket.c
-@@ -459,7 +459,7 @@ static void handle_offer(private_dhcp_socket_t *this, dhcp_t *dhcp, int optlen)
- {
- dhcp_transaction_t *transaction = NULL;
- enumerator_t *enumerator;
-- host_t *offer, *server;
-+ host_t *offer, *server = NULL;
-
- offer = host_create_from_chunk(AF_INET,
- chunk_from_thing(dhcp->your_address), 0);
-@@ -500,7 +500,7 @@ static void handle_offer(private_dhcp_socket_t *this, dhcp_t *dhcp, int optlen)
- chunk_create((char*)&option->data[pos], 4));
- }
- }
-- if (option->type == DHCP_SERVER_ID && option->len == 4)
-+ if (!server && option->type == DHCP_SERVER_ID && option->len == 4)
- {
- server = host_create_from_chunk(AF_INET,
- chunk_create(option->data, 4), DHCP_SERVER_PORT);
-@@ -515,12 +515,11 @@ static void handle_offer(private_dhcp_socket_t *this, dhcp_t *dhcp, int optlen)
- }
- DBG1(DBG_CFG, "received DHCP OFFER %H from %H", offer, server);
- transaction->set_address(transaction, offer->clone(offer));
-- transaction->set_server(transaction, server->clone(server));
-+ transaction->set_server(transaction, server);
- }
- this->mutex->unlock(this->mutex);
- this->condvar->broadcast(this->condvar);
- offer->destroy(offer);
-- server->destroy(server);
- }
-
- /**
diff --git a/net-misc/strongswan/strongswan-4.5.0-r1.ebuild b/net-misc/strongswan/strongswan-4.5.1.ebuild
index fb41004a960e..726bf50d29be 100644
--- a/net-misc/strongswan/strongswan-4.5.0-r1.ebuild
+++ b/net-misc/strongswan/strongswan-4.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/strongswan-4.5.0-r1.ebuild,v 1.1 2011/01/18 21:31:18 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/strongswan/strongswan-4.5.1.ebuild,v 1.1 2011/02/12 16:08:59 gurligebis Exp $
EAPI=2
inherit eutils linux-info
@@ -92,10 +92,6 @@ pkg_setup() {
fi
}
-src_prepare() {
- epatch "${FILESDIR}/strongswan-4.5.0-dhcp_segfault.patch"
-}
-
src_configure() {
local myconf=""