summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-12-01 16:52:36 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-12-01 16:52:36 +0000
commit04d24f4c708f1c6ce7c72f25ce45163a3d704f01 (patch)
tree67db2ad9c8f4a92c363b835bc14c0cb20341d595
parentdbench has no hard dependency on sys-apps/attr. Removed (diff)
downloadgentoo-2-04d24f4c708f1c6ce7c72f25ce45163a3d704f01.tar.gz
gentoo-2-04d24f4c708f1c6ce7c72f25ce45163a3d704f01.tar.bz2
gentoo-2-04d24f4c708f1c6ce7c72f25ce45163a3d704f01.zip
Fixed PKG_CONFIG issue.
(Portage version: 2.1.4_rc4)
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog6
-rw-r--r--app-laptop/pbbuttonsd/files/lz.patch16
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild7
3 files changed, 23 insertions, 6 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 4a234c4081dd..8b4dda7db6ab 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.71 2007/11/30 03:38:43 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.72 2007/12/01 16:52:36 josejx Exp $
+
+ 01 Dec 2007; Joseph Jezak <josejx@gentoo.org> files/lz.patch,
+ pbbuttonsd-0.8.1-r2.ebuild:
+ Fixed PKG_CONFIG issue.
30 Nov 2007; Joseph Jezak <josejx@gentoo.org> +files/g++.patch,
+files/lz.patch, -pbbuttonsd-0.8.1.ebuild, -pbbuttonsd-0.8.1-r1.ebuild,
diff --git a/app-laptop/pbbuttonsd/files/lz.patch b/app-laptop/pbbuttonsd/files/lz.patch
index c367acba0211..d648754e3ef3 100644
--- a/app-laptop/pbbuttonsd/files/lz.patch
+++ b/app-laptop/pbbuttonsd/files/lz.patch
@@ -1,6 +1,16 @@
---- configure.in.bak 2007-11-29 22:29:42.000000000 -0500
-+++ configure.in 2007-11-29 22:30:06.000000000 -0500
-@@ -59,10 +59,9 @@
+--- configure.in.bak 2007-12-01 11:45:51.000000000 -0500
++++ configure.in 2007-12-01 11:46:42.000000000 -0500
+@@ -33,6 +33,9 @@
+ PB_OBJECTS=
+ PB_LIBS=
+
++### Setup PKG_CONFIG
++PKG_PROG_PKG_CONFIG
++
+ if test "x$laptop" != "x"; then
+ ac_laptop=$laptop
+ elif test "x$LAPTOP" != "x"; then
+@@ -59,10 +62,9 @@
AC_CHECK_HEADERS([smbios/SystemInfo.h],
AC_DEFINE_UNQUOTED(WITH_SMBIOS, 1, [SMBIOS available]),
AC_MSG_ERROR([SMBios library not available. Please install development files for libsmbios.]), [/* dummy */])
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild
index ec7777ae6e38..407878ee47fd 100644
--- a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild,v 1.2 2007/11/30 03:38:43 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1-r2.ebuild,v 1.3 2007/12/01 16:52:36 josejx Exp $
inherit autotools flag-o-matic eutils
@@ -13,7 +13,10 @@ SLOT="0"
KEYWORDS="ppc ~x86"
IUSE="acpi alsa debug doc ibam macbook oss"
-DEPEND="macbook? ( sys-libs/libsmbios )
+DEPEND="macbook? (
+ sys-libs/libsmbios
+ sys-apps/pciutils
+ )
>=dev-libs/glib-2.6
doc? ( app-doc/doxygen )"
RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )