summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-24 08:40:19 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-24 08:40:19 +0000
commit06a0c396612df80206c4b28b8d78884babed8807 (patch)
tree350827acc368417d6a45b3112140ca4b3aed22b2
parentbump; add pypy support, fix to qa issue (diff)
downloadgentoo-2-06a0c396612df80206c4b28b8d78884babed8807.tar.gz
gentoo-2-06a0c396612df80206c4b28b8d78884babed8807.tar.bz2
gentoo-2-06a0c396612df80206c4b28b8d78884babed8807.zip
bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/datashape/ChangeLog7
-rw-r--r--dev-python/datashape/datashape-0.4.2.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/datashape/ChangeLog b/dev-python/datashape/ChangeLog
index 332377dee3b8..95e62f913443 100644
--- a/dev-python/datashape/ChangeLog
+++ b/dev-python/datashape/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/datashape
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.7 2014/11/18 03:45:16 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/ChangeLog,v 1.8 2014/12/24 08:40:19 idella4 Exp $
+
+*datashape-0.4.2 (24 Dec 2014)
+
+ 24 Dec 2014; Ian Delaney <idella4@gentoo.org> +datashape-0.4.2.ebuild:
+ bump
*datashape-0.4.1 (18 Nov 2014)
diff --git a/dev-python/datashape/datashape-0.4.2.ebuild b/dev-python/datashape/datashape-0.4.2.ebuild
new file mode 100644
index 000000000000..6172a33dd237
--- /dev/null
+++ b/dev-python/datashape/datashape-0.4.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/datashape/datashape-0.4.2.ebuild,v 1.1 2014/12/24 08:40:19 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/ContinuumIO/datashape"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}