summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-12-13 20:48:41 +0000
committerTim Harder <radhermit@gentoo.org>2012-12-13 20:48:41 +0000
commit0b4c9409f98a50fd83ee8850cb10fc0d5bcb856c (patch)
tree008971a88522b23ad499a309db7d4df30277f454
parentRemove old. (diff)
downloadgentoo-2-0b4c9409f98a50fd83ee8850cb10fc0d5bcb856c.tar.gz
gentoo-2-0b4c9409f98a50fd83ee8850cb10fc0d5bcb856c.tar.bz2
gentoo-2-0b4c9409f98a50fd83ee8850cb10fc0d5bcb856c.zip
Remove old.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--dev-lang/swig/ChangeLog7
-rw-r--r--dev-lang/swig/files/swig-2.0.7-illegal-destructors-warning.patch66
-rw-r--r--dev-lang/swig/files/swig-2.0.7-python3.patch18
-rw-r--r--dev-lang/swig/swig-2.0.7-r1.ebuild41
-rw-r--r--dev-lang/swig/swig-2.0.7-r2.ebuild43
5 files changed, 6 insertions, 169 deletions
diff --git a/dev-lang/swig/ChangeLog b/dev-lang/swig/ChangeLog
index 06d4f47b08df..94a51815946d 100644
--- a/dev-lang/swig/ChangeLog
+++ b/dev-lang/swig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/swig
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.178 2012/11/29 14:58:22 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.179 2012/12/13 20:48:41 radhermit Exp $
+
+ 13 Dec 2012; Tim Harder <radhermit@gentoo.org> -swig-2.0.7-r1.ebuild,
+ -swig-2.0.7-r2.ebuild, -files/swig-2.0.7-illegal-destructors-warning.patch,
+ -files/swig-2.0.7-python3.patch:
+ Remove old.
29 Nov 2012; Jeroen Roovers <jer@gentoo.org> swig-2.0.8.ebuild:
Stable for HPPA (bug #442510).
diff --git a/dev-lang/swig/files/swig-2.0.7-illegal-destructors-warning.patch b/dev-lang/swig/files/swig-2.0.7-illegal-destructors-warning.patch
deleted file mode 100644
index c4fc0e2b5cce..000000000000
--- a/dev-lang/swig/files/swig-2.0.7-illegal-destructors-warning.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-Index: Source/Modules/lang.cxx
-===================================================================
---- Source/Modules/lang.cxx (revision 13127)
-+++ Source/Modules/lang.cxx (revision 13128)
-@@ -2623,7 +2623,7 @@
- Delete(expected_name_resolved);
- }
- if (illegal_name) {
-- Swig_warning(WARN_LANG_RETURN_TYPE, input_file, line_number, "Function %s must have a return type. Ignored.\n", Swig_name_decl(name));
-+ Swig_warning(WARN_LANG_RETURN_TYPE, input_file, line_number, "Function %s must have a return type. Ignored.\n", Swig_name_decl(n));
- Swig_restore(n);
- return SWIG_NOWRAP;
- }
-@@ -2760,7 +2760,7 @@
- }
-
- if (illegal_name) {
-- Swig_warning(WARN_LANG_ILLEGAL_DESTRUCTOR, input_file, line_number, "Illegal destructor name %s. Ignored.\n", Swig_name_decl(name));
-+ Swig_warning(WARN_LANG_ILLEGAL_DESTRUCTOR, input_file, line_number, "Illegal destructor name %s. Ignored.\n", Swig_name_decl(n));
- Swig_restore(n);
- Delete(expected_name);
- return SWIG_NOWRAP;
-Index: Examples/test-suite/errors/expected.log
-===================================================================
---- Examples/test-suite/errors/expected.log (revision 13127)
-+++ Examples/test-suite/errors/expected.log (revision 13128)
-@@ -227,17 +227,17 @@
- cpp_extend_destructors.i:85: Warning 302: previous definition of '~JStruct'.
- cpp_extend_destructors.i:100: Warning 302: Identifier '~LStruct' redefined (ignored),
- cpp_extend_destructors.i:98: Warning 302: previous definition of '~LStruct'.
--cpp_extend_destructors.i:24: Warning 521: Illegal destructor name ~NOT_CStruct. Ignored.
--cpp_extend_destructors.i:30: Warning 521: Illegal destructor name ~NOT_DStruct. Ignored.
--cpp_extend_destructors.i:44: Warning 521: Illegal destructor name ~NOT_EStruct. Ignored.
--cpp_extend_destructors.i:50: Warning 521: Illegal destructor name ~NOT_FStruct. Ignored.
--cpp_extend_destructors.i:65: Warning 521: Illegal destructor name ~NOT_GStruct. Ignored.
--cpp_extend_destructors.i:72: Warning 521: Illegal destructor name ~NOT_HStruct. Ignored.
--cpp_extend_destructors.i:81: Warning 521: Illegal destructor name ~NOT_IStruct. Ignored.
--cpp_extend_destructors.i:86: Warning 521: Illegal destructor name ~NOT_JStruct. Ignored.
--cpp_extend_destructors.i:92: Warning 521: Illegal destructor name ~NOT_KStruct. Ignored.
--cpp_extend_destructors.i:99: Warning 521: Illegal destructor name ~NOT_LStruct< int >. Ignored.
--cpp_extend_destructors.i:99: Warning 521: Illegal destructor name ~NOT_LStruct< short >. Ignored.
-+cpp_extend_destructors.i:24: Warning 521: Illegal destructor name CStruct::~NOT_CStruct(). Ignored.
-+cpp_extend_destructors.i:30: Warning 521: Illegal destructor name DStruct::~NOT_DStruct(). Ignored.
-+cpp_extend_destructors.i:44: Warning 521: Illegal destructor name EStruct::~NOT_EStruct(). Ignored.
-+cpp_extend_destructors.i:50: Warning 521: Illegal destructor name FStruct::~NOT_FStruct(). Ignored.
-+cpp_extend_destructors.i:65: Warning 521: Illegal destructor name GStruct::~NOT_GStruct(). Ignored.
-+cpp_extend_destructors.i:72: Warning 521: Illegal destructor name HStruct::~NOT_HStruct(). Ignored.
-+cpp_extend_destructors.i:81: Warning 521: Illegal destructor name IStruct::~NOT_IStruct(). Ignored.
-+cpp_extend_destructors.i:86: Warning 521: Illegal destructor name JStruct::~NOT_JStruct(). Ignored.
-+cpp_extend_destructors.i:92: Warning 521: Illegal destructor name KStruct::~NOT_KStruct(). Ignored.
-+cpp_extend_destructors.i:99: Warning 521: Illegal destructor name LStruct< int >::~NOT_LStruct(). Ignored.
-+cpp_extend_destructors.i:99: Warning 521: Illegal destructor name LStruct< short >::~NOT_LStruct(). Ignored.
-
- :::::::::::::::::::::::::::::::: cpp_extend_redefine.i :::::::::::::::::::::::::::::::::::
- cpp_extend_redefine.i:9: Warning 302: Identifier 'bar' redefined by %extend (ignored),
-@@ -312,8 +312,8 @@
- cpp_no_access.i:3: Warning 319: No access specifier given for base class 'foo' (ignored).
-
- :::::::::::::::::::::::::::::::: cpp_no_return_type.i :::::::::::::::::::::::::::::::::::
--cpp_no_return_type.i:6: Warning 504: Function R must have a return type. Ignored.
--cpp_no_return_type.i:10: Warning 504: Function UU must have a return type. Ignored.
-+cpp_no_return_type.i:6: Warning 504: Function S::R() must have a return type. Ignored.
-+cpp_no_return_type.i:10: Warning 504: Function U::UU() must have a return type. Ignored.
-
- :::::::::::::::::::::::::::::::: cpp_nobase.i :::::::::::::::::::::::::::::::::::
- cpp_nobase.i:3: Warning 401: Nothing known about base class 'Bar'. Ignored.
diff --git a/dev-lang/swig/files/swig-2.0.7-python3.patch b/dev-lang/swig/files/swig-2.0.7-python3.patch
deleted file mode 100644
index 1c7727ae2491..000000000000
--- a/dev-lang/swig/files/swig-2.0.7-python3.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Description: Py3k: Map PyInt_FromSize_t to PyLong_FromSize_t
- The latest SWIG version introduced a usage of PyInt_FromSize_t, but
- does not define a compatibility macro for Python 3k as for the other
- PyInt_... functions. This patch adds that macro.
-
-Author: Torsten Landschoff <torsten@debian.org>
-
-
---- swig2.0-2.0.7.orig/Lib/python/pyhead.swg
-+++ swig2.0-2.0.7/Lib/python/pyhead.swg
-@@ -5,6 +5,7 @@
- #define PyInt_Check(x) PyLong_Check(x)
- #define PyInt_AsLong(x) PyLong_AsLong(x)
- #define PyInt_FromLong(x) PyLong_FromLong(x)
-+#define PyInt_FromSize_t(x) PyLong_FromSize_t(x)
- #define PyString_Check(name) PyBytes_Check(name)
- #define PyString_FromString(x) PyUnicode_FromString(x)
- #define PyString_Format(fmt, args) PyUnicode_Format(fmt, args)
diff --git a/dev-lang/swig/swig-2.0.7-r1.ebuild b/dev-lang/swig/swig-2.0.7-r1.ebuild
deleted file mode 100644
index 08a4b95135e0..000000000000
--- a/dev-lang/swig/swig-2.0.7-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-2.0.7-r1.ebuild,v 1.1 2012/07/12 19:20:57 radhermit Exp $
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="Simplified Wrapper and Interface Generator"
-HOMEPAGE="http://www.swig.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3 as-is"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="ccache doc pcre"
-RESTRICT="test"
-
-DEPEND="pcre? ( dev-libs/libpcre )
- ccache? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-DOCS=( ANNOUNCE CHANGES CHANGES.current README TODO )
-
-src_prepare() {
- # bug 417823
- epatch "${FILESDIR}"/${PN}-2.0.7-illegal-destructors-warning.patch
-}
-
-src_configure() {
- econf \
- $(use_enable ccache) \
- $(use_with pcre)
-}
-
-src_install() {
- default
- if use doc; then
- dohtml -r Doc/{Devel,Manual}
- fi
-}
diff --git a/dev-lang/swig/swig-2.0.7-r2.ebuild b/dev-lang/swig/swig-2.0.7-r2.ebuild
deleted file mode 100644
index 874b4809a47b..000000000000
--- a/dev-lang/swig/swig-2.0.7-r2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-2.0.7-r2.ebuild,v 1.1 2012/08/07 08:23:19 radhermit Exp $
-
-EAPI=4
-
-inherit eutils
-
-DESCRIPTION="Simplified Wrapper and Interface Generator"
-HOMEPAGE="http://www.swig.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3 as-is"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="ccache doc pcre"
-RESTRICT="test"
-
-DEPEND="pcre? ( dev-libs/libpcre )
- ccache? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-DOCS=( ANNOUNCE CHANGES CHANGES.current README TODO )
-
-src_prepare() {
- # bug 417823
- epatch "${FILESDIR}"/${PN}-2.0.7-illegal-destructors-warning.patch
- # bug 426428
- epatch "${FILESDIR}"/${P}-python3.patch
-}
-
-src_configure() {
- econf \
- $(use_enable ccache) \
- $(use_with pcre)
-}
-
-src_install() {
- default
- if use doc; then
- dohtml -r Doc/{Devel,Manual}
- fi
-}