summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-09 10:23:19 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-09 10:23:19 +0000
commit0e52024a77d52c0763155fc71fb12a73db4a3bc2 (patch)
tree87bad00f104502becd416dad0a778612f5c2dfc0
parentEnable 3.4 in release as well. (diff)
downloadgentoo-2-0e52024a77d52c0763155fc71fb12a73db4a3bc2.tar.gz
gentoo-2-0e52024a77d52c0763155fc71fb12a73db4a3bc2.tar.bz2
gentoo-2-0e52024a77d52c0763155fc71fb12a73db4a3bc2.zip
Version bump. Fixes prepending to PYTHON_COMPAT and handling python.eclass-unsupported implementations. Reads implementation support state from the repository. gpy-upgrade-impl updates both live and non-live ebuilds, bug #506246. gpy-showimpls marks keywords and exact eclass used.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--app-portage/gpyutils/ChangeLog10
-rw-r--r--app-portage/gpyutils/gpyutils-0.1.3.ebuild23
2 files changed, 32 insertions, 1 deletions
diff --git a/app-portage/gpyutils/ChangeLog b/app-portage/gpyutils/ChangeLog
index c3338aef3dd2..ddd414ef553d 100644
--- a/app-portage/gpyutils/ChangeLog
+++ b/app-portage/gpyutils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-portage/gpyutils
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gpyutils/ChangeLog,v 1.12 2014/04/09 09:26:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gpyutils/ChangeLog,v 1.13 2014/04/09 10:23:19 mgorny Exp $
+
+*gpyutils-0.1.3 (09 Apr 2014)
+
+ 09 Apr 2014; Michał Górny <mgorny@gentoo.org> +gpyutils-0.1.3.ebuild:
+ Version bump. Fixes prepending to PYTHON_COMPAT and handling python.eclass-
+ unsupported implementations. Reads implementation support state from the
+ repository. gpy-upgrade-impl updates both live and non-live ebuilds, bug
+ #506246. gpy-showimpls marks keywords and exact eclass used.
09 Apr 2014; Michał Górny <mgorny@gentoo.org> files/implementations.txt:
Update status on PyPy support.
diff --git a/app-portage/gpyutils/gpyutils-0.1.3.ebuild b/app-portage/gpyutils/gpyutils-0.1.3.ebuild
new file mode 100644
index 000000000000..9a29afa1b0a3
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.1.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gpyutils/gpyutils-0.1.3.ebuild,v 1.1 2014/04/09 10:23:19 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="https://bitbucket.org/mgorny/gpyutils/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.9[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}