summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-30 04:10:41 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-30 04:10:41 +0000
commit11c231030fa852a8ac0d987c229fcc6ffa669269 (patch)
tree20d093b54d06e647ce31b0f94c9a837fca5b10fb
parentVersion bump. (diff)
downloadgentoo-2-11c231030fa852a8ac0d987c229fcc6ffa669269.tar.gz
gentoo-2-11c231030fa852a8ac0d987c229fcc6ffa669269.tar.bz2
gentoo-2-11c231030fa852a8ac0d987c229fcc6ffa669269.zip
Version bump. Fix wrong enable option parsing at configure time
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
-rw-r--r--sci-libs/arprec/ChangeLog8
-rw-r--r--sci-libs/arprec/arprec-2.2.15.ebuild53
-rw-r--r--sci-libs/arprec/files/arprec-2.2.15-fix-enabling.patch56
-rw-r--r--sci-libs/arprec/metadata.xml21
4 files changed, 128 insertions, 10 deletions
diff --git a/sci-libs/arprec/ChangeLog b/sci-libs/arprec/ChangeLog
index fab90e857947..f591291cd228 100644
--- a/sci-libs/arprec/ChangeLog
+++ b/sci-libs/arprec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/arprec
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/arprec/ChangeLog,v 1.13 2012/10/18 21:12:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/arprec/ChangeLog,v 1.14 2012/11/30 04:10:41 bicatali Exp $
+
+*arprec-2.2.15 (30 Nov 2012)
+
+ 30 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> +arprec-2.2.15.ebuild,
+ +files/arprec-2.2.15-fix-enabling.patch, metadata.xml:
+ Version bump. Fix wrong enable option parsing at configure time
18 Oct 2012; Justin Lecher <jlec@gentoo.org> arprec-2.2.13.ebuild,
metadata.xml:
diff --git a/sci-libs/arprec/arprec-2.2.15.ebuild b/sci-libs/arprec/arprec-2.2.15.ebuild
new file mode 100644
index 000000000000..2053e7cf2e2c
--- /dev/null
+++ b/sci-libs/arprec/arprec-2.2.15.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/arprec/arprec-2.2.15.ebuild,v 1.1 2012/11/30 04:10:41 bicatali Exp $
+
+EAPI=4
+
+FORTRAN_NEEDED=fortran
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils fortran-2 autotools-utils
+
+DESCRIPTION="Arbitrary precision float arithmetics and functions"
+HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fma fortran qd static-libs"
+
+DEPEND="qd? ( sci-libs/qd[fortran=] )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-enabling.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable fma)
+ $(use_enable fortran)
+ $(use_enable qd)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use fortran && autotools-utils_src_compile toolkit
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use fortran; then
+ cd toolkit
+ ./mathinit || die "mathinit failed"
+ exeinto /usr/libexec/${PN}
+ doexe mathtool
+ insinto /usr/libexec/${PN}
+ doins *.dat
+ newdoc README README.mathtool
+ fi
+ use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
+}
diff --git a/sci-libs/arprec/files/arprec-2.2.15-fix-enabling.patch b/sci-libs/arprec/files/arprec-2.2.15-fix-enabling.patch
new file mode 100644
index 000000000000..e836dd6add71
--- /dev/null
+++ b/sci-libs/arprec/files/arprec-2.2.15-fix-enabling.patch
@@ -0,0 +1,56 @@
+--- configure.ac.orig 2012-11-29 19:50:09.547028887 -0800
++++ configure.ac 2012-11-29 19:52:14.380660761 -0800
+@@ -36,7 +36,7 @@
+
+ # Checks for command-line options
+ # --enable-inline option.
+-AC_ARG_ENABLE(enable_inline, AC_HELP_STRING(--enable-inline, [inline commonly used functions. [[default=yes]]]))
++AC_ARG_ENABLE(inline, AC_HELP_STRING(--enable-inline, [inline commonly used functions. [[default=yes]]]))
+ AC_MSG_CHECKING([if commonly used function is to be inlined])
+ if test "x$enable_inline" != "xno"; then
+ enable_inline="yes"
+@@ -45,7 +45,7 @@
+ AC_MSG_RESULT($enable_inline)
+
+ # --enable-debug
+-AC_ARG_ENABLE(enable_debug, AC_HELP_STRING(--enable-debug, [enable debugging code. [[default=no]]]))
++AC_ARG_ENABLE(debug, AC_HELP_STRING(--enable-debug, [enable debugging code. [[default=no]]]))
+ AC_MSG_CHECKING([if debugging code is to be enabled])
+ if test "x$enable_debug" = "xyes"; then
+ AC_DEFINE([ARPREC_DEBUG], [1], [Define to 1 to enable debugging code.])
+@@ -55,7 +55,7 @@
+ AC_MSG_RESULT($enable_debug)
+
+ # --enable-always-fix-fpu
+-AC_ARG_ENABLE(enable_always_fix_fpu, AC_HELP_STRING(--enable-always-fix-fpu, [Use FPU fix whenever C interface is called. [[default=no]]]))
++AC_ARG_ENABLE(always_fix_fpu, AC_HELP_STRING(--enable-always-fix-fpu, [Use FPU fix whenever C interface is called. [[default=no]]]))
+ if test "x$enable_always_fix_fpu" = "xyes"; then
+ AC_DEFINE([ALWAYS_FIX_FPU], [1], [Define to 1 to use FPU fix whenever C interface is called.])
+ else
+@@ -119,7 +119,7 @@
+ fi
+
+ # --enable-qd
+-AC_ARG_ENABLE(enable-qd, AC_HELP_STRING(--enable-qd, [Use quad-double (QD)
++AC_ARG_ENABLE(qd, AC_HELP_STRING(--enable-qd, [Use quad-double (QD)
+ library. [[default=no]]]))
+ if test "x$enable_qd" = "xyes"; then
+ AC_CHECK_QD([2.3], [CXXFLAGS="$CXXFLAGS $QD_CXXFLAGS"])
+@@ -129,7 +129,7 @@
+ fi
+
+ # --enable-fma
+-AC_ARG_ENABLE(enable_fma, AC_HELP_STRING(--enable-fma, [use fused multiply-add/subtract (auto,gnu,c99,ibm,compiler). Use this option with care. [[default=auto]]]))
++AC_ARG_ENABLE(fma, AC_HELP_STRING(--enable-fma, [use fused multiply-add/subtract (auto,gnu,c99,ibm,compiler). Use this option with care. [[default=auto]]]))
+ if test "x$enable_fma" = "x"; then
+ enable_fma="auto"
+ fi
+@@ -175,7 +175,7 @@
+ FCFLAGS="-O2"
+ fi
+ fi
+-AC_ARG_ENABLE(enable_fortran, AC_HELP_STRING(--enable-fortran, [build Fortran interfaces [[default=auto]]]))
++AC_ARG_ENABLE(fortran, AC_HELP_STRING(--enable-fortran, [build Fortran interfaces [[default=auto]]]))
+ if test "x$enable_fortran" != "xno"; then
+ AC_LANG_PUSH(Fortran)
+ AC_PROG_FC([xlf95 ifort pathf95 f95 gfortran g95 pgf95 lf95 fort ifc efc pathf90 xlf90 pgf90 epcf90 xlf f90])
diff --git a/sci-libs/arprec/metadata.xml b/sci-libs/arprec/metadata.xml
index 80244094e85e..df8c0e32337a 100644
--- a/sci-libs/arprec/metadata.xml
+++ b/sci-libs/arprec/metadata.xml
@@ -1,13 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <maintainer>
- <email>grozin@gentoo.org</email>
- <name>Andrey Grozin</name>
- </maintainer>
- <longdescription>Arbitrary precision float arithmetics and functions</longdescription>
- <use>
- <flag name="qd">Use <pkg>sci-libs/qd</pkg></flag>
- </use>
+ <herd>sci</herd>
+<maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<longdescription>
+ Arbitrary precision library for float arithmetics and mathematical functions.
+</longdescription>
+<use>
+ <flag name="fma">Use the Fused Multiply Add instruction set</flag>
+ <flag name="qd">Use <pkg>sci-libs/qd</pkg>for quad-double datatype</flag>
+</use>
</pkgmetadata>