summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 03:52:03 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 03:52:03 +0000
commit20c462b10ceab0aaa9ed3d0dd1705c45b99b55ca (patch)
treebdbd0659018181b56bae815c7b459d37a5cbd216
parentCloses #46164 (Manifest recommit) (diff)
downloadgentoo-2-20c462b10ceab0aaa9ed3d0dd1705c45b99b55ca.tar.gz
gentoo-2-20c462b10ceab0aaa9ed3d0dd1705c45b99b55ca.tar.bz2
gentoo-2-20c462b10ceab0aaa9ed3d0dd1705c45b99b55ca.zip
add inherit eutils
-rw-r--r--app-emacs/mule-ucs/mule-ucs-0.84-r1.ebuild16
-rw-r--r--app-emacs/nxml-mode/nxml-mode-20031031.ebuild8
-rw-r--r--app-emacs/regress/regress-1.5.0.ebuild10
-rw-r--r--app-emacs/tamago/tamago-4.0.6-r1.ebuild26
-rw-r--r--app-emacs/thumbs/thumbs-1.8.ebuild12
-rw-r--r--app-emacs/vm/vm-7.18.ebuild7
-rw-r--r--app-emulation/XWine/XWine-0.3.2.ebuild6
-rw-r--r--app-emulation/mono-wine/mono-wine-20030318.ebuild16
-rw-r--r--app-emulation/point2play/point2play-1.1.1-r1.ebuild4
-rw-r--r--app-emulation/point2play/point2play-1.2.ebuild4
-rw-r--r--app-i18n/canna/canna-3.6_p4.ebuild4
-rw-r--r--app-i18n/iiimgcf/iiimgcf-11.4.1467.ebuild15
12 files changed, 55 insertions, 73 deletions
diff --git a/app-emacs/mule-ucs/mule-ucs-0.84-r1.ebuild b/app-emacs/mule-ucs/mule-ucs-0.84-r1.ebuild
index 23f85f41c151..ee918358473b 100644
--- a/app-emacs/mule-ucs/mule-ucs-0.84-r1.ebuild
+++ b/app-emacs/mule-ucs/mule-ucs-0.84-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/mule-ucs/mule-ucs-0.84-r1.ebuild,v 1.1 2003/12/14 18:27:34 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/mule-ucs/mule-ucs-0.84-r1.ebuild,v 1.2 2004/04/06 03:47:37 vapier Exp $
-inherit elisp-common
+inherit elisp-common eutils
MY_PN="Mule-UCS"
MY_P="${MY_PN}-${PV}"
@@ -10,26 +10,23 @@ MY_PATCH="${P}+tats20021216"
S=${WORKDIR}/${MY_P}
DESCRIPTION="A character code translator."
+HOMEPAGE="http://www.m17n.org/mule/ http://tats.iris.ne.jp/mule-ucs/"
SRC_URI="ftp://ftp.m17n.org/pub/mule/Mule-UCS/${MY_P}.tar.gz
http://tats.iris.ne.jp/mule-ucs/${MY_PATCH}.diff.gz"
-HOMEPAGE="http://www.m17n.org/mule/
- http://tats.iris.ne.jp/mule-ucs/"
-DEPEND="virtual/emacs"
-SLOT="0"
LICENSE="GPL-2"
-
+SLOT="0"
KEYWORDS="x86 alpha sparc ppc"
-src_unpack() {
+DEPEND="virtual/emacs"
+src_unpack() {
unpack ${MY_P}.tar.gz
cd ${S}
epatch ${DISTDIR}/${MY_PATCH}.diff.gz
}
src_compile() {
-
emacs -q --no-site-file -batch -l mucs-comp.el || die
pushd lisp/big5conv
emacs -q --no-site-file -batch -l big5-comp.el || die
@@ -40,7 +37,6 @@ src_compile() {
}
src_install() {
-
elisp-install ${MY_PN} lisp/*.el{,c}
elisp-install ${MY_PN}/big5conv lisp/big5conv/*.el{,c}
elisp-install ${MY_PN}/jisx0213 lisp/jisx0213/*.el{,c}
diff --git a/app-emacs/nxml-mode/nxml-mode-20031031.ebuild b/app-emacs/nxml-mode/nxml-mode-20031031.ebuild
index 4a92cf39faae..989f56b2d563 100644
--- a/app-emacs/nxml-mode/nxml-mode-20031031.ebuild
+++ b/app-emacs/nxml-mode/nxml-mode-20031031.ebuild
@@ -1,20 +1,19 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-mode/nxml-mode-20031031.ebuild,v 1.2 2004/03/14 12:53:07 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-mode/nxml-mode-20031031.ebuild,v 1.3 2004/04/06 03:47:54 vapier Exp $
-inherit elisp
+inherit elisp eutils
DESCRIPTION="A new major mode for GNU Emacs for editing XML documents."
HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki/NxmlMode"
SRC_URI="http://thaiopensource.com/download/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
DEPEND="virtual/emacs"
-S=${WORKDIR}/${P}
-
SITEFILE=80nxml-mode-gentoo.el
src_unpack() {
@@ -22,6 +21,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PV}-info-gentoo.patch
}
+
src_compile() {
emacs -batch -l rng-auto.el -f rng-byte-compile-load
}
diff --git a/app-emacs/regress/regress-1.5.0.ebuild b/app-emacs/regress/regress-1.5.0.ebuild
index 341e332f7cea..e727731bede1 100644
--- a/app-emacs/regress/regress-1.5.0.ebuild
+++ b/app-emacs/regress/regress-1.5.0.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/regress/regress-1.5.0.ebuild,v 1.1 2003/11/25 17:28:02 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/regress/regress-1.5.0.ebuild,v 1.2 2004/04/06 03:48:08 vapier Exp $
-inherit elisp
+inherit elisp eutils
DESCRIPTION="Regression test harness for Emacs Lisp code"
HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki/WikifiedEmacsLispList"
SRC_URI="mirror://gentoo/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE=""
+
DEPEND="virtual/emacs"
-S=${WORKDIR}/${P}
SITEFILE=50regress-gentoo.el
diff --git a/app-emacs/tamago/tamago-4.0.6-r1.ebuild b/app-emacs/tamago/tamago-4.0.6-r1.ebuild
index ac3abc8fda7c..715bfa4cc868 100644
--- a/app-emacs/tamago/tamago-4.0.6-r1.ebuild
+++ b/app-emacs/tamago/tamago-4.0.6-r1.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/tamago/tamago-4.0.6-r1.ebuild,v 1.4 2003/11/14 21:23:15 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/tamago/tamago-4.0.6-r1.ebuild,v 1.5 2004/04/06 03:48:55 vapier Exp $
-inherit elisp
-
-IUSE="canna"
+inherit elisp eutils
DESCRIPTION="Emacs Backend for Sj3 Ver.2, FreeWnn, Wnn6 and Canna"
+HOMEPAGE="http://www.m17n.org/tamago/"
SRC_URI="ftp://ftp.m17n.org/pub/tamago/${P}.tar.gz
http://cgi18.plala.or.jp/nyy/canna/canna-20011204.diff.gz"
-HOMEPAGE="http://www.m17n.org/tamago/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
+IUSE="canna"
DEPEND="virtual/emacs
app-arch/gzip
@@ -21,11 +20,9 @@ DEPEND="virtual/emacs
RDEPEND="virtual/emacs
canna? ( app-i18n/canna )"
-S="${WORKDIR}/${P}"
SITEFILE=50tamago-gentoo.el
src_unpack() {
-
unpack ${A}
epatch ${FILESDIR}/${P}-canna-gentoo.patch
@@ -33,13 +30,11 @@ src_unpack() {
}
src_compile() {
-
./configure --prefix=/usr || die
emake || die
}
src_install() {
-
dodir ${SITELISP}/${PN}
emake prefix=${D}/usr \
infodir=${D}/usr/share/info \
@@ -48,7 +43,7 @@ src_install() {
cp ${FILESDIR}/${SITEFILE} ${SITEFILE}
- if [ -n "`use canna`" ] ; then
+ if use canna ; then
cat >>${SITEFILE}<<-EOF
(set-language-info "Japanese" 'input-method "japanese-egg-canna")
@@ -57,16 +52,15 @@ src_install() {
elisp-site-file-install ${SITEFILE} || die
- dodoc README.ja.txt COPYING AUTHORS PROBLEMS TODO ChangeLog
+ dodoc README.ja.txt AUTHORS PROBLEMS TODO ChangeLog
}
pkg_postinst() {
-
elisp-site-regen
- if ! grep -q inet /etc/conf.d/canna ; then
+ if ! grep -q inet ${ROOT}/etc/conf.d/canna ; then
sed -i -e '/CANNASERVER_OPTS/s/"\(.*\)"/"\1 -inet"/' \
- /etc/conf.d/canna
+ ${ROOT}/etc/conf.d/canna
einfo
einfo "Enabled inet domain socket for tamago."
diff --git a/app-emacs/thumbs/thumbs-1.8.ebuild b/app-emacs/thumbs/thumbs-1.8.ebuild
index a03e0c5ef50a..6d8796385ab6 100644
--- a/app-emacs/thumbs/thumbs-1.8.ebuild
+++ b/app-emacs/thumbs/thumbs-1.8.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/thumbs/thumbs-1.8.ebuild,v 1.1 2003/09/25 04:51:05 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/thumbs/thumbs-1.8.ebuild,v 1.2 2004/04/06 03:49:10 vapier Exp $
-inherit elisp
-
-IUSE=""
+inherit elisp eutils
DESCRIPTION="Emacs thumbnail previewer for image files"
HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki.pl?ThumbsMode"
SRC_URI="mirror://gentoo/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
@@ -16,8 +15,6 @@ KEYWORDS="x86"
DEPEND="virtual/emacs
media-gfx/imagemagick"
-S=${WORKDIR}/${P}
-
SITEFILE=50thumbs-gentoo.el
src_unpack() {
@@ -33,4 +30,3 @@ src_install() {
elisp-install ${PN} *.el *.elc
elisp-site-file-install ${FILESDIR}/${SITEFILE}
}
-
diff --git a/app-emacs/vm/vm-7.18.ebuild b/app-emacs/vm/vm-7.18.ebuild
index f80ac290aa26..f4e2410bf225 100644
--- a/app-emacs/vm/vm-7.18.ebuild
+++ b/app-emacs/vm/vm-7.18.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-7.18.ebuild,v 1.1 2004/03/13 18:16:07 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/vm/vm-7.18.ebuild,v 1.2 2004/04/06 03:49:26 vapier Exp $
-inherit elisp
-
-IUSE=""
+inherit elisp eutils
DESCRIPTION="An emacs major mode for reading and writing e-mail with support for GPG and MIME."
SRC_URI="ftp://ftp.uni-mainz.de/pub/software/gnu/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.wonderworks.com/vm"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
diff --git a/app-emulation/XWine/XWine-0.3.2.ebuild b/app-emulation/XWine/XWine-0.3.2.ebuild
index 68bf63e141be..7a1909613cfc 100644
--- a/app-emulation/XWine/XWine-0.3.2.ebuild
+++ b/app-emulation/XWine/XWine-0.3.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.3.2.ebuild,v 1.3 2004/02/20 06:08:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.3.2.ebuild,v 1.4 2004/04/06 03:49:47 vapier Exp $
+
+inherit eutils
DESCRIPTION="GTK+ frontend for Wine"
HOMEPAGE="http://darken.tuxfamily.org/pages/xwine_en.html"
@@ -30,7 +32,7 @@ src_install() {
einstall || die
# Don't need to install docs twice
rm -rf ${D}/usr/share/doc/xwine
- dodoc doc/Manual* FAQ* BUGS COPYING AUTHORS NEWS README TODO
+ dodoc doc/Manual* FAQ* BUGS AUTHORS NEWS README TODO
}
pkg_postinst() {
diff --git a/app-emulation/mono-wine/mono-wine-20030318.ebuild b/app-emulation/mono-wine/mono-wine-20030318.ebuild
index 78601ea46923..7d1a3dd7f1f5 100644
--- a/app-emulation/mono-wine/mono-wine-20030318.ebuild
+++ b/app-emulation/mono-wine/mono-wine-20030318.ebuild
@@ -1,28 +1,24 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mono-wine/mono-wine-20030318.ebuild,v 1.2 2004/02/20 06:08:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mono-wine/mono-wine-20030318.ebuild,v 1.3 2004/04/06 03:50:15 vapier Exp $
+
+inherit eutils
DESCRIPTION="Wine for mono's System.Windows.Forms"
HOMEPAGE="http://www.go-mono.com/winforms.html/"
SRC_URI="http://primates.ximian.com/~duncan/mono-wine/sources/Wine-${PV}.tar.gz
- http://primates.ximian.com/~duncan/mono-wine/sources/mono-wine.patch
- http://primates.ximian.com/~duncan/mono-wine/sources/dot-wine.tar.gz
- http://primates.ximian.com/~duncan/mono-wine/sources/mono-wine-setup"
+ http://primates.ximian.com/~duncan/mono-wine/sources/mono-wine.patch
+ http://primates.ximian.com/~duncan/mono-wine/sources/dot-wine.tar.gz
+ http://primates.ximian.com/~duncan/mono-wine/sources/mono-wine-setup"
LICENSE="GPL-2"
-
SLOT="0"
-
KEYWORDS="~x86"
DEPEND="virtual/x11"
S=${WORKDIR}/wine-${PV}
-src_unpack() {
- tar zxf ${DISTDIR}/Wine-${PV}.tar.gz
-}
-
src_compile() {
epatch ${DISTDIR}/mono-wine.patch
econf || die
diff --git a/app-emulation/point2play/point2play-1.1.1-r1.ebuild b/app-emulation/point2play/point2play-1.1.1-r1.ebuild
index 46425a0a4ae5..3eac5c8e2baa 100644
--- a/app-emulation/point2play/point2play-1.1.1-r1.ebuild
+++ b/app-emulation/point2play/point2play-1.1.1-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.1.1-r1.ebuild,v 1.3 2004/02/20 06:08:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.1.1-r1.ebuild,v 1.4 2004/04/06 03:50:30 vapier Exp $
+
+inherit eutils
MY_P=${PN}-small-${PV}
DESCRIPTION="graphical frontend for WineX"
diff --git a/app-emulation/point2play/point2play-1.2.ebuild b/app-emulation/point2play/point2play-1.2.ebuild
index d826057f1f30..d35b23ae4f1b 100644
--- a/app-emulation/point2play/point2play-1.2.ebuild
+++ b/app-emulation/point2play/point2play-1.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.2.ebuild,v 1.2 2004/02/20 06:08:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.2.ebuild,v 1.3 2004/04/06 03:50:38 vapier Exp $
+
+inherit eutils
MY_P=${PN}-small-${PV}
DESCRIPTION="graphical frontend for WineX"
diff --git a/app-i18n/canna/canna-3.6_p4.ebuild b/app-i18n/canna/canna-3.6_p4.ebuild
index 55503b9ec70e..f05c6b1e5b5e 100644
--- a/app-i18n/canna/canna-3.6_p4.ebuild
+++ b/app-i18n/canna/canna-3.6_p4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p4.ebuild,v 1.11 2004/03/30 06:14:16 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p4.ebuild,v 1.12 2004/04/06 03:50:44 vapier Exp $
-inherit cannadic
+inherit cannadic eutils
IUSE="doc"
diff --git a/app-i18n/iiimgcf/iiimgcf-11.4.1467.ebuild b/app-i18n/iiimgcf/iiimgcf-11.4.1467.ebuild
index 599dc1e35901..e24243729259 100644
--- a/app-i18n/iiimgcf/iiimgcf-11.4.1467.ebuild
+++ b/app-i18n/iiimgcf/iiimgcf-11.4.1467.ebuild
@@ -1,38 +1,33 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/iiimgcf/iiimgcf-11.4.1467.ebuild,v 1.3 2004/03/10 20:26:27 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/iiimgcf/iiimgcf-11.4.1467.ebuild,v 1.4 2004/04/06 03:52:03 vapier Exp $
-inherit iiimf
+inherit iiimf eutils
DESCRIPTION="IIIMGCF is a GTK+ client framework for IIIMF"
LICENSE="LGPL-2.1"
-
KEYWORDS="~x86"
+
DEPEND="dev-libs/libiiimp
dev-libs/libiiimcf
gtk? ( =x11-libs/gtk+-2* )"
src_unpack() {
-
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gentoo.diff
}
src_install() {
-
make DESTDIR=${D} install || die
-
dodoc AUTHORS ChangeLog
}
pkg_postinst() {
-
- gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+ gtk-query-immodules-2.0 > ${ROOT}/etc/gtk-2.0/gtk.immodules
}
pkg_postrm() {
-
- gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+ gtk-query-immodules-2.0 > ${ROOT}/etc/gtk-2.0/gtk.immodules
}