summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2010-01-25 01:30:06 +0000
committerDenis Dupeyron <calchan@gentoo.org>2010-01-25 01:30:06 +0000
commit20ff5158c903ca65dd77abe74f47046da3f9ccf2 (patch)
treec7e9c477d57d62d6c8b5158bc494f2ec3f854227
parentUpdated and cleaned-up binary libs. Fixed bug #210619. (diff)
downloadgentoo-2-20ff5158c903ca65dd77abe74f47046da3f9ccf2.tar.gz
gentoo-2-20ff5158c903ca65dd77abe74f47046da3f9ccf2.tar.bz2
gentoo-2-20ff5158c903ca65dd77abe74f47046da3f9ccf2.zip
Version bump, bug #267396.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
-rw-r--r--games-rpg/nwmouse/ChangeLog10
-rw-r--r--games-rpg/nwmouse/nwmouse-20090906.183839.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/games-rpg/nwmouse/ChangeLog b/games-rpg/nwmouse/ChangeLog
index 6ae6192583c6..1b715bda5243 100644
--- a/games-rpg/nwmouse/ChangeLog
+++ b/games-rpg/nwmouse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/nwmouse
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/ChangeLog,v 1.9 2008/08/18 17:55:37 calchan Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/ChangeLog,v 1.10 2010/01/25 01:30:06 calchan Exp $
+
+*nwmouse-20090906.183839 (25 Jan 2010)
+
+ 25 Jan 2010; Denis Dupeyron <calchan@gentoo.org>
+ +nwmouse-20090906.183839.ebuild:
+ Version bump, bug #267396.
18 Aug 2008; Denis Dupeyron <calchan@gentoo.org> nwmouse-0.1.ebuild,
nwmouse-0.1-r1.ebuild:
diff --git a/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild b/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild
new file mode 100644
index 000000000000..d288b5b4ff4f
--- /dev/null
+++ b/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwmouse/nwmouse-20090906.183839.ebuild,v 1.1 2010/01/25 01:30:06 calchan Exp $
+
+inherit games
+
+DESCRIPTION="Hardware mouse cursors for Neverwinter Nights"
+HOMEPAGE="http://home.roadrunner.com/~nwmovies/"
+SRC_URI="http://dev.gentoo.org/~calchan/distfiles/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# I've looked at this stuff, and I can't find the problem myself, so I'm just
+# removing the warnings. If someone feels like finding the patch, that would be
+# great and I'll gladly include it.
+QA_EXECSTACK="${GAMES_PREFIX_OPT:1}/nwn/nwmouse.so"
+QA_TEXTRELS="${GAMES_PREFIX_OPT:1}/nwn/nwmouse.so"
+IUSE=""
+RESTRICT="strip mirror"
+
+RDEPEND="sys-libs/glibc
+ games-rpg/nwn-data
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-sdl )
+ >=games-rpg/nwn-1.68-r4
+ x86? (
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libX11
+ media-libs/libsdl )"
+
+dir="${GAMES_PREFIX_OPT}/nwn"
+
+pkg_setup() {
+ games_pkg_setup
+ elog "This package is pre-compiled so it will work on both x86 and amd64."
+}
+
+src_install() {
+ # libelf moved to games-rpg/nwn, see bug #210562
+ exeinto "${dir}"
+ doexe "${PN}.so" || die "Installation failed"
+ exeinto "${dir}/${PN}/libdis"
+ doexe "libdisasm.so" || die "Installation failed"
+ insinto "${dir}/${PN}/cursors"
+ doins -r cursors/* || die "Installation failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "When starting nwn the next time, nwmouse will scan the nwmain"
+ elog "binary for its hooks, store this information in:"
+ elog " ${dir}/nwmouse.ini"
+ elog "and exit. This is normal."
+ elog
+ elog "You will have to remove this file whenever you update nwn."
+}