summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-06-24 10:32:07 +0000
committerPacho Ramos <pacho@gentoo.org>2014-06-24 10:32:07 +0000
commit26ed07974500f00dfca40bebeddc8eca7c0aa25d (patch)
treee427ef12ffc4f36289234af6bbf11ca5859f080a
parentre-set paramiko in RDEPEND, noted by Arfrever (diff)
downloadgentoo-2-26ed07974500f00dfca40bebeddc8eca7c0aa25d.tar.gz
gentoo-2-26ed07974500f00dfca40bebeddc8eca7c0aa25d.tar.bz2
gentoo-2-26ed07974500f00dfca40bebeddc8eca7c0aa25d.zip
Version bump, also fixes (#514864 by Patrick Lauer)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
-rw-r--r--dev-libs/qof/ChangeLog10
-rw-r--r--dev-libs/qof/qof-0.8.7.ebuild55
2 files changed, 62 insertions, 3 deletions
diff --git a/dev-libs/qof/ChangeLog b/dev-libs/qof/ChangeLog
index 087fa2d7fd19..86963ee450a0 100644
--- a/dev-libs/qof/ChangeLog
+++ b/dev-libs/qof/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/qof
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/ChangeLog,v 1.37 2012/06/16 12:03:21 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/ChangeLog,v 1.38 2014/06/24 10:32:07 pacho Exp $
+
+*qof-0.8.7 (24 Jun 2014)
+
+ 24 Jun 2014; Pacho Ramos <pacho@gentoo.org> +qof-0.8.7.ebuild:
+ Version bump, also fixes (#514864 by Patrick Lauer)
16 Jun 2012; Pacho Ramos <pacho@gentoo.org>
-files/qof-0.7.4-remove_spurious_CFLAGS.patch, -qof-0.7.5-r1.ebuild:
@@ -149,4 +154,3 @@
15 Oct 2007; Christian Faulhammer <opfer@gentoo.org> +metadata.xml,
+qof-0.7.2.ebuild:
initial commit for bug 118517; taken from Sunrise
-
diff --git a/dev-libs/qof/qof-0.8.7.ebuild b/dev-libs/qof/qof-0.8.7.ebuild
new file mode 100644
index 000000000000..da8a6ff21794
--- /dev/null
+++ b/dev-libs/qof/qof-0.8.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/qof-0.8.7.ebuild,v 1.1 2014/06/24 10:32:07 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2
+
+DESCRIPTION="A Query Object Framework"
+HOMEPAGE="https://alioth.debian.org/projects/qof/"
+SRC_URI="mirror://debian//pool/main/q/${PN}/${PN}_${PV}.orig.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc nls sqlite"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/glib:2
+ sqlite? ( >=dev-db/sqlite-2.8.0:0 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ !dev-libs/qof:0
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-latex )
+"
+
+src_prepare() {
+ sed -i -e 's/-g2 //' configure.ac || die
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-error-on-warning \
+ --disable-static \
+ --disable-gdasql \
+ --disable-gdabackend \
+ $(use_enable nls) \
+ $(use_enable sqlite) \
+ $(use_enable doc doxygen) \
+ $(use_enable doc latex-docs) \
+ $(use_enable doc html-docs)
+}
+
+src_compile() {
+ # upstream bug ????
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_compile
+}