summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-03-04 23:31:44 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-03-04 23:31:44 +0000
commit276bb00564328065708ed3e46fe8d3aece719d8c (patch)
tree7049ed9b4f305eb840afad4d1aef4163d55c8d59
parentDelete older ebuild. (diff)
downloadgentoo-2-276bb00564328065708ed3e46fe8d3aece719d8c.tar.gz
gentoo-2-276bb00564328065708ed3e46fe8d3aece719d8c.tar.bz2
gentoo-2-276bb00564328065708ed3e46fe8d3aece719d8c.zip
Removing older versions
(Portage version: 2.1.9.41/cvs/Linux x86_64)
-rw-r--r--dev-php/xdebug/ChangeLog9
-rw-r--r--dev-php/xdebug/xdebug-2.0.2.ebuild79
-rw-r--r--dev-php/xdebug/xdebug-2.0.3.ebuild79
-rw-r--r--dev-php/xdebug/xdebug-2.0.5.ebuild87
-rw-r--r--dev-php/xdebug/xdebug-2.1.0.ebuild87
-rw-r--r--dev-php/xdebug/xdebug-2.1.0_rc1.ebuild87
6 files changed, 7 insertions, 421 deletions
diff --git a/dev-php/xdebug/ChangeLog b/dev-php/xdebug/ChangeLog
index 88f0792efc72..3ce5c1e6d257 100644
--- a/dev-php/xdebug/ChangeLog
+++ b/dev-php/xdebug/ChangeLog
@@ -1,6 +1,11 @@
-# ChangeLog for dev-php5/xdebug
+# ChangeLog for dev-php/xdebug
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/ChangeLog,v 1.27 2011/03/03 18:17:09 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/ChangeLog,v 1.28 2011/03/04 23:31:40 olemarkus Exp $
+
+ 04 Mar 2011; <olemarkus@gentoo.org> -xdebug-2.0.2.ebuild,
+ -xdebug-2.0.3.ebuild, -xdebug-2.0.5.ebuild, -xdebug-2.1.0_rc1.ebuild,
+ -xdebug-2.1.0.ebuild:
+ Removing older versions
30 Jan 2011; Raúl Porcel <armin76@gentoo.org> xdebug-2.1.0-r1.ebuild:
ia64/sparc stable
diff --git a/dev-php/xdebug/xdebug-2.0.2.ebuild b/dev-php/xdebug/xdebug-2.0.2.ebuild
deleted file mode 100644
index 089fe1abf009..000000000000
--- a/dev-php/xdebug/xdebug-2.0.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.0.2.ebuild,v 1.1 2011/03/03 18:17:09 olemarkus Exp $
-
-PHP_EXT_NAME="xdebug"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-
-inherit php-ext-source-r1
-
-KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
-
-MY_PV="${PV/_/}"
-MY_PV="${MY_PV/rc/RC}"
-
-DESCRIPTION="A PHP Debugging and Profiling extension."
-HOMEPAGE="http://www.xdebug.org/"
-SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
-LICENSE="Xdebug"
-SLOT="0"
-IUSE=""
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DEPEND="!dev-php5/ZendOptimizer"
-RDEPEND="${DEPEND}
- ~dev-php/xdebug-client-${PV}"
-
-need_php_by_category
-
-src_install() {
- php-ext-source-r1_src_install
- dodoc-php NEWS README Changelog CREDITS LICENSE
-
- php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
- php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
- php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
- php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_children" '"128"'
-}
diff --git a/dev-php/xdebug/xdebug-2.0.3.ebuild b/dev-php/xdebug/xdebug-2.0.3.ebuild
deleted file mode 100644
index faafccd0bf99..000000000000
--- a/dev-php/xdebug/xdebug-2.0.3.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.0.3.ebuild,v 1.1 2011/03/03 18:17:09 olemarkus Exp $
-
-PHP_EXT_NAME="xdebug"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-
-inherit php-ext-source-r1
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-MY_PV="${PV/_/}"
-MY_PV="${MY_PV/rc/RC}"
-
-DESCRIPTION="A PHP Debugging and Profiling extension."
-HOMEPAGE="http://www.xdebug.org/"
-SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
-LICENSE="Xdebug"
-SLOT="0"
-IUSE=""
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DEPEND="!dev-php5/ZendOptimizer"
-RDEPEND="${DEPEND}
- ~dev-php/xdebug-client-${PV}"
-
-need_php_by_category
-
-src_install() {
- php-ext-source-r1_src_install
- dodoc-php NEWS README Changelog CREDITS LICENSE
-
- php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
- php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
- php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
- php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_children" '"128"'
-}
diff --git a/dev-php/xdebug/xdebug-2.0.5.ebuild b/dev-php/xdebug/xdebug-2.0.5.ebuild
deleted file mode 100644
index 25a59b58c281..000000000000
--- a/dev-php/xdebug/xdebug-2.0.5.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.0.5.ebuild,v 1.1 2011/03/03 18:17:09 olemarkus Exp $
-
-PHP_EXT_NAME="xdebug"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-
-inherit php-ext-source-r1
-
-KEYWORDS="~alpha amd64 hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
-
-MY_PV="${PV/_/}"
-MY_PV="${MY_PV/rc/RC}"
-
-DESCRIPTION="A PHP debugging and profiling extension"
-HOMEPAGE="http://www.xdebug.org/"
-SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
-LICENSE="Xdebug"
-SLOT="0"
-IUSE=""
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DEPEND="!dev-php5/ZendOptimizer"
-RDEPEND="${DEPEND}
- ~dev-php/xdebug-client-${PV}"
-
-need_php_by_category
-
-src_install() {
- php-ext-source-r1_src_install
- dodoc-php NEWS README Changelog CREDITS LICENSE
-
- php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
- php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
- php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
- php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_children" '"128"'
-}
-
-pkg_postinst() {
- ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
- ewarn "installed as a dependency, and not all users will want xdebug to be"
- ewarn "enabled by default. If you want to enable it, you should edit the"
- ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
- ewarn "call xdebug_enable() in your code."
-}
diff --git a/dev-php/xdebug/xdebug-2.1.0.ebuild b/dev-php/xdebug/xdebug-2.1.0.ebuild
deleted file mode 100644
index b048279c70a0..000000000000
--- a/dev-php/xdebug/xdebug-2.1.0.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.1.0.ebuild,v 1.1 2011/03/03 18:17:09 olemarkus Exp $
-
-PHP_EXT_NAME="xdebug"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-
-inherit php-ext-source-r1
-
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
-
-MY_PV="${PV/_/}"
-MY_PV="${MY_PV/rc/RC}"
-
-DESCRIPTION="A PHP debugging and profiling extension"
-HOMEPAGE="http://www.xdebug.org/"
-SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
-LICENSE="Xdebug"
-SLOT="0"
-IUSE=""
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DEPEND="!dev-php5/ZendOptimizer"
-RDEPEND="${DEPEND}
- ~dev-php/xdebug-client-${PV}"
-
-need_php_by_category
-
-src_install() {
- php-ext-source-r1_src_install
- dodoc-php NEWS README Changelog CREDITS LICENSE
-
- php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
- php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
- php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
- php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_children" '"128"'
-}
-
-pkg_postinst() {
- ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
- ewarn "installed as a dependency, and not all users will want xdebug to be"
- ewarn "enabled by default. If you want to enable it, you should edit the"
- ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
- ewarn "call xdebug_enable() in your code."
-}
diff --git a/dev-php/xdebug/xdebug-2.1.0_rc1.ebuild b/dev-php/xdebug/xdebug-2.1.0_rc1.ebuild
deleted file mode 100644
index 932f25de9071..000000000000
--- a/dev-php/xdebug/xdebug-2.1.0_rc1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xdebug/xdebug-2.1.0_rc1.ebuild,v 1.1 2011/03/03 18:17:09 olemarkus Exp $
-
-PHP_EXT_NAME="xdebug"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="yes"
-
-inherit php-ext-source-r1
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-MY_PV="${PV/_/}"
-MY_PV="${MY_PV/rc/RC}"
-
-DESCRIPTION="A PHP debugging and profiling extension"
-HOMEPAGE="http://www.xdebug.org/"
-SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
-LICENSE="Xdebug"
-SLOT="0"
-IUSE=""
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DEPEND="!dev-php5/ZendOptimizer"
-RDEPEND="${DEPEND}
- ~dev-php/xdebug-client-${PV}"
-
-need_php_by_category
-
-src_install() {
- php-ext-source-r1_src_install
- dodoc-php NEWS README Changelog CREDITS LICENSE
-
- php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
- php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
- php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
- php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
- php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
- php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
- php-ext-base-r1_addtoinifiles "xdebug.var_display_max_children" '"128"'
-}
-
-pkg_postinst() {
- ewarn "We have set xdebug.default_enable to 0 (off), as xdebug can be"
- ewarn "installed as a dependency, and not all users will want xdebug to be"
- ewarn "enabled by default. If you want to enable it, you should edit the"
- ewarn "ini file and set xdebug.default_enable to 1. Alternatively you can"
- ewarn "call xdebug_enable() in your code."
-}