summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-10-25 13:14:14 +0000
committerMarkus Meier <maekke@gentoo.org>2008-10-25 13:14:14 +0000
commit2798abad3e6754d17d9cab8532b56c286b556997 (patch)
tree2b1863c1929914104af9a3abe6d70cfe8ebfa43e
parentKeyworded ~ppc. Closes bug #244238 (diff)
downloadgentoo-2-2798abad3e6754d17d9cab8532b56c286b556997.tar.gz
gentoo-2-2798abad3e6754d17d9cab8532b56c286b556997.tar.bz2
gentoo-2-2798abad3e6754d17d9cab8532b56c286b556997.zip
do not prestrip files, bug #243836; respect CC variable
(Portage version: 2.2_rc12/cvs/Linux 2.6.27.3 i686)
-rw-r--r--media-gfx/tuxpaint/ChangeLog6
-rw-r--r--media-gfx/tuxpaint/files/tuxpaint-0.9.19-strip.patch11
-rw-r--r--media-gfx/tuxpaint/tuxpaint-0.9.19.ebuild7
3 files changed, 20 insertions, 4 deletions
diff --git a/media-gfx/tuxpaint/ChangeLog b/media-gfx/tuxpaint/ChangeLog
index a0254d7abfdf..0e3a67403b25 100644
--- a/media-gfx/tuxpaint/ChangeLog
+++ b/media-gfx/tuxpaint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/tuxpaint
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/tuxpaint/ChangeLog,v 1.43 2008/10/21 20:25:04 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tuxpaint/ChangeLog,v 1.44 2008/10/25 13:14:14 maekke Exp $
+
+ 25 Oct 2008; Markus Meier <maekke@gentoo.org>
+ +files/tuxpaint-0.9.19-strip.patch, tuxpaint-0.9.19.ebuild:
+ do not prestrip files, bug #243836; respect CC variable
21 Oct 2008; Thomas Anderson <gentoofan23@gentoo.org>
tuxpaint-0.9.19.ebuild:
diff --git a/media-gfx/tuxpaint/files/tuxpaint-0.9.19-strip.patch b/media-gfx/tuxpaint/files/tuxpaint-0.9.19-strip.patch
new file mode 100644
index 000000000000..8e031c537add
--- /dev/null
+++ b/media-gfx/tuxpaint/files/tuxpaint-0.9.19-strip.patch
@@ -0,0 +1,11 @@
+diff -ru tuxpaint-0.9.19.orig/magic/Makefile tuxpaint-0.9.19/magic/Makefile
+--- tuxpaint-0.9.19.orig/magic/Makefile 2008-10-25 14:58:57.000000000 +0200
++++ tuxpaint-0.9.19/magic/Makefile 2008-10-25 14:59:13.000000000 +0200
+@@ -50,7 +50,6 @@
+ shift.$(SO_TYPE) \
+ calligraphy.$(SO_TYPE) \
+ distortion.$(SO_TYPE)
+- @strip *.$(SO_TYPE)
+
+ install:
+ cd .. ; make install-magic-plugins
diff --git a/media-gfx/tuxpaint/tuxpaint-0.9.19.ebuild b/media-gfx/tuxpaint/tuxpaint-0.9.19.ebuild
index d72c95c3a370..d1b83714b22d 100644
--- a/media-gfx/tuxpaint/tuxpaint-0.9.19.ebuild
+++ b/media-gfx/tuxpaint/tuxpaint-0.9.19.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/tuxpaint/tuxpaint-0.9.19.ebuild,v 1.3 2008/10/21 20:25:04 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tuxpaint/tuxpaint-0.9.19.ebuild,v 1.4 2008/10/25 13:14:14 maekke Exp $
-inherit eutils gnome2-utils multilib
+inherit eutils gnome2-utils multilib toolchain-funcs
DESCRIPTION="Drawing program designed for young children"
HOMEPAGE="http://www.tuxpaint.org/"
@@ -34,6 +34,7 @@ src_unpack() {
# Sanitize the Makefile and correct a few other issues.
epatch "${FILESDIR}/${P}-gentoo.patch"
epatch "${FILESDIR}/${P}-libpng.patch"
+ epatch "${FILESDIR}/${P}-strip.patch"
# Make multilib-strict compliant, see bug #200740
sed -i -e "s:/GET_LIBDIR/:/$(get_libdir)/:" Makefile || die "sed failed"
@@ -46,7 +47,7 @@ src_compile() {
use svg || myopts="${myopts} nosvg"
# emake may break things
- make ${myopts} || die "Compilation failed"
+ make CC="$(tc-getCC)" ${myopts} || die "Compilation failed"
}
src_install () {