summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-08-06 16:47:54 +0000
committerSven Wegener <swegener@gentoo.org>2005-08-06 16:47:54 +0000
commit2d8eeb8380b1b0c3fbf5e55681f4aade5045a8aa (patch)
tree019be1fd8b1fa53be5d67a86adb9028ed451c688
parentStable on alpha. (diff)
downloadgentoo-2-2d8eeb8380b1b0c3fbf5e55681f4aade5045a8aa.tar.gz
gentoo-2-2d8eeb8380b1b0c3fbf5e55681f4aade5045a8aa.tar.bz2
gentoo-2-2d8eeb8380b1b0c3fbf5e55681f4aade5045a8aa.zip
remove default src_compile
(Portage version: 2.0.51.22-r2)
-rw-r--r--x11-libs/nucleo/nucleo-0.1-r1.ebuild9
-rw-r--r--x11-libs/nucleo/nucleo-0.1_p20041130.ebuild13
-rw-r--r--x11-libs/nucleo/nucleo-0.1_p20041216.ebuild13
-rw-r--r--x11-misc/bbcd/bbcd-0.3.1-r1.ebuild17
-rw-r--r--x11-misc/bbcd/bbcd-0.3.1.ebuild11
5 files changed, 19 insertions, 44 deletions
diff --git a/x11-libs/nucleo/nucleo-0.1-r1.ebuild b/x11-libs/nucleo/nucleo-0.1-r1.ebuild
index eeaad991a0d7..bf890b851e31 100644
--- a/x11-libs/nucleo/nucleo-0.1-r1.ebuild
+++ b/x11-libs/nucleo/nucleo-0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1-r1.ebuild,v 1.5 2005/02/10 08:39:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1-r1.ebuild,v 1.6 2005/08/06 16:45:37 swegener Exp $
IUSE=""
@@ -20,12 +20,7 @@ SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86 ppc"
-src_compile() {
- econf || die "configure failed"
- emake || die "make failed"
-}
-
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README ChangeLog AUTHORS NEWS
}
diff --git a/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild b/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild
index 053ca89dd640..3fe2aa80d437 100644
--- a/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild
+++ b/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild,v 1.3 2005/02/10 08:39:16 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1_p20041130.ebuild,v 1.4 2005/08/06 16:45:37 swegener Exp $
inherit eutils
@@ -24,16 +24,11 @@ S="${WORKDIR}/${P/_p*/}"
src_unpack() {
unpack ${A}
- cd ${S}/nucleo/gl/texture
- epatch ${FILESDIR}/${P/_p*/}-nv.patch
-}
-
-src_compile() {
- econf || die "configure failed"
- emake || die "make failed"
+ cd "${S}"/nucleo/gl/texture
+ epatch "${FILESDIR}"/${P/_p*/}-nv.patch
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README ChangeLog AUTHORS NEWS
}
diff --git a/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild b/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild
index ce80ff26f22b..7427a0b02322 100644
--- a/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild
+++ b/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild,v 1.3 2005/04/23 00:36:43 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/nucleo/nucleo-0.1_p20041216.ebuild,v 1.4 2005/08/06 16:45:37 swegener Exp $
inherit eutils
@@ -24,16 +24,11 @@ S="${WORKDIR}/${P/_p*/}"
src_unpack() {
unpack ${A}
- cd ${S}/nucleo/gl/texture
- epatch ${FILESDIR}/${P/_p*/}-nv.patch
-}
-
-src_compile() {
- econf || die "configure failed"
- emake || die "make failed"
+ cd "${S}"/nucleo/gl/texture
+ epatch "${FILESDIR}"/${P/_p*/}-nv.patch
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc README ChangeLog AUTHORS NEWS
}
diff --git a/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild b/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
index 182d456d58ed..ecacb491b146 100644
--- a/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
+++ b/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild,v 1.5 2004/06/24 22:12:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/bbcd-0.3.1-r1.ebuild,v 1.6 2005/08/06 16:47:54 swegener Exp $
inherit eutils
@@ -16,20 +16,15 @@ DEPEND="virtual/blackbox
media-libs/libcdaudio"
src_unpack() {
- unpack ${P}.tar.gz
- epatch ${FILESDIR}/${P}_${PV}a.diff.gz
- epatch ${FILESDIR}/${P}-gcc3.3.patch
-}
-
-src_compile() {
- econf || die
- emake || die
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}_${PV}a.diff.gz
+ epatch "${FILESDIR}"/${P}-gcc3.3.patch
}
src_install () {
make \
- DESTDIR=${D} \
+ DESTDIR="${D}" \
install || die
- rm -rf ${D}/usr/doc
+ rm -rf "${D}"/usr/doc
dodoc AUTHORS BUGS ChangeLog NEWS README
}
diff --git a/x11-misc/bbcd/bbcd-0.3.1.ebuild b/x11-misc/bbcd/bbcd-0.3.1.ebuild
index 21ca25fb481a..f6e7bc1cd86c 100644
--- a/x11-misc/bbcd/bbcd-0.3.1.ebuild
+++ b/x11-misc/bbcd/bbcd-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/bbcd-0.3.1.ebuild,v 1.6 2004/07/15 00:49:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbcd/bbcd-0.3.1.ebuild,v 1.7 2005/08/06 16:47:54 swegener Exp $
DESCRIPTION="Basic CD Player for blackbox wm"
HOMEPAGE="http://tranber1.free.fr/bbcd.html"
@@ -13,15 +13,10 @@ IUSE=""
DEPEND="virtual/blackbox
media-libs/libcdaudio"
-src_compile() {
- econf || die
- emake || die
-}
-
src_install () {
make \
- DESTDIR=${D} \
+ DESTDIR="${D}" \
install || die
- rm -rf ${D}/usr/doc
+ rm -rf "${D}"/usr/doc
dodoc AUTHORS BUGS ChangeLog NEWS README
}