summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-10-13 08:00:07 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-10-13 08:00:07 +0000
commit33085fe57c88f1952fa3d0d3b4a89fdad12f92bb (patch)
tree1c38c8a2fbfe8ecae3c00dcfb4a669e31c997502
parentFixed build issue: specify spool-dir and always depend on mailbase, bug #3869... (diff)
downloadgentoo-2-33085fe57c88f1952fa3d0d3b4a89fdad12f92bb.tar.gz
gentoo-2-33085fe57c88f1952fa3d0d3b4a89fdad12f92bb.tar.bz2
gentoo-2-33085fe57c88f1952fa3d0d3b4a89fdad12f92bb.zip
No more rely on build-time opengl choice. Bug #377295
(Portage version: 2.1.10.26/cvs/Linux i686)
-rw-r--r--games-sports/foobillard/ChangeLog15
-rw-r--r--games-sports/foobillard/foobillard-3.0a.ebuild14
2 files changed, 13 insertions, 16 deletions
diff --git a/games-sports/foobillard/ChangeLog b/games-sports/foobillard/ChangeLog
index 3126c1e38b10..e821f365b268 100644
--- a/games-sports/foobillard/ChangeLog
+++ b/games-sports/foobillard/ChangeLog
@@ -1,13 +1,16 @@
# ChangeLog for games-sports/foobillard
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.18 2011/02/21 20:28:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/ChangeLog,v 1.19 2011/10/13 08:00:07 tupone Exp $
+
+ 13 Oct 2011; Tupone Alfredo <tupone@gentoo.org> foobillard-3.0a.ebuild:
+ No more rely on build-time opengl choice. Bug #377295 by Michał Górny
21 Feb 2011; Michael Sterrett <mr_bones_@gentoo.org>
foobillard-3.0a.ebuild, +files/foobillard-3.0a-gl-clamp.patch:
work around issues with some drivers related to GL_CLAMP (bug #355821)
- patch submitted by Alan Swanson
- 16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ 16 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
foobillard-3.0a.ebuild:
virtual/glut -> media-libs/glut
@@ -22,15 +25,15 @@
24 Feb 2007; Tristan Heaven <nyhm@gentoo.org> foobillard-3.0a.ebuild:
Fix dependencies, bug #168179
- 12 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> foobillard-3.0a.ebuild:
+ 12 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> foobillard-3.0a.ebuild:
Force latest versions of autotools.
- 02 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> foobillard-3.0a.ebuild:
+ 02 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> foobillard-3.0a.ebuild:
Add ~x86-fbsd keyword.
01 Oct 2006; Michael Sterrett <mr_bones_@gentoo.org>
+files/foobillard-3.0a-fbsd.patch, foobillard-3.0a.ebuild:
- fixup nvidia detection and add fbsd support - patch from Diego Pettenò (bug
+ fixup nvidia detection and add fbsd support - patch from Diego Pettenò (bug
#149718)
29 Jan 2006; Joshua Baergen <joshuabaergen@gentoo.org>
@@ -85,7 +88,7 @@
*foobillard-1.5 (21 Jun 2002)
- 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> foobillard-1.5.ebuild :
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> foobillard-1.5.ebuild :
Added KEYWORDS, SLOT.
21 Jun 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
diff --git a/games-sports/foobillard/foobillard-3.0a.ebuild b/games-sports/foobillard/foobillard-3.0a.ebuild
index 0e32b0d39947..622e0fb02158 100644
--- a/games-sports/foobillard/foobillard-3.0a.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.15 2011/02/21 20:28:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/foobillard/foobillard-3.0a.ebuild,v 1.16 2011/10/13 08:00:07 tupone Exp $
EAPI=2
inherit eutils autotools games
@@ -12,7 +12,7 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-IUSE="sdl"
+IUSE="sdl video_cards_nvidia"
RDEPEND="x11-libs/libXaw
x11-libs/libXi
@@ -22,8 +22,7 @@ RDEPEND="x11-libs/libXaw
media-libs/libpng
sdl? ( media-libs/libsdl )
!sdl? ( media-libs/freeglut )"
-DEPEND="${RDEPEND}
- app-admin/eselect-opengl"
+DEPEND="${RDEPEND}"
src_prepare() {
epatch \
@@ -36,16 +35,11 @@ src_prepare() {
}
src_configure() {
- local myconf
- [[ "$(eselect opengl show)" == 'nvidia' ]] \
- && myconf='--enable-nvidia=yes' \
- || myconf='--enable-nvidia=no'
-
egamesconf \
--enable-sound \
$(use_enable sdl SDL) \
$(use_enable !sdl glut) \
- ${myconf}
+ $(use_enable video_cards_nvidia nvidia)
}
src_install() {