summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-25 23:08:56 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-25 23:08:56 +0000
commit37b6724068a0ba8e686b1442b39b32e41ca51d75 (patch)
treeba6328a8100721cbc90424e89a2ced813819dc47
parentFix unintended patch change for 2.46, bug #533544. (diff)
downloadgentoo-2-37b6724068a0ba8e686b1442b39b32e41ca51d75.tar.gz
gentoo-2-37b6724068a0ba8e686b1442b39b32e41ca51d75.tar.bz2
gentoo-2-37b6724068a0ba8e686b1442b39b32e41ca51d75.zip
Convert to distutils-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--dev-python/pylibacl/ChangeLog10
-rw-r--r--dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild36
2 files changed, 43 insertions, 3 deletions
diff --git a/dev-python/pylibacl/ChangeLog b/dev-python/pylibacl/ChangeLog
index 61305f7b3651..d17a2927c0dc 100644
--- a/dev-python/pylibacl/ChangeLog
+++ b/dev-python/pylibacl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pylibacl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/ChangeLog,v 1.38 2012/09/23 04:27:22 mattst88 Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/ChangeLog,v 1.39 2014/12/25 23:08:56 mgorny Exp $
+
+*pylibacl-0.5.0-r1 (25 Dec 2014)
+
+ 25 Dec 2014; Michał Górny <mgorny@gentoo.org> +pylibacl-0.5.0-r1.ebuild:
+ Convert to distutils-r1.
23 Sep 2012; Matt Turner <mattst88@gentoo.org> pylibacl-0.5.0.ebuild:
Added ~alpha ~mips, bug 406911.
@@ -130,4 +135,3 @@
+pylibacl-0.2.1.ebuild:
Initial commit, ebuild submitted by Thomas Bettler
<bettlertho@sis.unibe.ch>, dependancy for new rdiff-backup.
-
diff --git a/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild b/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..804e9e51ea99
--- /dev/null
+++ b/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylibacl/pylibacl-0.5.0-r1.ebuild,v 1.1 2014/12/25 23:08:56 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="POSIX ACLs (Access Control Lists) for Python"
+HOMEPAGE="http://sourceforge.net/projects/pylibacl/ http://pypi.python.org/pypi/pylibacl"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/acl"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# Tests are missing in the tarball.
+RESTRICT="test"
+
+python_test() {
+ if ! "${PYTHON}" test/test_acls.py; then
+ eerror
+ eerror "If you got the following errors:"
+ eerror "\"IOError: [Errno 95] Operation not supported\","
+ eerror "then you should remount the filesystem containing"
+ eerror "build directory with \"acl\" option enabled."
+ eerror
+ die "Tests fail with ${EPYTHON}"
+ fi
+}