summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-12-22 21:16:27 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-12-22 21:16:27 +0000
commit39f4bee084a53e6ac2793828c7caa81d7401d8d5 (patch)
tree50e141c91c7f3906dd95d20b624bd9fb55806365
parentFix building against llvm-3.2, bug #447962. (diff)
downloadgentoo-2-39f4bee084a53e6ac2793828c7caa81d7401d8d5.tar.gz
gentoo-2-39f4bee084a53e6ac2793828c7caa81d7401d8d5.tar.bz2
gentoo-2-39f4bee084a53e6ac2793828c7caa81d7401d8d5.zip
Version bump.
(Portage version: 2.2.0_alpha149_p1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
-rw-r--r--dev-haskell/bzlib/ChangeLog8
-rw-r--r--dev-haskell/bzlib/bzlib-0.5.0.2.ebuild28
-rw-r--r--dev-haskell/bzlib/bzlib-0.5.0.4.ebuild (renamed from dev-haskell/bzlib/bzlib-0.5.0.1.ebuild)14
3 files changed, 14 insertions, 36 deletions
diff --git a/dev-haskell/bzlib/ChangeLog b/dev-haskell/bzlib/ChangeLog
index b177ec546f8a..55f068c86d69 100644
--- a/dev-haskell/bzlib/ChangeLog
+++ b/dev-haskell/bzlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/bzlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bzlib/ChangeLog,v 1.7 2012/09/12 15:14:36 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bzlib/ChangeLog,v 1.8 2012/12/22 21:16:27 slyfox Exp $
+
+*bzlib-0.5.0.4 (22 Dec 2012)
+
+ 22 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org> +bzlib-0.5.0.4.ebuild,
+ -bzlib-0.5.0.1.ebuild, -bzlib-0.5.0.2.ebuild:
+ Version bump.
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> bzlib-0.5.0.1.ebuild,
bzlib-0.5.0.2.ebuild, bzlib-0.5.0.3.ebuild:
diff --git a/dev-haskell/bzlib/bzlib-0.5.0.2.ebuild b/dev-haskell/bzlib/bzlib-0.5.0.2.ebuild
deleted file mode 100644
index e19d55c987d7..000000000000
--- a/dev-haskell/bzlib/bzlib-0.5.0.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bzlib/bzlib-0.5.0.2.ebuild,v 1.2 2012/09/12 15:14:36 qnikst Exp $
-
-# ebuild generated by hackport 0.2.14
-
-EAPI="3"
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Compression and decompression in the bzip2 format"
-HOMEPAGE="http://hackage.haskell.org/package/bzlib"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/ghc-6.8.2
- >=app-arch/bzip2-1.0"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
-
-# Workaround this error when compiling with ghc 7.0.4:
-# Stream.hsc:62:21: error: missing binary operator before token "("
-CABAL_EXTRA_CONFIGURE_FLAGS="--hsc2hs-options=--include=${S}/dist/build/autogen/cabal_macros.h"
diff --git a/dev-haskell/bzlib/bzlib-0.5.0.1.ebuild b/dev-haskell/bzlib/bzlib-0.5.0.4.ebuild
index 44ae9133d88d..bbb3c1e5d2cf 100644
--- a/dev-haskell/bzlib/bzlib-0.5.0.1.ebuild
+++ b/dev-haskell/bzlib/bzlib-0.5.0.4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bzlib/bzlib-0.5.0.1.ebuild,v 1.2 2012/09/12 15:14:36 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bzlib/bzlib-0.5.0.4.ebuild,v 1.1 2012/12/22 21:16:27 slyfox Exp $
-# ebuild generated by hackport 0.2.13
+EAPI=5
-EAPI="3"
+# ebuild generated by hackport 0.3.9999
-CABAL_FEATURES="lib profile haddock hscolour"
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Compression and decompression in the bzip2 format"
@@ -14,11 +14,11 @@ HOMEPAGE="http://hackage.haskell.org/package/bzlib"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE=""
-RDEPEND=">=dev-lang/ghc-6.8.2
- >=app-arch/bzip2-1.0"
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+ app-arch/bzip2"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6"