summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-06 19:00:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-06 19:00:15 +0000
commit3ce57725af3028932625f90d64b87e44e7152cd5 (patch)
treee334ebb7d7befaa677ff1dd33ee6c73b6349d8a0
parentReplace base inherit by eutils inherit. Update FDO MIME desktop database and ... (diff)
downloadgentoo-2-3ce57725af3028932625f90d64b87e44e7152cd5.tar.gz
gentoo-2-3ce57725af3028932625f90d64b87e44e7152cd5.tar.bz2
gentoo-2-3ce57725af3028932625f90d64b87e44e7152cd5.zip
Version bump wrt #503656 by "Nikoli" and "Uwe L. Korn"
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
-rw-r--r--media-libs/libechonest/ChangeLog9
-rw-r--r--media-libs/libechonest/libechonest-2.2.0.ebuild32
2 files changed, 39 insertions, 2 deletions
diff --git a/media-libs/libechonest/ChangeLog b/media-libs/libechonest/ChangeLog
index c8186e0576ad..2bafd5759bfb 100644
--- a/media-libs/libechonest/ChangeLog
+++ b/media-libs/libechonest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libechonest
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libechonest/ChangeLog,v 1.26 2013/10/29 20:03:16 maksbotan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libechonest/ChangeLog,v 1.27 2014/04/06 19:00:15 ssuominen Exp $
+
+*libechonest-2.2.0 (06 Apr 2014)
+
+ 06 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> +libechonest-2.2.0.ebuild:
+ Version bump wrt #503656 by "Nikoli" and "Uwe L. Korn"
29 Oct 2013; Maxim Koltsov <maksbotan@gentoo.org> libechonest-2.0.3.ebuild,
libechonest-2.1.0.ebuild:
diff --git a/media-libs/libechonest/libechonest-2.2.0.ebuild b/media-libs/libechonest/libechonest-2.2.0.ebuild
new file mode 100644
index 000000000000..77b8029f42e7
--- /dev/null
+++ b/media-libs/libechonest/libechonest-2.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libechonest/libechonest-2.2.0.ebuild,v 1.1 2014/04/06 19:00:15 ssuominen Exp $
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A library for communicating with The Echo Nest"
+HOMEPAGE="http://projects.kde.org/projects/playground/libs/libechonest"
+SRC_URI="http://files.lfranchi.com/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/2.2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT="test" # Networking required
+
+RDEPEND=">=dev-libs/qjson-0.5
+ dev-qt/qtcore:4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-qt/qttest:4"
+
+DOCS=( AUTHORS README TODO )
+
+src_configure() {
+ local mycmakeargs=(
+ -DECHONEST_BUILD_TESTS=OFF
+ )
+ cmake-utils_src_configure
+}