summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-12 13:18:37 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-12 13:18:37 +0000
commit4018451906d31efbee6ddbed305c3819893c1d85 (patch)
tree0c1aeda7c2b413b96fd315d902b3c9f8915b51f5
parentMarked ppc/ppc64 stable for bug #336462. (diff)
downloadgentoo-2-4018451906d31efbee6ddbed305c3819893c1d85.tar.gz
gentoo-2-4018451906d31efbee6ddbed305c3819893c1d85.tar.bz2
gentoo-2-4018451906d31efbee6ddbed305c3819893c1d85.zip
Version Bump, fix for missing LDFLAGS 335299
(Portage version: 2.2_rc79/cvs/Linux x86_64)
-rw-r--r--app-misc/cw/ChangeLog10
-rw-r--r--app-misc/cw/cw-1.0.16.ebuild65
-rw-r--r--app-misc/cw/files/1.0.16-ldflags.patch18
3 files changed, 91 insertions, 2 deletions
diff --git a/app-misc/cw/ChangeLog b/app-misc/cw/ChangeLog
index f1b7f6cabfa8..9d530b39aafe 100644
--- a/app-misc/cw/ChangeLog
+++ b/app-misc/cw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/cw
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cw/ChangeLog,v 1.20 2009/09/23 16:00:44 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cw/ChangeLog,v 1.21 2010/09/12 13:18:33 jlec Exp $
+
+*cw-1.0.16 (12 Sep 2010)
+
+ 12 Sep 2010; Justin Lecher <jlec@gentoo.org> +files/1.0.16-ldflags.patch,
+ +cw-1.0.16.ebuild:
+ Version Bump, fix for missing LDFLAGS 335299
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> cw-1.0.15.ebuild:
Remove virtual/libc
diff --git a/app-misc/cw/cw-1.0.16.ebuild b/app-misc/cw/cw-1.0.16.ebuild
new file mode 100644
index 000000000000..d93898c11cf2
--- /dev/null
+++ b/app-misc/cw/cw-1.0.16.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cw/cw-1.0.16.ebuild,v 1.1 2010/09/12 13:18:34 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A non-intrusive real-time ANSI color wrapper for common unix-based commands"
+HOMEPAGE="http://cwrapper.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cwrapper/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+ sed -i 's|\(CWLIB=\)/usr/local/lib/cw|\1/usr/libexec/cw|' bin/colorcfg || \
+ die "sed failed"
+ tc-export CC
+}
+
+#src_configure() {
+# econf \
+# CFLAGS="${CFLAGS}" \
+# LDFLAGS="${LDFLAGS}"
+#}
+
+src_compile() {
+ emake \
+ local || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/share/cw
+ doins etc/* || die
+
+ exeinto /usr/libexec/cw
+ doexe def/* || die
+
+ doman man/* || die
+ dodoc CHANGES CONTRIB INSTALL README PLATFORM doc/README* || die
+
+ dobin bin/{cw,cwu,colorcfg} || die
+ # app-misc/color currently conflicts; hopefully 'colors' is safe
+ newbin bin/color colors
+}
+
+pkg_postinst() {
+ ebegin "Updating definition files"
+ cwu /usr/libexec/cw /usr/bin/cw >/dev/null
+ eend $?
+
+ elog "To enable color-wrapper, as your user, run:"
+ elog " colorcfg [1|2|3]"
+ elog "to add relevant environment variables to your ~/.bash_profile"
+ elog "Run colorcfg without options to see what [1|2|3] means."
+ elog
+ elog "After sourcing your ~/.bash_profile, commands for which definitions"
+ elog "are provided should have colored output."
+ elog
+ elog "To enable/disable colored output, run: 'colors [on|off]'."
+}
diff --git a/app-misc/cw/files/1.0.16-ldflags.patch b/app-misc/cw/files/1.0.16-ldflags.patch
new file mode 100644
index 000000000000..f2186a87b17f
--- /dev/null
+++ b/app-misc/cw/files/1.0.16-ldflags.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile.in b/Makefile.in
+index 9a6e4ec..e510493 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -19,11 +19,11 @@ all:
+
+ cw:
+ @$(ECHO) "* Compiling cw(color wrapper)..."
+- @$(CC) src/cw.c -o bin/cw @CFLAGS@ @LIBS@ @DEFS@
++ $(CC) $(CFLAGS) -c src/cw.c -o bin/cw @CFLAGS@ @LIBS@ @DEFS@
+
+ cwu:
+ @$(ECHO) "* Compiling cwu(color wrapper directive updater)..."
+- @$(CC) src/cwu.c -o bin/cwu @CFLAGS@
++ $(CC) $(CFLAGS) $(LDFLAGS) src/cwu.c -o bin/cwu
+
+ local: cw cwu
+