summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-10-23 13:16:50 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-10-23 13:16:50 +0000
commit4413a0ab2f5f5c5e192354d09bac14c374c69ae7 (patch)
tree6100fb3504f0e6a45b64baaab34f2150da5b7118
parentInitial import. Thanks to mft at GentooJP EbuildJP, http://ebuild.gentoo.gr.j... (diff)
downloadgentoo-2-4413a0ab2f5f5c5e192354d09bac14c374c69ae7.tar.gz
gentoo-2-4413a0ab2f5f5c5e192354d09bac14c374c69ae7.tar.bz2
gentoo-2-4413a0ab2f5f5c5e192354d09bac14c374c69ae7.zip
new release
-rw-r--r--sec-policy/selinux-base-policy/ChangeLog9
-rw-r--r--sec-policy/selinux-base-policy/files/digest-selinux-base-policy-200410231
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-20041023.ebuild86
3 files changed, 95 insertions, 1 deletions
diff --git a/sec-policy/selinux-base-policy/ChangeLog b/sec-policy/selinux-base-policy/ChangeLog
index 3d0e2eff3c52..4d05150905c4 100644
--- a/sec-policy/selinux-base-policy/ChangeLog
+++ b/sec-policy/selinux-base-policy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sec-policy/selinux-base-policy
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.30 2004/09/06 21:26:41 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.31 2004/10/23 13:16:50 pebenito Exp $
+
+*selinux-base-policy-20041023 (23 Oct 2004)
+
+ 23 Oct 2004; Chris PeBenito <pebenito@gentoo.org>
+ +selinux-base-policy-20041023.ebuild:
+ New release with 1.16 merge. Tcpd and inetd have been deprecated since they
+ are not in the base system anymore, and probably no one uses them anyway.
*selinux-base-policy-20040906 (06 Sep 2004)
diff --git a/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20041023 b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20041023
new file mode 100644
index 000000000000..642cd0ee6458
--- /dev/null
+++ b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20041023
@@ -0,0 +1 @@
+MD5 287240a8a3f77180dac0acbd64f158e7 selinux-base-policy-20041023.tar.bz2 71327
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-20041023.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-20041023.ebuild
new file mode 100644
index 000000000000..5f4dfd5e11b0
--- /dev/null
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-20041023.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-20041023.ebuild,v 1.1 2004/10/23 13:16:50 pebenito Exp $
+
+IUSE="build"
+
+inherit eutils
+
+DESCRIPTION="Gentoo base policy for SELinux"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+DEPEND="build? ( sys-devel/make
+ sys-devel/m4 )"
+RDEPEND="sys-devel/m4
+ sys-devel/make"
+
+S=${WORKDIR}/base-policy
+
+[ -z ${POLICYDIR} ] && POLICYDIR="/etc/security/selinux/src/policy"
+
+# deprecated policies:
+DEPRECATED="domains/program/devfsd.te domains/program/opt.te
+ file_contexts/program/devfsd.fc file_contexts/program/opt.fc
+ file_contexts/users.fc domains/program/inetd.te
+ domains/program/tcpd.te file_contexts/program/inetd.fc
+ file_contexts/program/tcpd.fc"
+
+src_compile() {
+ return
+}
+
+src_install() {
+ if use build; then
+ # generate a file_contexts
+ dodir ${POLICYDIR}/file_contexts
+ einfo "Ignore the checkpolicy error on the next line."
+ make -C ${S} \
+ FC=${D}/${POLICYDIR}/file_contexts/file_contexts \
+ ${D}/${POLICYDIR}/file_contexts/file_contexts
+
+ [ ! -f ${D}/${POLICYDIR}/file_contexts/file_contexts ] && \
+ die "file_contexts was not generated."
+ else
+ # install full policy
+ dodir /etc/security/selinux/src
+
+ insinto /etc/security
+ doins ${S}/appconfig/*
+
+ cp -a ${S} ${D}/${POLICYDIR}
+ rm -fR ${D}/${POLICYDIR}/appconfig
+ fi
+}
+
+pkg_postinst() {
+ local isdeprecated
+ echo
+ einfo "This is the base policy for SELinux on Gentoo. This policy"
+ einfo "package only covers the applications in the system profile."
+ einfo "More policy may need to be added according to your requirements."
+ echo
+ eerror "It is STRONGLY suggested that you evaluate and merge the"
+ eerror "policy changes. If any of the file contexts (*.fc) have"
+ eerror "changed, you should also relabel."
+ echo
+ ewarn "Please check the Changelog, there may be important information."
+ echo
+ echo
+
+ einfo "Checking for deprecated policy..."
+ for i in $DEPRECATED; do
+ if [ -f "${POLICYDIR}/${i}" ]; then
+ eerror "${POLICYDIR}/${i}"
+ isdeprecated="y"
+ fi
+ done
+ [ "${isdeprecated}" ] && \
+ eerror "The above policy file(s) should be removed if possible." || \
+ einfo "None found."
+
+ ebeep 4
+ epause 4
+}