summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-01 16:05:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-01 16:05:51 +0000
commit446cc43c9bdba7c43f20d93cd120ebabd2f08487 (patch)
tree0f4e2e8c258725270014c6301503d4a26657f035
parentBackport changes in CTR mode (bug #356325). (diff)
downloadgentoo-2-446cc43c9bdba7c43f20d93cd120ebabd2f08487.tar.gz
gentoo-2-446cc43c9bdba7c43f20d93cd120ebabd2f08487.tar.bz2
gentoo-2-446cc43c9bdba7c43f20d93cd120ebabd2f08487.zip
Update init script to wait to see if ufdb successfully started; add urls to the generated tables if present; add a variable to set options for ufdbGenTable and default to -W.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
-rw-r--r--net-proxy/ufdbguard/ChangeLog11
-rw-r--r--net-proxy/ufdbguard/files/ufdb.confd6
-rw-r--r--net-proxy/ufdbguard/files/ufdb.initd20
-rw-r--r--net-proxy/ufdbguard/ufdbguard-1.23-r1.ebuild130
-rw-r--r--net-proxy/ufdbguard/ufdbguard-1.24-r1.ebuild (renamed from net-proxy/ufdbguard/ufdbguard-1.24.ebuild)2
5 files changed, 29 insertions, 140 deletions
diff --git a/net-proxy/ufdbguard/ChangeLog b/net-proxy/ufdbguard/ChangeLog
index b572ac15a050..b0bc7e92bbb3 100644
--- a/net-proxy/ufdbguard/ChangeLog
+++ b/net-proxy/ufdbguard/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-proxy/ufdbguard
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/ChangeLog,v 1.13 2011/02/16 10:41:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/ChangeLog,v 1.14 2011/05/01 16:05:51 flameeyes Exp $
+
+*ufdbguard-1.24-r1 (01 May 2011)
+
+ 01 May 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ -ufdbguard-1.23-r1.ebuild, -ufdbguard-1.24.ebuild, +ufdbguard-1.24-r1.ebuild,
+ files/ufdb.confd, files/ufdb.initd:
+ Update init script to wait to see if ufdb successfully started; add urls to
+ the generated tables if present; add a variable to set options for
+ ufdbGenTable and default to -W.
16 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Update metadata, I'll co-maintain 1.24 and later as well.
diff --git a/net-proxy/ufdbguard/files/ufdb.confd b/net-proxy/ufdbguard/files/ufdb.confd
index 5ef5e4af6c53..e80c5519373e 100644
--- a/net-proxy/ufdbguard/files/ufdb.confd
+++ b/net-proxy/ufdbguard/files/ufdb.confd
@@ -1,9 +1,13 @@
# -*- sh -*-
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/files/ufdb.confd,v 1.1 2010/12/07 09:11:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/files/ufdb.confd,v 1.2 2011/05/01 16:05:50 flameeyes Exp $
# Tables to re-generate when starting or reloading ufdbguard
UFDB_GT="alwaysallow alwaysdeny"
+# Options passed to ufdbGenTable when generating the tables listed in
+# UFDB_GT
+GENTABLE_OPTIONS="-W"
+
# User under which to run ufdbguard; it should be the same as the
# proxy server you're using, so by default it is squid.
UFDB_USER="squid"
diff --git a/net-proxy/ufdbguard/files/ufdb.initd b/net-proxy/ufdbguard/files/ufdb.initd
index b6c02c6b34fd..df6d6a15c5b4 100644
--- a/net-proxy/ufdbguard/files/ufdb.initd
+++ b/net-proxy/ufdbguard/files/ufdb.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/files/ufdb.initd,v 1.1 2010/12/07 09:11:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/files/ufdb.initd,v 1.2 2011/05/01 16:05:50 flameeyes Exp $
# reconfig is what the upstream documentation suggests, so let's
# provide it for compatibility.
@@ -21,10 +21,14 @@ gentables() {
local dbhome=$(get_config dbhome)
for gt in ${UFDB_GT} ; do
- if [ -f "${dbhome}/${gt}/domains" ] ; then
- einfo "Generating domainlist ${gt}"
- ufdbGenTable -t "${gt}" -d "${dbhome}/${gt}/domains"
- fi
+ [ -f "${dbhome}/${gt}/domains" ] || continue
+
+ urls=
+ [ -f "${dbhome}/${gt}/urls" ] && urls="${dbhome}/${gt}/urls"
+
+ ebegin "Generating domainlist ${gt}"
+ ufdbGenTable ${GENTABLE_OPTIONS} -t "${gt}" -d "${dbhome}/${gt}/domains" ${urls:+-u "${urls}"}
+ eend $?
done
}
@@ -44,7 +48,9 @@ start() {
fi
ebegin "Starting ufdbGuard"
- start-stop-daemon --start --chuid ${UFDB_USER} \
+ start-stop-daemon --start \
+ --chuid ${UFDB_USER} \
+ --wait 1500 \
--exec /usr/libexec/ufdbguard/ufdbguardd \
--pidfile /var/run/ufdbguard/ufdbguardd.pid -- \
-c /etc/ufdbGuard.conf ${UFDB_OPTS}
diff --git a/net-proxy/ufdbguard/ufdbguard-1.23-r1.ebuild b/net-proxy/ufdbguard/ufdbguard-1.23-r1.ebuild
deleted file mode 100644
index 48015778dd49..000000000000
--- a/net-proxy/ufdbguard/ufdbguard-1.23-r1.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/ufdbguard-1.23-r1.ebuild,v 1.1 2011/01/31 05:37:32 jer Exp $
-
-EAPI="2"
-
-inherit eutils
-
-MY_P="ufdbGuard-${PV}"
-
-DESCRIPTION="ufdbGuard is a redirector for the Squid internet proxy."
-HOMEPAGE="http://www.urlfilterdb.com/en/products/ufdbguard.html"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
- doc? ( mirror://sourceforge/${PN}/ReferenceManual_v${PV/\./_}.pdf -> ${P}-manual.pdf )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+httpd doc"
-
-RDEPEND="dev-libs/openssl
- app-arch/bzip2
- net-misc/wget"
-
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- # create the squid user exactly as done by net-proxy/squid-3.1.9
- enewgroup squid 31
- enewuser squid 31 -1 /var/cache/squid squid
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-parallel-make.patch
- epatch "${FILESDIR}"/${P}-gentoo.patch
-
- egrep -r -e '/var/tmp/ufdb(guard|http)d.pid' "${S}" -lZ | xargs -0 \
- sed -i -e 's:/var/tmp/ufdb\(guard\|http\)d.pid:/var/run/ufdbguard/ufdb\1d.pid:' \
- || die
-
- # directory where ufdbhttpd is to be found
- sed -i -e 's:DEFAULT_BINDIR.*:DEFAULT_BINDIR "/usr/libexec/ufdbguard":' \
- src/ufdb.h.in || die
-}
-
-src_configure() {
- econf \
- --with-ufdb-user=squid \
- --with-ufdb-config=/etc \
- --with-ufdb-logdir=/var/log/ufdbguard \
- --with-ufdb-dbhome=/usr/share/ufdbguard/blacklists \
- --with-ufdb-images_dir=/usr/share/ufdbguard/images
-}
-
-src_install() {
- dodoc CHANGELOG INSTALL README src/sampleufdbGuard.conf || die
- doman doc/*.1 || die
-
- dobin src/ufdbAnalyse src/ufdbGenTable src/ufdbGrab \
- src/ufdbConvertDB || die
- dosbin src/ufdbUpdate || die
-
- exeinto /usr/libexec/ufdbguard
- doexe src/mtserver/ufdbguardd src/mtserver/ufdbgclient || die
-
- if use httpd; then
- exeinto /usr/libexec/ufdbguard
- doexe src/ufdbhttpd || die
- fi
-
- keepdir /usr/share/ufdbguard/blacklists
-
- insinto /etc
- doins src/ufdbGuard.conf || die
-
- insinto /usr/share/ufdbguard/images
- doins src/images/* || die
-
- newconfd "${FILESDIR}"/ufdb.confd ufdb || die
- newinitd "${FILESDIR}"/ufdb.initd ufdb || die
-
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/ufdbUpdate.cron ufdbUpdate || die
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- newins "${DISTDIR}"/${P}-manual.pdf ReferenceManual.pdf || die
- fi
-}
-
-pkg_postinst() {
- elog "The default location for the blacklist database has been"
- elog "moved to /usr/share/ufdbguard/blacklists."
- elog ""
- elog "The configuration file is no longer configurable in the"
- elog "service file, and now resides at /etc/ufdbGuard.conf ."
- elog ""
- elog "The service script has been renamed from ufdbguad to simply"
- elog "/etc/init.d/ufdb, to follow the official documentation, and"
- elog "it gained a reload option with a reconfig alias."
- elog ""
- elog "You can configure the username and password parameters for"
- elog "ufdbUpdate, to fetch the blacklist database provided by"
- elog "URLfilterDB, directly in /etc/conf.d/ufdb without touching"
- elog "the script itself."
- elog ""
- elog "To enable ufdbguard in squid, you should add this to your"
- elog "squid.conf:"
- elog ""
- elog " url_rewrite_program /usr/libexec/ufdbguard/ufdbgclient -l /var/log/ufdbguard"
- elog " url_rewrite_children 64"
- elog ""
- if ! use httpd; then
- elog "You chose to not install the lightweight http daemon that"
- elog "comes with ufdbguard."
- else
- elog "The ufdb service will start both the ufdbguardd daemon and"
- elog "the ufdbhttpd http daemon to provide a local redirect CGI."
- elog "If you don't want this to happen, disable the httpd USE flag."
- fi
- if use doc; then
- elog ""
- elog "The reference manual has been installed as"
- elog " /usr/share/doc/${PF}/ReferenceManual.pdf"
- fi
-}
diff --git a/net-proxy/ufdbguard/ufdbguard-1.24.ebuild b/net-proxy/ufdbguard/ufdbguard-1.24-r1.ebuild
index 97912d9b1509..53fdf2946ebb 100644
--- a/net-proxy/ufdbguard/ufdbguard-1.24.ebuild
+++ b/net-proxy/ufdbguard/ufdbguard-1.24-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/ufdbguard-1.24.ebuild,v 1.1 2011/02/16 10:38:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ufdbguard/ufdbguard-1.24-r1.ebuild,v 1.1 2011/05/01 16:05:51 flameeyes Exp $
EAPI="2"