summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-02 00:09:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-02 00:09:11 +0000
commit4a1a1e383963b68cfcb5bc2c943e241a2bbb7178 (patch)
tree92faad0ff7dbf86c265352a98fc8a3a341d7d498
parentTypo. (diff)
downloadgentoo-2-4a1a1e383963b68cfcb5bc2c943e241a2bbb7178.tar.gz
gentoo-2-4a1a1e383963b68cfcb5bc2c943e241a2bbb7178.tar.bz2
gentoo-2-4a1a1e383963b68cfcb5bc2c943e241a2bbb7178.zip
Version bump; add a readline USE flag for the new optional dependency.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
-rw-r--r--sys-process/fcron/ChangeLog10
-rw-r--r--sys-process/fcron/fcron-3.1.1.ebuild207
-rw-r--r--sys-process/fcron/files/fcron-3.1.1-noreadline.patch14
3 files changed, 229 insertions, 2 deletions
diff --git a/sys-process/fcron/ChangeLog b/sys-process/fcron/ChangeLog
index 1d0a901a5490..e43338217d2f 100644
--- a/sys-process/fcron/ChangeLog
+++ b/sys-process/fcron/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/fcron
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.99 2012/12/23 12:49:38 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.100 2013/01/02 00:09:11 flameeyes Exp $
+
+*fcron-3.1.1 (02 Jan 2013)
+
+ 02 Jan 2013; Diego E. Pettenò <flameeyes@gentoo.org> +fcron-3.1.1.ebuild,
+ +files/fcron-3.1.1-noreadline.patch:
+ Version bump; add a readline USE flag for the new optional dependency.
*fcron-3.1.0 (23 Dec 2012)
diff --git a/sys-process/fcron/fcron-3.1.1.ebuild b/sys-process/fcron/fcron-3.1.1.ebuild
new file mode 100644
index 000000000000..f5da3f8ee090
--- /dev/null
+++ b/sys-process/fcron/fcron-3.1.1.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.1.1.ebuild,v 1.1 2013/01/02 00:09:11 flameeyes Exp $
+
+EAPI=5
+
+WANT_AUTOMAKE=none
+
+inherit cron pam eutils flag-o-matic user autotools
+
+MY_P=${P/_/-}
+DESCRIPTION="A command scheduler with extended capabilities over cron and anacron"
+HOMEPAGE="http://fcron.free.fr/"
+SRC_URI="http://fcron.free.fr/archives/${MY_P}.src.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug pam selinux linguas_fr +system-crontab readline"
+
+DEPEND="selinux? ( sys-libs/libselinux )
+ pam? ( virtual/pam )
+ readline? ( sys-libs/readline )"
+
+# see bug 282214 for the reason to depend on bash
+RDEPEND="${DEPEND}
+ app-shells/bash
+ >=app-misc/editor-wrapper-3
+ pam? ( >=sys-auth/pambase-20100310 )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup fcron
+ enewuser fcron -1 -1 -1 fcron
+ rootuser=$(egetent passwd 0 | cut -d ':' -f 1)
+ [[ ${rootuser} ]] || rootuser=root
+ rootgroup=$(egetent group 0 | cut -d ':' -f 1)
+ [[ ${rootgroup} ]] || rootgroup=root
+}
+
+src_prepare() {
+ # respect LDFLAGS
+ sed -i "s:\(@LIBS@\):\$(LDFLAGS) \1:" Makefile.in || die "sed failed"
+
+ sed -i -e 's:/etc/fcrontab:/etc/fcron/fcrontab:' script/check_system_crontabs.sh || die
+
+ epatch "${FILESDIR}"/${P}-noreadline.patch
+ eautoconf
+}
+
+src_configure() {
+ local myconf
+
+ # Don't try to pass --with-debug as it'll play with cflags as
+ # well, and run foreground which is a _very_ nasty idea for
+ # Gentoo.
+ use debug && append-flags -DDEBUG
+
+ # bindir is used just for calling fcronsighup
+ econf \
+ --with-cflags="${CFLAGS}" \
+ --bindir=/usr/libexec \
+ $(use_with pam) \
+ $(use_with selinux) \
+ $(use_with readline) \
+ --without-audit \
+ --sysconfdir=/etc/fcron \
+ --with-username=fcron \
+ --with-groupname=fcron \
+ --with-piddir=/var/run \
+ --with-spooldir=/var/spool/fcron \
+ --with-fifodir=/var/run \
+ --with-fcrondyn=yes \
+ --disable-checks \
+ --with-editor=/usr/libexec/editor \
+ --with-sendmail=/usr/sbin/sendmail \
+ --with-shell=/bin/sh \
+ --without-db2man --without-dsssl-dir \
+ --with-rootname=${rootuser} \
+ --with-rootgroup=${rootgroup}
+}
+
+src_compile() {
+ default
+
+ # bug #216460
+ sed -i \
+ -e 's:/usr/local/etc/fcron:/etc/fcron/fcron:g' \
+ -e 's:/usr/local/etc:/etc:g' \
+ -e 's:/usr/local/:/usr/:g' \
+ doc/*/*/*.{txt,1,5,8,html} \
+ || die "unable to fix documentation references"
+}
+
+src_install() {
+ keepdir /var/spool/fcron
+
+ exeinto /usr/libexec
+ doexe fcron fcronsighup
+
+ dobin fcrondyn fcrontab
+
+ insinto /etc/fcron
+ doins files/fcron.{allow,deny,conf}
+
+ if use system-crontab; then
+ dosym fcrontab /usr/bin/crontab
+
+ exeinto /usr/libexec
+ newexe script/check_system_crontabs.sh check_system_crontabs
+
+ insinto /etc/fcron
+ newins "${FILESDIR}"/fcrontab.2 fcrontab
+
+ fowners ${rootuser}:fcron /etc/fcron/fcrontab
+ fperms 0640 /etc/fcron/fcrontab
+
+ insinto /etc
+ doins "${FILESDIR}"/crontab
+ fi
+
+ fowners fcron:fcron \
+ /var/spool/fcron \
+ /usr/bin/fcron{dyn,tab}
+
+ # fcronsighup needs to be suid root, because it sends a HUP to the
+ # running fcron daemon, but only has to be called by the fcron group
+ # anyway
+ fowners ${rootuser}:fcron \
+ /usr/libexec/fcronsighup \
+ /etc/fcron/fcron.{allow,deny,conf} \
+ /etc/fcron
+
+ fperms 6770 /var/spool/fcron
+ fperms 6775 /usr/bin/fcron{dyn,tab}
+
+ fperms 4710 /usr/libexec/fcronsighup
+
+ fperms 0750 /etc/fcron
+ fperms 0640 /etc/fcron/fcron.{allow,deny,conf}
+
+ pamd_mimic system-services fcron auth account session
+ cat > "${T}"/fcrontab.pam <<- EOF
+ # Don't ask for the user's password; fcrontab will only allow to
+ # change user if running as root.
+ auth sufficient pam_permit.so
+
+ # Still use the system-auth stack for account and session as the
+ # sysadmin might have set up stuff properly, and also avoids
+ # sidestepping limits (since fcrontab will run \$EDITOR).
+ account include system-auth
+ session include system-auth
+ EOF
+ newpamd "${T}"/fcrontab.pam fcrontab
+
+ newinitd "${FILESDIR}"/fcron.init.3 fcron
+
+ dodoc MANIFEST VERSION "${FILESDIR}"/crontab \
+ doc/en/txt/{readme,thanks,faq,todo,relnotes,changes}.txt
+ newdoc files/fcron.conf fcron.conf.sample
+ dohtml doc/en/HTML/*.html
+ doman doc/en/man/*.{1,5,8}
+
+ for lang in fr; do
+ use linguas_${lang} || continue
+
+ doman -i18n=${lang} doc/${lang}/man/*.{1,5,8} || die
+ docinto html/${lang}
+ dohtml doc/${lang}/HTML/*.html || die
+ done
+}
+
+pkg_postinst() {
+ elog "If it's the first time you install fcron make sure to execute"
+ elog " emerge --config ${CATEGORY}/${PN}"
+ elog "to configure the proper settings."
+ if ! use system-crontab; then
+ echo ""
+ ewarn "Remember that fcron will *not* use /etc/cron.d in this configuration"
+ echo ""
+ fi
+}
+
+pkg_config() {
+ if [[ $(fcrontab -l -u systab 2>/dev/null) ]]; then
+ eerror "We're not going to make any change to your systab as long as"
+ eerror "it contains data; please clear it before proceeding."
+ return 1
+ fi
+
+ if use system-crontab; then
+ elog "This is going to set up fcron to execute check_system_crontabs."
+ elog "In this configuration, you're no longer free to edit the systab"
+ elog "at your leisure, at it'll be rewritten the moment the crontabs"
+ elog "are modified."
+ /usr/libexec/check_system_crontabs -v -i -f
+ else
+ elog "This is going to set up fcron to set up a default systab that"
+ elog "executes /etc/cron.{hourly,daily,weekly,monthly}."
+ fcrontab -u systab - <<- EOF
+ 0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
+ 1 3 * * * rm -f /var/spool/cron/lastrun/cron.daily
+ 15 4 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
+ 30 5 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
+ EOF
+ fi
+}
diff --git a/sys-process/fcron/files/fcron-3.1.1-noreadline.patch b/sys-process/fcron/files/fcron-3.1.1-noreadline.patch
new file mode 100644
index 000000000000..161e75b0998e
--- /dev/null
+++ b/sys-process/fcron/files/fcron-3.1.1-noreadline.patch
@@ -0,0 +1,14 @@
+Index: fcron-3.1.1/configure.in
+===================================================================
+--- fcron-3.1.1.orig/configure.in
++++ fcron-3.1.1/configure.in
+@@ -86,7 +86,8 @@ AC_FUNC_WAIT3
+ AC_CHECK_LIB(xnet, shutdown)
+ AC_CHECK_LIB(selinux, getcon, [selinuxavail=1], [selinuxavail=0])
+ AC_CHECK_LIB(audit, audit_open, [auditavail=1], [auditavail=0])
+-AX_LIB_READLINE
++AC_ARG_WITH([readline], AS_HELP_STRING([--without-readline], [Build without readline @<:@default=yes@:>@]))
++AS_IF([test "x$with_readline" != "xno"], [AX_LIB_READLINE], [ax_cv_lib_readline=no])
+ AC_CHECK_FUNC(getloadavg, [getloadavg=1], [getloadavg=0])
+ AC_CHECK_LIB(kstat, kstat_open, [kstat=1], [kstat=0])
+ if test $getloadavg -eq 1; then