summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-13 23:53:00 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-13 23:53:00 +0000
commit4f40a498cfa700a1d0238960bdbf5bd3b95d6ab9 (patch)
treee0b94717201cc1c42363cf0d38f7cc72e2eec612
parentVersion bump (thanks to Franz Schrober for the report, bug 381665) (diff)
downloadgentoo-2-4f40a498cfa700a1d0238960bdbf5bd3b95d6ab9.tar.gz
gentoo-2-4f40a498cfa700a1d0238960bdbf5bd3b95d6ab9.tar.bz2
gentoo-2-4f40a498cfa700a1d0238960bdbf5bd3b95d6ab9.zip
fix .la file removal (thanks Alexander Adam, bug 374575), remove old version
(Portage version: 2.1.10.11/cvs/Linux x86_64)
-rw-r--r--sys-auth/libfprint/ChangeLog6
-rw-r--r--sys-auth/libfprint/libfprint-0.3.0-r1.ebuild53
-rw-r--r--sys-auth/libfprint/libfprint-0.4.0.ebuild17
3 files changed, 12 insertions, 64 deletions
diff --git a/sys-auth/libfprint/ChangeLog b/sys-auth/libfprint/ChangeLog
index 7c422b22a9d5..a5e2674f94a4 100644
--- a/sys-auth/libfprint/ChangeLog
+++ b/sys-auth/libfprint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-auth/libfprint
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.5 2011/06/16 23:28:59 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.6 2011/11/13 23:53:00 xmw Exp $
+
+ 13 Nov 2011; Michael Weber <xmw@gentoo.org> -libfprint-0.3.0-r1.ebuild,
+ libfprint-0.4.0.ebuild:
+ fix .la file removal (thanks Alexander Adam, bug 374575), remove old version
*libfprint-0.4.0 (16 Jun 2011)
*libfprint-0.3.0-r1 (16 Jun 2011)
diff --git a/sys-auth/libfprint/libfprint-0.3.0-r1.ebuild b/sys-auth/libfprint/libfprint-0.3.0-r1.ebuild
deleted file mode 100644
index 95d810a753eb..000000000000
--- a/sys-auth/libfprint/libfprint-0.3.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.3.0-r1.ebuild,v 1.1 2011/06/16 23:28:59 xmw Exp $
-
-EAPI=3
-
-inherit autotools versionator
-
-MY_PV="v_$(replace_all_version_separators _)"
-DESCRIPTION="library to add support for consumer fingerprint readers"
-HOMEPAGE="http://cgit.freedesktop.org/libfprint/libfprint/"
-SRC_URI="http://cgit.freedesktop.org/${PN}/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug static-libs"
-
-RDEPEND="dev-libs/glib:2
- dev-libs/libusb:1
- dev-libs/nss
- x11-libs/gtk+:2
- || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
-
-DEPEND="${DEPEND}
- dev-util/pkgconfig"
-
-S=${WORKDIR}/${MY_PV}
-
-src_prepare() {
- mkdir m4 || die
- eautoreconf
-}
-
-pkg_setup() {
- einfo
- elog "This version does not support fdu2000 and upektc (yet)."
- einfo
-}
-
-src_configure() {
- econf ${my_conf} \
- $(use_enable debug debug-log) \
- $(use_enable static-libs static) || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- if ! use static-libs ; then
- rm -v "${D}"/usr/lib64/libfprint.la || die
- fi
- dodoc AUTHORS HACKING NEWS README THANKS TODO || die
-}
diff --git a/sys-auth/libfprint/libfprint-0.4.0.ebuild b/sys-auth/libfprint/libfprint-0.4.0.ebuild
index e465c1648638..09a567205dd2 100644
--- a/sys-auth/libfprint/libfprint-0.4.0.ebuild
+++ b/sys-auth/libfprint/libfprint-0.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.4.0.ebuild,v 1.1 2011/06/16 23:28:59 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.4.0.ebuild,v 1.2 2011/11/13 23:53:00 xmw Exp $
-EAPI=3
+EAPI=4
inherit autotools
@@ -21,7 +21,6 @@ RDEPEND="dev-libs/glib:2
dev-libs/nss
x11-libs/gtk+:2
|| ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
-
DEPEND="${DEPEND}
dev-util/pkgconfig"
@@ -39,15 +38,13 @@ pkg_setup() {
}
src_configure() {
- econf ${my_conf} \
+ econf \
$(use_enable debug debug-log) \
- $(use_enable static-libs static) || die
+ $(use_enable static-libs static)
}
src_install() {
- emake DESTDIR="${D}" install || die
- if ! use static-libs ; then
- rm -v "${D}"/usr/lib64/libfprint.la || die
- fi
- dodoc AUTHORS HACKING NEWS README THANKS TODO || die
+ emake DESTDIR="${D}" install
+ use static-libs || find "${D}" -name "*.la" -delete
+ dodoc AUTHORS HACKING NEWS README THANKS TODO
}