summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-09 22:44:44 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-09 22:44:44 +0000
commit54dcab2aa0335b51aa202ae736b75e38bce4a274 (patch)
tree318507caddcfc0fb10227f1bbfacd1ea076b786c
parentversion bump wrt bug #232831. ebuild cleanup thanks to Craig. (diff)
downloadgentoo-2-54dcab2aa0335b51aa202ae736b75e38bce4a274.tar.gz
gentoo-2-54dcab2aa0335b51aa202ae736b75e38bce4a274.tar.bz2
gentoo-2-54dcab2aa0335b51aa202ae736b75e38bce4a274.zip
Remove src/pynotify.c so it's regenerated, #212128. Fix python_mod_cleanup.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
-rw-r--r--dev-python/notify-python/ChangeLog9
-rw-r--r--dev-python/notify-python/notify-python-0.1.1-r1.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/notify-python/ChangeLog b/dev-python/notify-python/ChangeLog
index 3919b615a656..7dd6eb8f04f0 100644
--- a/dev-python/notify-python/ChangeLog
+++ b/dev-python/notify-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/notify-python
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/ChangeLog,v 1.10 2008/08/08 19:04:17 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/ChangeLog,v 1.11 2008/09/09 22:44:44 hawking Exp $
+
+*notify-python-0.1.1-r1 (09 Sep 2008)
+
+ 09 Sep 2008; Ali Polatel <hawking@gentoo.org>
+ +notify-python-0.1.1-r1.ebuild:
+ Remove src/pynotify.c so it's regenerated, #212128. Fix
+ python_mod_cleanup.
08 Aug 2008; Markus Rothe <corsair@gentoo.org> notify-python-0.1.1.ebuild:
Stable on ppc64; bug #233766
diff --git a/dev-python/notify-python/notify-python-0.1.1-r1.ebuild b/dev-python/notify-python/notify-python-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..f514a087837e
--- /dev/null
+++ b/dev-python/notify-python/notify-python-0.1.1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/notify-python/notify-python-0.1.1-r1.ebuild,v 1.1 2008/09/09 22:44:44 hawking Exp $
+
+NEED_PYTHON=2.3.5
+
+inherit python
+
+DESCRIPTION="Python bindings for libnotify"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-python/pygtk-2.4.0
+ >=x11-libs/libnotify-0.4.3"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # Remove the old pynotify.c to ensure it's properly regenerated #212128.
+ rm -f src/pynotify.c
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0/pynotify
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/gtk-2.0/pynotify
+}
+