summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-10-23 13:13:52 +0000
committerMichael Januszewski <spock@gentoo.org>2004-10-23 13:13:52 +0000
commit56ae64e96b13293418e37c2ce1dc82d97d85b45f (patch)
tree4c67c9ea45533c750418623f2d2548eba580b77c
parentDigest fix (Manifest recommit) (diff)
downloadgentoo-2-56ae64e96b13293418e37c2ce1dc82d97d85b45f.tar.gz
gentoo-2-56ae64e96b13293418e37c2ce1dc82d97d85b45f.tar.bz2
gentoo-2-56ae64e96b13293418e37c2ce1dc82d97d85b45f.zip
Version bump.
-rw-r--r--net-im/gnugadu/ChangeLog7
-rw-r--r--net-im/gnugadu/files/digest-gnugadu-2.2.11
-rw-r--r--net-im/gnugadu/gnugadu-2.2.1.ebuild64
3 files changed, 71 insertions, 1 deletions
diff --git a/net-im/gnugadu/ChangeLog b/net-im/gnugadu/ChangeLog
index 3c4a2c5b51af..251f5f65eca8 100644
--- a/net-im/gnugadu/ChangeLog
+++ b/net-im/gnugadu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/gnugadu
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.25 2004/10/21 20:31:18 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/ChangeLog,v 1.26 2004/10/23 13:13:52 spock Exp $
+
+*gnugadu-2.2.1 (23 Oct 2004)
+
+ 23 Oct 2004; Michal Januszewski <spock@gentoo.org> +gnugadu-2.2.1.ebuild:
+ Version bump.
21 Oct 2004; Michal Januszewski <spock@gentoo.org> gnugadu-2.2.0.ebuild:
Fixed loudmouth dep.
diff --git a/net-im/gnugadu/files/digest-gnugadu-2.2.1 b/net-im/gnugadu/files/digest-gnugadu-2.2.1
new file mode 100644
index 000000000000..4645e78a2c89
--- /dev/null
+++ b/net-im/gnugadu/files/digest-gnugadu-2.2.1
@@ -0,0 +1 @@
+MD5 370ceeb422f7fe9b4a182a6966311af0 gg2-2.2.1.tar.gz 1282832
diff --git a/net-im/gnugadu/gnugadu-2.2.1.ebuild b/net-im/gnugadu/gnugadu-2.2.1.ebuild
new file mode 100644
index 000000000000..120c54a4b3d0
--- /dev/null
+++ b/net-im/gnugadu/gnugadu-2.2.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnugadu/gnugadu-2.2.1.ebuild,v 1.1 2004/10/23 13:13:52 spock Exp $
+
+IUSE="debug tlen esd oss xosd arts jabber perl spell"
+
+inherit eutils
+
+MY_P="gg2-${PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="GTK-based Gadu-Gadu, Tlen and Jabber IM client"
+SRC_URI="mirror://sourceforge/ggadu/${MY_P}.tar.gz"
+HOMEPAGE="http://gadu.gnu.pl/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=x11-libs/gtk+-2.4.0
+ sys-devel/gettext
+ >=sys-devel/automake-1.7
+ >=sys-devel/libtool-1.4
+ jabber? ( >=net-libs/loudmouth-0.17 )
+ xosd? ( x11-libs/xosd )
+ perl? ( dev-lang/perl dev-perl/XML-Parser )
+ arts? ( >=kde-base/arts-0.9.5 )
+ esd? ( media-sound/esound )
+ tlen? ( net-libs/libtlen )
+ spell? ( app-text/gtkspell )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -re 's#GTKSPELL_LIBS=`(.*)`#GTKSPELL_LIBS="`\1` -laspell"#g' -i configure
+}
+
+src_compile() {
+
+ myconf="--with-gui --with-gadu --with-remote --with-docklet_system_tray --with-docklet_dockapp \
+ --with-sms --with-update --with-external --with-gghist --with-history-external-viewer"
+
+ if use arts; then
+ myconf="${myconf} --with-arts --with-arts-prefix=`artsc-config --arts-prefix`"
+ fi
+
+ econf ${myconf} \
+ `use_enable debug` \
+ `use_with oss` \
+ `use_with esd` \
+ `use_with xosd` \
+ `use_with arts` \
+ `use_with perl` \
+ `use_with tlen` \
+ `use_with jabber` \
+ `use_with spell gtkspell` || die
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+