summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-03-16 17:22:41 +0000
committerChuck Short <zul@gentoo.org>2004-03-16 17:22:41 +0000
commit5c14ef6adc1a57fe0745b6eca57f503917a36ca6 (patch)
tree8c5582b726e798063b5980a298392c603c2e9594
parentVersion bump, closes #44580. (diff)
downloadgentoo-2-5c14ef6adc1a57fe0745b6eca57f503917a36ca6.tar.gz
gentoo-2-5c14ef6adc1a57fe0745b6eca57f503917a36ca6.tar.bz2
gentoo-2-5c14ef6adc1a57fe0745b6eca57f503917a36ca6.zip
Version bump, closes #44580.
-rw-r--r--app-admin/bacula/ChangeLog14
-rw-r--r--app-admin/bacula/Manifest6
-rw-r--r--app-admin/bacula/bacula-1.32f-r5.ebuild115
-rw-r--r--app-admin/bacula/bacula-1.32f.ebuild4
-rw-r--r--app-admin/bacula/files/digest-bacula-1.32f-r51
5 files changed, 134 insertions, 6 deletions
diff --git a/app-admin/bacula/ChangeLog b/app-admin/bacula/ChangeLog
index 98af84a3040a..2342421676c5 100644
--- a/app-admin/bacula/ChangeLog
+++ b/app-admin/bacula/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-admin/bacula
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.14 2004/02/11 23:38:03 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/ChangeLog,v 1.15 2004/03/16 17:22:31 zul Exp $
+
+*bacula-1.32f-r5 (16 Mar 2004)
+
+ 16 Mar 2004; Chuck Short <zul@gentoo.org> bacula-1.32f-r5.ebuild,
+ bacula-1.32f.ebuild:
+ Version bump, closes #44580.
+
+ Bacula 1.32f-r5 is 1.32f-5 and bacula 1.32f is 1.32f. The
+ next release 1.32f-6 will be 1.32f-r6.
+
+ 14 Mar 2004; Chuck Short <zul@gentoo.org> bacula-1.32f.ebuild:
+ Marked stable for x86.
11 Feb 2004; Chuck Short <zul@gentoo.org> bacula-1.29.ebuild:
For some reason console does not get installed to /usr/sbin. Added depend on
diff --git a/app-admin/bacula/Manifest b/app-admin/bacula/Manifest
index bfd143f32640..66fe4afc0a50 100644
--- a/app-admin/bacula/Manifest
+++ b/app-admin/bacula/Manifest
@@ -1,8 +1,8 @@
MD5 44a42713d947389c5e6f8593da166466 bacula-1.31.ebuild 3160
MD5 7d8026ac27aab1258edb0554f0eb5033 bacula-1.29.ebuild 3294
-MD5 09d107c8c9a85cd47acac78e8aba1c38 bacula-1.32f.ebuild 3354
-MD5 e80ff7c3d58452fcb4b3c414ebf3532f bacula-1.32f-r5.ebuild 3144
-MD5 eec913bafbbff0a64dc67e4724956915 ChangeLog 2046
+MD5 d23484990ae8ab5dacb30d4e40df7b34 bacula-1.32f.ebuild 3354
+MD5 857dd683325ea275c533e1160ded2a29 bacula-1.32f-r5.ebuild 3147
+MD5 2bb6a5e2fb1c83b7c9f38317b5ee6b6c ChangeLog 2306
MD5 7e285f080272b311b0eb8b0028928e07 metadata.xml 219
MD5 c453d7375a93ff187e5bc03ede9417b8 files/digest-bacula-1.32f-r5 67
MD5 68cdbb97c1064de4654b8db6160442ca files/digest-bacula-1.32f 268
diff --git a/app-admin/bacula/bacula-1.32f-r5.ebuild b/app-admin/bacula/bacula-1.32f-r5.ebuild
new file mode 100644
index 000000000000..10eec663d1e8
--- /dev/null
+++ b/app-admin/bacula/bacula-1.32f-r5.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/bacula-1.32f-r5.ebuild,v 1.1 2004/03/16 17:22:31 zul Exp $
+
+MY_P="bacula-1.32f-5"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="featureful client/server network backup suite"
+HOMEPAGE="http://www.bacula.org/"
+SRC_URI="mirror://sourceforge/bacula/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="readline tcpd ssl gnome mysql sqlite X static"
+
+#theres a local sqlite use flag. use it -OR- mysql, not both.
+#mysql is the reccomended choice ...
+DEPEND="sys-libs/libtermcap-compat
+ >=sys-libs/zlib-1.1.4
+ readline? >=sys-libs/readline-4.1
+ tcpd? >=sys-apps/tcp-wrappers-7.6
+ ssl? >=dev-libs/openssl-0.9.6
+ gnome? gnome-base/gnome-libs
+ sqlite? >=dev-db/sqlite-2.7
+ mysql? >=dev-db/mysql-3.23
+ X? virtual/x11
+ virtual/mta
+ dev-libs/gmp"
+RDEPEND="${DEPEND}
+ sys-apps/mtx
+ app-arch/mt-st"
+
+src_compile() {
+ local myconf=""
+
+ #define this to skip building the other daemons ...
+ [ -n "$BUILD_CLIENT_ONLY" ] \
+ && myconf="${myconf} --enable-client-only"
+
+ #might be handy to have static bins in certain situations ...
+ use static \
+ && myconf="${myconf} --enable-static-tools \
+ --enable-static-fd --enable-static-sd \
+ --enable-static-dir --enable-static-cons"
+ myconf="
+ `use_enable readline`
+ `use_enable gnome`
+ `use_enable tcpd`
+ `use_enable X x`
+ "
+ #not ./configure'able
+ #`use_enable ssl`
+
+ # mysql is the reccomended choice ...
+ if use mysql
+ then
+ myconf="${myconf} --with-mysql=/usr"
+ fi
+
+ if use sqlite
+ then
+ myconf="${myconf} --with-sqlite=/usr"
+ fi
+
+ if use sqlite && use mysql
+ then
+ myconf="${myconf/--with-sqlite/}"
+ fi
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-pid-dir=/var/run \
+ --sysconfdir=/etc/bacula \
+ --infodir=/usr/share/info \
+ --with-subsys-dir=/var/lib/bacula \
+ --with-working-dir=/var/lib/bacula \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ rm -rf ${D}/var #empty dir
+
+ dodoc ABOUT-NLS COPYING ChangeLog CheckList INSTALL \
+ README ReleaseNotes kernstodo doc/bacula.pdf
+ cp -a examples ${D}/usr/share/doc/${PF}
+ chown -R root:root ${D}/usr/share/doc/${PF} #hrmph :\
+ dohtml -r doc/html-manual doc/home-page
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bacula-init bacula
+}
+
+pkg_postinst() {
+ # empty dir ...
+ install -m0755 -o root -g root -d ${ROOT}/var/lib/bacula
+ einfo
+ einfo "If this is a new install and you plan to use mysql for your"
+ einfo "catalog database, then you should now create it by doing"
+ einfo "these commands:"
+ einfo " sh /etc/bacula/grant_mysql_privileges"
+ einfo " sh /etc/bacula/create_mysql_database"
+ einfo " sh /etc/bacula/make_mysql_tables"
+ einfo
+ einfo "Then setup your configuration files in /etc/bacula and"
+ einfo "start the daemons:"
+ einfo " /etc/init.d/bacula start"
+ einfo
+ einfo "If upgrading from version 1.30 or below, please note that"
+ einfo "the database format has changed. Please read the"
+ einfo "release notes for how to upgrade your database!!!"
+ einfo
+}
diff --git a/app-admin/bacula/bacula-1.32f.ebuild b/app-admin/bacula/bacula-1.32f.ebuild
index 2c93643d67e7..e1e3cc2daf39 100644
--- a/app-admin/bacula/bacula-1.32f.ebuild
+++ b/app-admin/bacula/bacula-1.32f.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/bacula-1.32f.ebuild,v 1.2 2004/02/11 01:29:09 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bacula/bacula-1.32f.ebuild,v 1.3 2004/03/16 17:22:31 zul Exp $
S="${WORKDIR}/${P}"
DESCRIPTION="featureful client/server network backup suite"
@@ -9,7 +9,7 @@ SRC_URI="mirror://sourceforge/bacula/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ~ppc"
IUSE="readline tcpd ssl gnome mysql sqlite X static"
#theres a local sqlite use flag. use it -OR- mysql, not both.
diff --git a/app-admin/bacula/files/digest-bacula-1.32f-r5 b/app-admin/bacula/files/digest-bacula-1.32f-r5
new file mode 100644
index 000000000000..617210741709
--- /dev/null
+++ b/app-admin/bacula/files/digest-bacula-1.32f-r5
@@ -0,0 +1 @@
+MD5 20fe32f7849723c8717ba59121eb6f99 bacula-1.32f-5.tar.gz 3337763