summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-10-02 22:13:03 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-10-02 22:13:03 +0000
commit6662e991708bd1f83140bf7e7513eaf11a2435e4 (patch)
treea05eb1752b11daf648aa94690b3e168d5309b4e5
parentAdded a Software RAID reference counter fix, bug #30124. (diff)
downloadgentoo-2-6662e991708bd1f83140bf7e7513eaf11a2435e4.tar.gz
gentoo-2-6662e991708bd1f83140bf7e7513eaf11a2435e4.tar.bz2
gentoo-2-6662e991708bd1f83140bf7e7513eaf11a2435e4.zip
Forgot some changes from 0.9.6-r1.
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.9.7.ebuild29
1 files changed, 28 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/alsa-utils-0.9.7.ebuild b/media-sound/alsa-utils/alsa-utils-0.9.7.ebuild
index 7352f0468c3f..8150f9732929 100644
--- a/media-sound/alsa-utils/alsa-utils-0.9.7.ebuild
+++ b/media-sound/alsa-utils/alsa-utils-0.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.9.7.ebuild,v 1.1 2003/10/02 22:08:15 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.9.7.ebuild,v 1.2 2003/10/02 22:13:03 agenkin Exp $
DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
HOMEPAGE="http://www.alsa-project.org/"
@@ -29,4 +29,31 @@ src_install() {
dodoc ${ALSA_UTILS_DOCS}
newdoc alsamixer/README README.alsamixer
+
+ dodir /etc/init.d
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run update-modules. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && update-modules"
+ echo
+ ewarn "Pausing for 20 seconds to give you time to read..."
+ sleep 20
}