summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-30 21:45:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-30 21:45:03 +0000
commit6ff1ccad5ba6d72426e76e1c621ac869c10d4108 (patch)
treee2006fe5dc35c47e39085d5a3ba7cc42b9daaad9
parentold (diff)
downloadgentoo-2-6ff1ccad5ba6d72426e76e1c621ac869c10d4108.tar.gz
gentoo-2-6ff1ccad5ba6d72426e76e1c621ac869c10d4108.tar.bz2
gentoo-2-6ff1ccad5ba6d72426e76e1c621ac869c10d4108.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
-rw-r--r--games-puzzle/xbomb/ChangeLog10
-rw-r--r--games-puzzle/xbomb/files/xbomb-2.2a-DESTDIR.patch35
-rw-r--r--games-puzzle/xbomb/xbomb-2.2a.ebuild40
3 files changed, 83 insertions, 2 deletions
diff --git a/games-puzzle/xbomb/ChangeLog b/games-puzzle/xbomb/ChangeLog
index 5865ee4e0391..eb5205444a21 100644
--- a/games-puzzle/xbomb/ChangeLog
+++ b/games-puzzle/xbomb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/xbomb
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xbomb/ChangeLog,v 1.16 2008/05/11 16:33:00 corsair Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xbomb/ChangeLog,v 1.17 2009/11/30 21:45:03 mr_bones_ Exp $
+
+*xbomb-2.2a (30 Nov 2009)
+
+ 30 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org> +xbomb-2.2a.ebuild,
+ +files/xbomb-2.2a-DESTDIR.patch:
+ version bump
11 May 2008; Markus Rothe <corsair@gentoo.org> xbomb-2.2.ebuild:
Stable on ppc64; bug #220046
diff --git a/games-puzzle/xbomb/files/xbomb-2.2a-DESTDIR.patch b/games-puzzle/xbomb/files/xbomb-2.2a-DESTDIR.patch
new file mode 100644
index 000000000000..945ac700be86
--- /dev/null
+++ b/games-puzzle/xbomb/files/xbomb-2.2a-DESTDIR.patch
@@ -0,0 +1,35 @@
+diff -c xbomb-2.1/Makefile xbomb-2.1.new/Makefile
+*** xbomb-2.1/Makefile 1996-01-20 16:02:46.000000000 -0500
+--- xbomb-2.1.new/Makefile 2002-11-13 10:31:30.000000000 -0500
+***************
+*** 27,34 ****
+
+ OBJ=xbomb.o xwindow.o hiscore.o
+
+- INSTDIR=/usr/local
+-
+ ########
+
+ xbomb : $(OBJ)
+--- 27,32 ----
+***************
+*** 52,60 ****
+
+ install :
+ strip xbomb
+! install -d $(INSTDIR)/bin
+! install -d $(INSTDIR)/man/man6
+! install -d $(INSTDIR)/lib/app-defaults
+! install -m 755 xbomb $(INSTDIR)/bin
+! install -m 644 xbomb.6 $(INSTDIR)/man/man6
+! install -m 644 xbomb.ad $(INSTDIR)/lib/app-defaults/XBomb
+--- 50,58 ----
+
+ install :
+ strip xbomb
+! install -d $(DESTDIR)/usr/bin
+! install -d $(DESTDIR)/usr/share/man/man6
+! install -d $(DESTDIR)/etc/X11/app-defaults
+! install -m 755 xbomb $(DESTDIR)/usr/bin
+! install -m 644 xbomb.6 $(DESTDIR)/usr/share/man/man6
+! install -m 644 xbomb.ad $(DESTDIR)/etc/X11/app-defaults/XBomb
diff --git a/games-puzzle/xbomb/xbomb-2.2a.ebuild b/games-puzzle/xbomb/xbomb-2.2a.ebuild
new file mode 100644
index 000000000000..7e275d8c02ce
--- /dev/null
+++ b/games-puzzle/xbomb/xbomb-2.2a.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xbomb/xbomb-2.2a.ebuild,v 1.1 2009/11/30 21:45:03 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Minesweeper clone with hexagonal, rectangular and triangular grid"
+HOMEPAGE="http://www.gedanken.demon.co.uk/xbomb/"
+SRC_URI="http://www.gedanken.demon.co.uk/download-xbomb/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXaw"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-DESTDIR.patch
+ sed -i \
+ -e '/strip/d' \
+ -e "/^CFLAGS/ { s:=.*:=${CFLAGS}: }" \
+ -e "s:/usr/bin:${GAMES_BINDIR}:" \
+ Makefile \
+ || die "sed Makefile failed"
+ sed -i \
+ -e "s:/var/tmp:${GAMES_STATEDIR}/${PN}:g" \
+ hiscore.c \
+ || die "sed hiscore.c failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README LSM
+ dodir "${GAMES_STATEDIR}"/${PN}
+ touch "${D}/${GAMES_STATEDIR}"/${PN}/${PN}{3,4,6}.hi || die "touch failed"
+ fperms 660 "${GAMES_STATEDIR}"/${PN}/${PN}{3,4,6}.hi || die "fperms failed"
+ prepgamesdirs
+}