summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-05 15:04:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-05 15:04:57 +0000
commit7d86c50eb3b17dc3080253cf97df978fd19809ea (patch)
tree8298590ecf8095c94b79da9fd3e1413da412c233
parentDropping sparc keywords, see #96229 (diff)
downloadgentoo-2-7d86c50eb3b17dc3080253cf97df978fd19809ea.tar.gz
gentoo-2-7d86c50eb3b17dc3080253cf97df978fd19809ea.tar.bz2
gentoo-2-7d86c50eb3b17dc3080253cf97df978fd19809ea.zip
Version bump, remove old broken release.
(Portage version: 2.1.2_pre2-r3)
-rw-r--r--net-p2p/rtorrent/ChangeLog8
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.6.33
-rw-r--r--net-p2p/rtorrent/rtorrent-0.6.3.ebuild44
3 files changed, 54 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 812133bfff7a..cdd8279ec244 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.60 2006/09/24 09:14:03 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.61 2006/10/05 15:04:57 flameeyes Exp $
+
+*rtorrent-0.6.3 (05 Oct 2006)
+
+ 05 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> -rtorrent-0.6.2.ebuild,
+ +rtorrent-0.6.3.ebuild:
+ Version bump, remove old broken release.
24 Sep 2006; Michael Hanselmann <hansmi@gentoo.org> rtorrent-0.6.0.ebuild:
Stable on ppc.
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.6.3 b/net-p2p/rtorrent/files/digest-rtorrent-0.6.3
new file mode 100644
index 000000000000..c1dbd3912746
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.6.3
@@ -0,0 +1,3 @@
+MD5 80119c01f484a81626ca89d83bfee885 rtorrent-0.6.3.tar.gz 411337
+RMD160 95c6a7d56d88245a4adf8450261cd82c1923f191 rtorrent-0.6.3.tar.gz 411337
+SHA256 ac9b007213e1a124fee3e4ea77c2f7e94e2e9cc9366702a2ec668ebef8907533 rtorrent-0.6.3.tar.gz 411337
diff --git a/net-p2p/rtorrent/rtorrent-0.6.3.ebuild b/net-p2p/rtorrent/rtorrent-0.6.3.ebuild
new file mode 100644
index 000000000000..729795c5aae5
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.6.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.6.3.ebuild,v 1.1 2006/10/05 15:04:57 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.10.1
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-devel/bc"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}