summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-07-13 22:55:22 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-07-13 22:55:22 +0000
commit83235177f35c8afbab0d9da2f1e53c094b02b071 (patch)
treee7d97208a8ab16cd8af53d0bae475531f3b6a761
parentxft bug #24398 (diff)
downloadgentoo-2-83235177f35c8afbab0d9da2f1e53c094b02b071.tar.gz
gentoo-2-83235177f35c8afbab0d9da2f1e53c094b02b071.tar.bz2
gentoo-2-83235177f35c8afbab0d9da2f1e53c094b02b071.zip
initial release of linux32 tool
-rw-r--r--sys-apps/linux32/ChangeLog8
-rw-r--r--sys-apps/linux32/Manifest3
-rw-r--r--sys-apps/linux32/files/digest-linux32-1.01
-rw-r--r--sys-apps/linux32/linux32-1.0.ebuild24
4 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/linux32/ChangeLog b/sys-apps/linux32/ChangeLog
new file mode 100644
index 000000000000..cf9cdee65780
--- /dev/null
+++ b/sys-apps/linux32/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for sys-apps/linux32
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux32/ChangeLog,v 1.1 2003/07/13 22:55:22 drobbins Exp $
+
+*linux32-1.0 (13 Jul 2003)
+
+ 13 Jul 2003; Daniel Robbins <drobbins@gentoo.org> linux32-1.0.ebuild: initial
+ ebuild.
diff --git a/sys-apps/linux32/Manifest b/sys-apps/linux32/Manifest
new file mode 100644
index 000000000000..6baaaf718517
--- /dev/null
+++ b/sys-apps/linux32/Manifest
@@ -0,0 +1,3 @@
+MD5 71492697c714ffe08477abf13bb3a83f linux32-1.0.ebuild 714
+MD5 14884256e35061947235ee5f157a2d7c ChangeLog 244
+MD5 c5a46361e6c1f30e842435a34749acd8 files/digest-linux32-1.0 61
diff --git a/sys-apps/linux32/files/digest-linux32-1.0 b/sys-apps/linux32/files/digest-linux32-1.0
new file mode 100644
index 000000000000..87d826941b53
--- /dev/null
+++ b/sys-apps/linux32/files/digest-linux32-1.0
@@ -0,0 +1 @@
+MD5 7785583580d8c6e82d882c83d0647fb9 linux32-1.0.tar.gz 8412
diff --git a/sys-apps/linux32/linux32-1.0.ebuild b/sys-apps/linux32/linux32-1.0.ebuild
new file mode 100644
index 000000000000..2ab18965f955
--- /dev/null
+++ b/sys-apps/linux32/linux32-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux32/linux32-1.0.ebuild,v 1.1 2003/07/13 22:55:22 drobbins Exp $
+
+DESCRIPTION="A utility that allows AMD64 code to run in an environment so that the uname() call returns non-AMD64-specific info"
+HOMEPAGE="ftp://ftp.x86-64.org/pub/linux-x86_64/tools/linux32/"
+SRC_URI="mirror://${P}.tar.gz"
+SLOT="0"
+KEYWORDS="-* amd64"
+LICENSE="GPL-2"
+
+src_compile() {
+ cd ${S}
+ gcc ${CFLAGS} linux32.c -o linux32
+}
+
+src_install() {
+ into /
+ dobin ${S}/linux32
+ ln -s linux32 ${D}/bin/linux64
+ doman ${S}/linux32.1
+ ln -s linux32.1.gz ${D}/usr/share/man/man1/linux64.1.gz
+ dodoc ${S}/README
+}