summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Jackson <mjolnir@gentoo.org>2007-02-10 06:57:47 +0000
committerMartin Jackson <mjolnir@gentoo.org>2007-02-10 06:57:47 +0000
commit883879dab3560dfb6c7155b9b6565998c2c1a780 (patch)
tree1aebd0df61e7d8208d3e4ce25c96b89b58158df2
parentChanged dependencies wrt udev and hotplug. Thanks to Jakub Moc for reporting... (diff)
downloadgentoo-2-883879dab3560dfb6c7155b9b6565998c2c1a780.tar.gz
gentoo-2-883879dab3560dfb6c7155b9b6565998c2c1a780.tar.bz2
gentoo-2-883879dab3560dfb6c7155b9b6565998c2c1a780.zip
Add patch to help with GCC 3.4 issues
(Portage version: 2.1.1-r2)
-rw-r--r--net-analyzer/wireshark/ChangeLog7
-rw-r--r--net-analyzer/wireshark/files/wireshark-epan_dissectors_packet-diameter.diff19
-rw-r--r--net-analyzer/wireshark/wireshark-0.99.5.ebuild3
3 files changed, 27 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 1934e67d6f7e..f1105ed5e44d 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.44 2007/02/03 23:59:28 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.45 2007/02/10 06:57:47 mjolnir Exp $
+
+ 10 Feb 2007; Martin Jackson <mjolnir@gentoo.org>
+ +files/wireshark-epan_dissectors_packet-diameter.diff,
+ wireshark-0.99.5.ebuild:
+ Add patch from FC3/FreeBSD to fix GCC 3.4 link error (#165340)
*wireshark-0.99.5 (03 Feb 2007)
diff --git a/net-analyzer/wireshark/files/wireshark-epan_dissectors_packet-diameter.diff b/net-analyzer/wireshark/files/wireshark-epan_dissectors_packet-diameter.diff
new file mode 100644
index 000000000000..e71aaba61516
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-epan_dissectors_packet-diameter.diff
@@ -0,0 +1,19 @@
+--- dissectors/packet-diameter.c.orig Thu May 12 03:07:06 2005
++++ dissectors/packet-diameter.c Thu May 12 02:54:14 2005
+@@ -2022,13 +2022,13 @@
+ { "Flags", "diameter.flags", FT_UINT8, BASE_HEX, NULL, 0x0,
+ "", HFILL }},
+ { &hf_diameter_flags_request,
+- { "Request", "diameter.flags.request", FT_BOOLEAN, 8, TFS(&flags_set_truth), DIAM_FLAGS_R,
++ { "Request ", "diameter.flags.request", FT_BOOLEAN, 8, TFS(&flags_set_truth), DIAM_FLAGS_R,
+ "", HFILL }},
+ { &hf_diameter_flags_proxyable,
+- { "Proxyable", "diameter.flags.proxyable", FT_BOOLEAN, 8, TFS(&flags_set_truth), DIAM_FLAGS_P,
++ { "Proxyable ", "diameter.flags.proxyable", FT_BOOLEAN, 8, TFS(&flags_set_truth), DIAM_FLAGS_P,
+ "", HFILL }},
+ { &hf_diameter_flags_error,
+- { "Error","diameter.flags.error", FT_BOOLEAN, 8, TFS(&flags_set_truth), DIAM_FLAGS_E,
++ { "Error ","diameter.flags.error", FT_BOOLEAN, 8, TFS(&flags_set_truth), DIAM_FLAGS_E,
+ "", HFILL }},
+ { &hf_diameter_flags_T,
+ { "T(Potentially re-transmitted message)","diameter.flags.T", FT_BOOLEAN, 8, TFS(&flags_set_truth),DIAM_FLAGS_T,
diff --git a/net-analyzer/wireshark/wireshark-0.99.5.ebuild b/net-analyzer/wireshark/wireshark-0.99.5.ebuild
index e808b72f82ad..474a2b325968 100644
--- a/net-analyzer/wireshark/wireshark-0.99.5.ebuild
+++ b/net-analyzer/wireshark/wireshark-0.99.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-0.99.5.ebuild,v 1.1 2007/02/03 23:59:28 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-0.99.5.ebuild,v 1.2 2007/02/10 06:57:47 mjolnir Exp $
inherit libtool flag-o-matic eutils autotools
@@ -58,6 +58,7 @@ src_unpack() {
unpack ${A}
cd "${S}"/epan
epatch "${FILESDIR}"/wireshark-except-double-free.diff
+ epatch "${FILESDIR}"/wireshark-epan_dissectors_packet-diameter.diff
}
src_compile() {