summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-07-20 11:59:52 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-07-20 11:59:52 +0000
commit9147098cddebdf444c442a43971915ac2e13995a (patch)
treef5dbc7770cfe7f20fa31e0720617d57378534187
parentFix desktop files, bug 185869 and now it uses the langpack according to the l... (diff)
downloadgentoo-2-9147098cddebdf444c442a43971915ac2e13995a.tar.gz
gentoo-2-9147098cddebdf444c442a43971915ac2e13995a.tar.bz2
gentoo-2-9147098cddebdf444c442a43971915ac2e13995a.zip
Minor changes
(Portage version: 2.1.3_rc8)
-rw-r--r--www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.5.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.5.ebuild b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.5.ebuild
index df1ccb364ec3..4b370d9d0078 100644
--- a/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.5.ebuild
+++ b/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.5.ebuild,v 1.3 2007/07/20 10:08:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox-bin/mozilla-firefox-bin-2.0.0.5.ebuild,v 1.4 2007/07/20 11:59:52 armin76 Exp $
inherit eutils mozilla-launcher multilib mozextension
@@ -71,18 +71,23 @@ src_install() {
touch ${S}/extensions/talkback@mozilla.org/chrome.manifest
mv ${S} ${D}${MOZILLA_FIVE_HOME}
+ # Install langpacks
for X in ${A}; do
[[ ${X} == *.xpi ]] && xpi_install "${WORKDIR}"/${X%.xpi}
done
+ # Use a langpack depending on the system locale
+ for i in ${D}/"${MOZILLA_FIVE_HOME}"/greprefs/all-gentoo.js \
+ ${D}"${MOZILLA_FIVE_HOME}"/defaults/pref/all-gentoo.js; do
+ echo 'pref("intl.locale.matchOS", true);' >> $i
+ done
+
# Create /usr/bin/firefox-bin
install_mozilla_launcher_stub firefox-bin ${MOZILLA_FIVE_HOME}
# Install icon and .desktop for menu entry
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/icon/${PN}-icon.png
- insinto /usr/share/applications
- doins ${FILESDIR}/icon/${PN}.desktop
+ doicon ${FILESDIR}/icon/${PN}-icon.png
+ domenu ${FILESDIR}/icon/${PN}.desktop
# revdep-rebuild entry
insinto /etc/revdep-rebuild
@@ -90,11 +95,6 @@ src_install() {
# install ldpath env.d
doenvd ${FILESDIR}/71firefox-bin
-
- for i in ${D}/"${MOZILLA_FIVE_HOME}"/greprefs/all-gentoo.js \
- ${D}"${MOZILLA_FIVE_HOME}"/defaults/pref/all-gentoo.js; do
- echo 'pref("intl.locale.matchOS", true);' >> $i
- done
}
pkg_preinst() {
@@ -106,11 +106,7 @@ pkg_preinst() {
}
pkg_postinst() {
- if use amd64; then
- echo
- einfo "NB: You just installed a 32-bit firefox"
- fi
-
+ use amd64 && einfo "NB: You just installed a 32-bit firefox"
update_mozilla_launcher_symlinks
}