summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 21:48:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 21:48:54 +0000
commit931f26ade5d1dbc82894d0e4fe78b2c074154393 (patch)
tree448e2143abb5203f62bfbbba6ad9439b472ff636
parentRemove unused file. (diff)
downloadgentoo-2-931f26ade5d1dbc82894d0e4fe78b2c074154393.tar.gz
gentoo-2-931f26ade5d1dbc82894d0e4fe78b2c074154393.tar.bz2
gentoo-2-931f26ade5d1dbc82894d0e4fe78b2c074154393.zip
Remove unused file. Cleanup old version.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-ruby/ruby-prof/ChangeLog6
-rw-r--r--dev-ruby/ruby-prof/files/ruby-prof-0.7.2+glibc-2.8.patch13
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild67
3 files changed, 5 insertions, 81 deletions
diff --git a/dev-ruby/ruby-prof/ChangeLog b/dev-ruby/ruby-prof/ChangeLog
index 98971fc4fae3..5e885bfad1d2 100644
--- a/dev-ruby/ruby-prof/ChangeLog
+++ b/dev-ruby/ruby-prof/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-prof
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.27 2010/08/08 18:03:58 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ChangeLog,v 1.28 2010/08/21 21:48:54 flameeyes Exp $
+
+ 21 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -files/ruby-prof-0.7.2+glibc-2.8.patch, -ruby-prof-0.8.2.ebuild:
+ Remove unused file. Cleanup old version.
*ruby-prof-0.8.2-r1 (08 Aug 2010)
diff --git a/dev-ruby/ruby-prof/files/ruby-prof-0.7.2+glibc-2.8.patch b/dev-ruby/ruby-prof/files/ruby-prof-0.7.2+glibc-2.8.patch
deleted file mode 100644
index 53f478afb4de..000000000000
--- a/dev-ruby/ruby-prof/files/ruby-prof-0.7.2+glibc-2.8.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ruby-prof-0.7.2/ext/measure_cpu_time.h
-===================================================================
---- ruby-prof-0.7.2.orig/ext/measure_cpu_time.h
-+++ ruby-prof-0.7.2/ext/measure_cpu_time.h
-@@ -33,6 +33,8 @@ static unsigned long long cpu_frequency;
-
- #if defined(__GNUC__)
-
-+#include <stdint.h>
-+
- static prof_measure_t
- measure_cpu_time()
- {
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild
deleted file mode 100644
index 1b44a678afe4..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-prof/ruby-prof-0.8.2.ebuild,v 1.1 2010/07/12 06:03:56 graaff Exp $
-
-EAPI=2
-
-# jruby → not compatible, since it uses an extension
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_EXTRADOC="README CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="http://rubyforge.org/projects/ruby-prof/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # The thread testing in 0.8.1 and earlier versions is broken, it
- # has to be tested for the next versions, since upstream is
- # looking for a solution. The problem is that it's _very_
- # timing-dependent.
- rm "${S}"/test/thread_test.rb \
- || die "unable to remove broken test unit"
- sed -i -e '/thread_test/d' \
- test/test_suite.rb || die "unable to remove broken test reference"
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # On ruby 1.9 this test fails badly, so we disable it
- # until upstream can fix the related bug:
- # http://redmine.ruby-lang.org/issues/show/2012
- sed -i -e '/^ def test_flat_string_with_numbers/,/^ end/ s:^:#:' \
- test/printers_test.rb || die "Unable to disable test_flat_string_with_numbers"
- ;;
- esac
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- # gem ships with prebuild files
- emake -Cext/ruby_prof clean || die "clean failed"
- emake -Cext/ruby_prof || die "build failed"
-
- cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- for dir in examples rails rails/example rails/environment; do
- docinto "$dir"
- dodoc "$dir"/* || die "dodoc $dir failed"
- done
-}