summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-06-01 13:19:38 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-06-01 13:19:38 +0000
commit95d2680b02c20517fe6483af708044ca15764d8f (patch)
treeac5e2fceba6d42fa5e5a20e55244b2ecf5a7eecc
parentVersion bump wrt bug #416809. (diff)
downloadgentoo-2-95d2680b02c20517fe6483af708044ca15764d8f.tar.gz
gentoo-2-95d2680b02c20517fe6483af708044ca15764d8f.tar.bz2
gentoo-2-95d2680b02c20517fe6483af708044ca15764d8f.zip
The 4.13 has bug which is workarounded in the 4.14, therefore removing the
older version. (Portage version: 2.1.10.63/cvs/Linux x86_64)
-rw-r--r--dev-python/pyro/ChangeLog7
-rw-r--r--dev-python/pyro/pyro-4.13.ebuild86
2 files changed, 6 insertions, 87 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index 6e5370e542ab..24305ab833e6 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.68 2012/06/01 13:16:04 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.69 2012/06/01 13:19:38 aidecoe Exp $
+
+ 01 Jun 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> -pyro-4.13.ebuild,
+ pyro-4.11.ebuild:
+ The 4.13 has bug which is workarounded in the 4.14, therefore removing the
+ older version.
*pyro-4.14 (01 Jun 2012)
diff --git a/dev-python/pyro/pyro-4.13.ebuild b/dev-python/pyro/pyro-4.13.ebuild
deleted file mode 100644
index be728cf118ec..000000000000
--- a/dev-python/pyro/pyro-4.13.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.13.ebuild,v 1.1 2012/04/19 09:04:18 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45]"
-
-inherit distutils
-
-MY_PN="Pyro4"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="!dev-python/pyro:0"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? (
- dev-python/coverage
- dev-python/nose
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="Pyro4"
-
-src_prepare() {
- distutils_src_prepare
-
- sed -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' -i tests/run_suite.py
-
- # Disable tests requiring network connection.
- sed \
- -e "s/testBCstart/_&/" \
- -e "s/testDaemonPyroObj/_&/" \
- -e "s/testLookupAndRegister/_&/" \
- -e "s/testMulti/_&/" \
- -e "s/testRefuseDottedNames/_&/" \
- -e "s/testResolve/_&/" \
- -i tests/PyroTests/test_naming.py
- sed \
- -e "s/testOwnloopBasics/_&/" \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/test_naming2.py
-
- sed \
- -e "s/testServerConnections/_&/" \
- -e "s/testServerParallelism/_&/" \
- -i tests/PyroTests/test_server.py
-
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -i tests/PyroTests/test_socket.py
-}
-
-src_test() {
- cd tests
-
- testing() {
- "$(PYTHON)" run_suite.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}