summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-10 15:13:50 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-10 15:13:50 +0000
commita093dd62a5e749031385953a4b2991b69bc30e91 (patch)
tree29da683bb3abee7641a384dba4f73bdde40b7c5b
parentAdd further missing includes (diff)
downloadgentoo-2-a093dd62a5e749031385953a4b2991b69bc30e91.tar.gz
gentoo-2-a093dd62a5e749031385953a4b2991b69bc30e91.tar.bz2
gentoo-2-a093dd62a5e749031385953a4b2991b69bc30e91.zip
remove Werror wrt #456654
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
-rw-r--r--games-arcade/frozen-bubble/ChangeLog9
-rw-r--r--games-arcade/frozen-bubble/files/frozen-bubble-2.2.1_beta1-Werror.patch15
-rw-r--r--games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild9
3 files changed, 29 insertions, 4 deletions
diff --git a/games-arcade/frozen-bubble/ChangeLog b/games-arcade/frozen-bubble/ChangeLog
index c7ddeae3bd88..196f4e696926 100644
--- a/games-arcade/frozen-bubble/ChangeLog
+++ b/games-arcade/frozen-bubble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/frozen-bubble
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/ChangeLog,v 1.51 2012/10/22 04:09:37 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/ChangeLog,v 1.52 2013/02/10 15:13:50 hasufell Exp $
+
+ 10 Feb 2013; Julian Ospald <hasufell@gentoo.org>
+ frozen-bubble-2.2.1_beta1.ebuild,
+ +files/frozen-bubble-2.2.1_beta1-Werror.patch:
+ remove Werror wrt #456654
22 Oct 2012; Michael Sterrett <mr_bones_@gentoo.org>
frozen-bubble-2.2.1_beta1.ebuild:
diff --git a/games-arcade/frozen-bubble/files/frozen-bubble-2.2.1_beta1-Werror.patch b/games-arcade/frozen-bubble/files/frozen-bubble-2.2.1_beta1-Werror.patch
new file mode 100644
index 000000000000..d891d8e71a63
--- /dev/null
+++ b/games-arcade/frozen-bubble/files/frozen-bubble-2.2.1_beta1-Werror.patch
@@ -0,0 +1,15 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Feb 10 14:48:58 UTC 2013
+Subject: remove Werror compiler flag wrt #456654
+
+--- inc/My/Builder.pm
++++ inc/My/Builder.pm
+@@ -123,7 +123,7 @@
+ push @ofiles, $cbuilder->compile(
+ source => catfile($server_directory, $cfile),
+ extra_compiler_flags => [
+- qw(-g -Wall -Werror -pipe), # verbatim from Makefile
++ qw(-Wall), # verbatim from Makefile
+ '-I' . $server_directory, # does not seem to be necessary
+ $cbuilder->split_like_shell(`pkg-config glib-2.0 --cflags`),
+ $cbuilder->split_like_shell(`pkg-config glib-2.0 --libs`),
diff --git a/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild b/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild
index c21a1d050b5a..b18ced96ddd8 100644
--- a/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild
+++ b/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild,v 1.8 2012/10/22 04:09:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1.ebuild,v 1.9 2013/02/10 15:13:50 hasufell Exp $
EAPI=2
@@ -42,6 +42,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ perl-module_src_prepare
+ epatch "${FILESDIR}"/${P}-Werror.patch
+}
+
src_configure() {
LD=$(tc-getCC) perl-module_src_configure
}