summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-06-01 22:27:37 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-06-01 22:27:37 +0000
commita58b26e74502612c85c5e26136fe7549776c664f (patch)
tree54d37b0e7ff9776ff89e85bb5a092979b5691ce4
parentstable (diff)
downloadgentoo-2-a58b26e74502612c85c5e26136fe7549776c664f.tar.gz
gentoo-2-a58b26e74502612c85c5e26136fe7549776c664f.tar.bz2
gentoo-2-a58b26e74502612c85c5e26136fe7549776c664f.zip
respect GAMES variables wrt #494202, install icon and desktop file wrt #494224
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
-rw-r--r--games-simulation/crrcsim/ChangeLog9
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.12-r1.ebuild (renamed from games-simulation/crrcsim/crrcsim-0.9.12.ebuild)27
-rw-r--r--games-simulation/crrcsim/files/crrcsim-buildsystem.patch10
3 files changed, 41 insertions, 5 deletions
diff --git a/games-simulation/crrcsim/ChangeLog b/games-simulation/crrcsim/ChangeLog
index cede1eb32658..1075260e32ed 100644
--- a/games-simulation/crrcsim/ChangeLog
+++ b/games-simulation/crrcsim/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-simulation/crrcsim
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/ChangeLog,v 1.9 2014/05/15 16:59:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/ChangeLog,v 1.10 2014/06/01 22:27:36 hasufell Exp $
+
+*crrcsim-0.9.12-r1 (01 Jun 2014)
+
+ 01 Jun 2014; Julian Ospald <hasufell@gentoo.org> -crrcsim-0.9.12.ebuild,
+ +crrcsim-0.9.12-r1.ebuild, files/crrcsim-buildsystem.patch:
+ respect GAMES variables wrt #494202, install icon and desktop file wrt
+ #494224
15 May 2014; Ulrich Müller <ulm@gentoo.org> crrcsim-0.9.12.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
diff --git a/games-simulation/crrcsim/crrcsim-0.9.12.ebuild b/games-simulation/crrcsim/crrcsim-0.9.12-r1.ebuild
index 5681f9bebfc2..28a6d2779779 100644
--- a/games-simulation/crrcsim/crrcsim-0.9.12.ebuild
+++ b/games-simulation/crrcsim/crrcsim-0.9.12-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/crrcsim-0.9.12.ebuild,v 1.4 2014/05/15 16:59:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/crrcsim-0.9.12-r1.ebuild,v 1.1 2014/06/01 22:27:36 hasufell Exp $
-EAPI=4
+EAPI=5
WANT_AUTOMAKE="1.10"
-inherit autotools eutils games
+inherit autotools eutils gnome2-utils games
DESCRIPTION="model-airplane flight simulation program"
HOMEPAGE="http://sourceforge.net/projects/crrcsim/"
@@ -30,12 +30,31 @@ src_prepare() {
}
src_configure() {
- econf --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ egamesconf \
+ --datarootdir="${EPREFIX%/}/usr/share" \
+ --datadir="${GAMES_DATADIR}" \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
$(use_with portaudio)
}
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS HISTORY NEWS README
+ doicon -s 32 packages/icons/${PN}.png
+ make_desktop_entry ${PN}
prepgamesdirs
}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-simulation/crrcsim/files/crrcsim-buildsystem.patch b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
index 774a19379ef8..3bc784d16bd7 100644
--- a/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
+++ b/games-simulation/crrcsim/files/crrcsim-buildsystem.patch
@@ -13,3 +13,13 @@
if (test "x$ac_cv_header_portaudio_h" = "xyes"); then
dnl Check for Portaudio 18
+--- crrcsim-0.9.12/locale/Makefile.am
++++ crrcsim-0.9.12/locale/Makefile.am
+@@ -1,7 +1,5 @@
+ # Makefile.am for "/locale"
+
+-localedir = $(datadir)/locale
+-
+ nobase_locale_DATA = fr/LC_MESSAGES/crrcsim.mo \
+ de/LC_MESSAGES/crrcsim.mo \
+ it/LC_MESSAGES/crrcsim.mo